Neat Image

standalone application (Win)

*To make images look better.*

User guide

Document version 9.1, 20-Sep-2023
# Table of contents

1 Introduction
  1.1 Overview ................................................. 4
  1.2 Features ................................................. 4
  1.3 Requirements ............................................. 5

2 Key concepts
  2.1 What it can do – functionality of Neat Image .................. 7
  2.2 When it works – types of input images ........................ 7

3 Filtration process overview
  3.1 Overview of Neat Image filtration process ....................... 8
  3.2 Running Neat Image on a sample image ........................ 9

4 Filtration process details
  4.1 Stage I. Open an input image ............................... 11
  4.2 Stage II. Prepare a device noise profile ....................... 12
  4.3 Stage III. Adjust filter settings ........................... 17
  4.4 Stage IV (a). Beginner Mode ................................ 17
  4.5 Stage IV (b). Advanced Mode ................................ 20
  4.6 Stage V. Save filter settings into a preset (optional) ........ 27
  4.7 Stage VI. Apply filter to the input image ................... 28
  4.8 Stage VII. Save the output image ........................... 28

5 Device noise profiles
  5.1 Getting ready-made noise profiles .......................... 29
  5.2 Building a profile for a device mode (standard profiling procedure) ................................. 29
  5.3 Preparing profile set for different device modes ................ 37
  5.4 Using noise profiles ....................................... 42

6 Additional tools
  6.1 Variants of filtration ....................................... 44
  6.2 Alternative modes of image viewer .......................... 45
  6.3 Navigator .................................................... 45
  6.4 Profile Viewer ............................................... 46

7 Batch processing
  7.1 All Tasks tab ............................................... 47
  7.2 Creating new image filtration tasks .......................... 48
  7.3 Configuring image filtration tasks ........................... 50
  7.4 Processing image filtration tasks ........................... 51
  7.5 Reviewing processing results ................................ 52
  7.6 Saving output images ....................................... 52
  7.7 Removing image filtration tasks ............................. 53

8 Preferences
  8.1 General preferences ......................................... 54
  8.2 Defaults ..................................................... 55
  8.3 Profiling preferences ....................................... 56
  8.4 Matching preferences ....................................... 56
  8.5 Filtration preferences ...................................... 57
  8.6 Performance preferences .................................... 58
  8.7 Folder preferences .......................................... 59
  8.8 Output preferences .......................................... 60

9 Command line version ........................................... 62

10 Using Neat Image with Lightroom ............................. 63
1. Introduction

1.1. Overview

Neat Image is an image filter designed to reduce visible noise and grain in digital photographic images. Neat Image detects, analyzes and reduces noise. It incorporates the most advanced image noise reduction algorithms in the industry. The filtration quality is higher than that of other methods because Neat Image takes into account noise characteristics of particular image acquisition devices, making the filtration more accurate. Using device noise profiles, Neat Image adapts its noise reduction to almost any input device – digital camera, scanner, etc.

The rich control set of the noise filter allows you to easily achieve the desired level of noise reduction. In addition, Neat Image can make images look sharper without degradation of image quality (which is usually inevitable with noisy images). Smart application of sharpening based on preceding noise analysis makes that possible.

Neat Image standalone (Win) is currently produced in three editions: Demo, Home and Pro. All editions provide top-quality noise reduction and sharpening. The key differences are the following:

- Demo is a freeware edition of the software with limited functionality
- Home edition supports 8-bit images and limited batching (up to 100 images in one batch)
- Pro edition supports 8-bit, 16-bit and 32-bit images and unlimited batching

1.2. Features

**Noise Reduction and Smart Sharpening**

- Advanced noise filters to reduce noise and grain in digital images
- Complete control over the filter settings to achieve the desired level of noise reduction
- Smart sharpening filter to make images look sharper without amplification of noise
- 8-bit, 16-bit and 32-bit image support to fully utilize capabilities of modern image acquisition devices and support HDR post-processing workflows
- CUDA and OpenCL acceleration to speed up processing using computation-capable GPUs

**Device Noise Profiles**

- Auto Profile to build noise profiles for your camera or scanner using samples of noise
- Generic Profile function to create custom profiles without using noise samples
- Rich set of pre-built noise profiles in the online profile library
- Auto Match to select the most suitable pre-built noise profiles
- Batch profiler to automate profiling with the Calibration Target

**Batch Processing**

- Batch functionality to process many images automatically
- Background processing: while multiple images are processed in background, you can prepare new images in Neat Image or work in another application
**Preview**

- **Embedded preview** for any selected image area
- Preview of filtration results separately for each **channel** and **frequency component**

Some features are only available in the Home or Pro edition. Detailed feature map (page 70) explains the differences between Neat Image Demo, Home and Pro editions in details.

### 1.3. Requirements

#### 1.3.1. System requirements

System requirements for practical use of Neat Image depend on size of input images. The more system RAM is available the larger the images that can be handled. The processing speed is determined primarily by the processor’s number-crunching power (clock frequency, number of cores/processors, cache size), memory speed and availability of supported computation-capable GPUs.

- Intel x64 or AMD x64 series processor, single or multi-processor
- Windows 11, 10, 8, 7; 64-bit

Optional CUDA acceleration requires:

- CUDA-capable NVIDIA GPU with compute capability 3.5 or higher
- Recent video driver supporting CUDA 9 or newer
Optional OpenCL acceleration requires:

* Supported AMD video card:
  - AMD Radeon HD 7790;
  - AMD Radeon R7 260/260X/360;
  - AMD Radeon R9 285/285X/290/290X/295X2;
  - AMD Radeon R9 380/380X/390/390X;
  - AMD Radeon R9 Fury, R9 Nano, R9 Fury X, Pro Duo;
  - AMD Radeon RX 460/470/480;
  - AMD Radeon RX 540/540X/550/550X/560/570/580;
  - AMD Radeon RX Vega 56/64;
  - AMD Radeon Vega Frontier Edition;
  - AMD Radeon RX 5300M/5500/5500M;
  - AMD Radeon RX 5600/5600M/5600 XT/5700/5700M/5700 XT;
  - AMD Radeon RX 6600/6600 XT;
  - AMD Radeon RX 6700 XT/6800/6800 XT/6900 XT;
  - AMD Radeon RX 7900 XT/7900 XTX;
  - AMD Radeon Pro WX 2100/3100/4100/5100/7100/9100;
  - AMD Radeon VII;
  - Another AMD GPU based on one of the following chip series: Bonaire, Hawaii, Tonga, Fiji, Ellesmere, Baffin, gfx804, gfx900, gfx901, gfx906, gfx907, gfx90c, gfx1010, gfx1012, gfx1030, gfx1031, gfx1032, gfx1100

* The latest version of AMD Adrenalin driver.

If you experience a problem with the latest version of the driver, please check the known issues page for possible solutions:

https://ni.neatvideo.com/support/known-issues

You can download the latest and archive versions of AMD Driver from

https://www.amd.com/en/support

### 1.3.2. Supported types of images

Neat Image supports the following formats of input images (the same formats are supported to save output images):

* **TIFF (single image, no layers, no mask)**
  
  8/16/32-bit per channel
  
  RGB and grayscale

* **JPEG**
  
  8-bit per channel
  
  RGB and grayscale

* **PNG**
  
  8/16-bit per channel
  
  RGB and grayscale

* **BMP (uncompressed, Win3x)**
  
  8-bit per channel
  
  RGB

RAW images can be processed after they are converted to TIFFs (using TIFF is recommended to avoid quality loss due to compression) or to JPEGs (this involves quality loss, because JPEG is a lossy format).

Color input images are supposed to be in RGB representation, for example, AdobeRGB, sRGB, etc. Neat Image will preserve the representation in the output image (it will use the same color space).

The minimum size of an input image is 40x40 pixels; the maximum size is usually limited by the amount of system RAM available.

---

1 There are some limitations in the Demo edition. Please see Detailed feature map, page 70, for more information.
2. Key concepts

2.1. What it can do – functionality of Neat Image

Neat Image is a digital image filter. Its main function is to reduce noise in digital images.

Neat Image can work with images produced by any imaging devices – digital cameras, scanners, etc. Neat Image can be adjusted to a particular device by means of a device noise profile, which describes the noise characteristics of the device.

A device noise profile is built by analyzing featureless areas of an image – areas that contain no visible or important details and show only noise. Usually, the software can find such featureless areas completely automatically. In a difficult case, you can assist it and select a featureless area manually. Finding such areas is very easy for human eyes but may sometimes be a bit difficult for computer software.

By analyzing those featureless areas, the Auto Profile function builds a profile which describes the properties of the noise contained there. Using such a profile, Neat Image’s noise filter can then efficiently reduce noise in the whole image.

When you have several such noise profiles for different device modes (for example, different ISO rates), the Auto Match function can automatically select the profile that matches a given input image. In this way, you can skip noise analysis and simply re-use one of profiles built earlier.

Smart Profile combines the power of Auto Profile and Auto Match by preparing two candidate profiles and then selecting the better one for actual image processing. This helps to achieve great results with less manual assistance.

The noise filter processes images in several spatial frequency ranges. This allows, for example, to accurately reduce noise in one frequency range while fully preserving details that may be present in other frequency ranges. In the same way, the filter can also selectively process the color channels.

In addition to the noise filter, there is the smart sharpening filter, which sharpens only details but not noise, so the noise is not amplified. Combining the noise reduction and sharpening in this way saves processing time and produces better overall results.

2.2. When it works – types of input images

Neat Image is designed to reduce noise in images produced by digital cameras and scanners, and can also be used to process images from other sources. For Neat Image to be efficient, input images should satisfy the following requirements:

- Noise must be uniformly distributed throughout the image, i.e., there should be no strong surges of noise intensity in some areas of the image or significant changes of noise characteristics across the image.

Neat Image works fine, for example, on images with high ISO noise because such noise usually uniformly covers the whole image area. However, ‘hot’ or ‘dead’ pixels (produced by single ‘broken’ elements of image sensor) do not satisfy the uniformity condition and, therefore, are not efficiently removed by Neat Image.

Another frequent source of noise is JPEG compression. The JPEG noise is approximately uniform when high quality setting (low compression rate, larger file size) is used. However, low compression quality makes noise non-uniform. Therefore, we recommend using the highest quality levels whenever possible. Try to avoid visible artifacts (‘squares’ or ‘blocks’ introduced by JPEG compression) in input images beginning from the early stages of image processing. If you can, use lossless file formats such as TIFF.
3. Filtration process overview

3.1. Overview of Neat Image filtration process

When you start Neat Image, the main Neat Image window opens automatically. Then you can take the following steps to process one image:

1. Open an input image
   - the image viewer will display the input image;
   - the information panel will display relevant image data;

2. Prepare a device noise profile – noise analysis necessary to filter the image
   - to build a new profile click the Auto Profile button; this will automatically select and analyze a featureless (noise-only) image area;
   - if you see that automatic selection includes any important image details, then move the selection to an area without details and click the Build Profile button;

Continued on the next page...
3. Adjust the noise filter and sharpening settings to achieve desired level of noise reduction and sharpening

- try to vary the setting:
  Noise Reduction Amounts > Luminance

and see how the preview changes;
- when you are happy with the preview proceed to the next stage;

4. Switch to the Save Output Image tab and let Neat Image process the image;
- when processing is finished, evaluate the resulting output image by comparing it with the input image: click the image to switch to the original for comparison;

5. Save the output image to a file on the hard drive.

3.2. Running Neat Image on a sample image

There is a test-kit prepared to help you start using Neat Image. You can download it using this direct link: https://ni.neatvideo.com/project/resources/testkit9.zip, 2.5 MB. Having downloaded, please unzip it to a new folder on the hard drive.

The test-kit contains a sample image: the SampleImage.jpg file. This is a typical photo taken with a modern digital camera. The detailed information about the image is available in the SampleImageInfo.txt file.

Please start Neat Image and go through the stages below to see how it can improve the image:

Stage I. Open the sample image

1. Click in the toolbar in the Open Input Image tab:

2. In the Select input image(s) dialog, navigate to the folder where the testkit has been unzipped and double click on the SampleImage.jpg file.

Neat Image will open the sample image.

You will see that there is some strong noise in the image (zoom in to better see the noise). This is typical noise produced by a digital camera. The task of Neat Image is to reduce this noise.
Stage II. Build a noise profile using Auto Profile

To reduce noise Neat Image generally needs a noise profile describing the noise properties of the image. It is possible to build such a noise profile using the image itself.

To prepare a noise profile please do the following:

1. In the Prepare Noise Profile tab:  
   click (the Auto Profile button);  
   Auto Profile will try to automatically find and analyze a flat featureless image area that contains only noise and no important details.

2. Visually inspect the image area selected by Auto Profile. The area should contain no visible details, only noise; otherwise the noise profile and subsequent noise reduction may be inaccurate.

   If the selected area does contain any details, move the selection to another area without details or draw a new selection in such an area. Then click the Build Profile button to re-build the profile using the newly selected area (the name of the Auto Profile button will change into Build Profile when you select an area manually).

Once processing is completed, the noise profile is ready and Neat Image can apply its noise reduction to the image.

Stage III. Check preview

1. Switch to the Adjust and Preview tab:  
2. Once preview is automatically prepared, visually evaluate the results of noise reduction.

   You can click the image to quickly switch between original and filtered images for comparison. Zoom in to better see details at 100% zoom level.

3. You can also try to adjust the filter settings a bit. For example, try to vary Noise Reduction Amounts > Luminance control and see how that affects the preview.

Stage IV. Apply the filter

1. Switch to the Save Output Image tab:  
2. Wait until the progress indicator disappears.

Processing may take a few seconds. Then the filtered output image is displayed. Click the output image to compare it with the input image. Zoom in to better see details at 100% zoom level. Notice that the noise has been significantly reduced throughout the image while the image details have been preserved.

You can process your own images in a similar fashion as well. Neat Image can perform noise reduction on images captured or acquired by any digital camera (or scanner) working in any mode. To be able to do that Neat Image needs a device noise profile describing the properties of noise produced by the corresponding device. Neat Image can build such a profile on the fly using the Auto Profile function. Also, you can find ready-made noise profiles for many cameras and scanners in the Profiles section of the Neat Image web page. There is also a way to build a noise profile without using a sample of noise. You will find more details on that later in the document.

The next sections – Filtration process details, page 11, and Device noise profiles, page 29 contain detailed descriptions of the filtration and profiling processes.

There are also examples of profiling and filtration in the Neat Image web page: https://ni.neatvideo.com/support/how-to-use/device-noise-profiling and https://ni.neatvideo.com/examples
4. Filtration process details

Neat Image can be used to filter a single image or to automatically process multiple images. This section describes the single image workflow. Processing multiple images is detailed in the Batch processing section, page 47.

The main window of Neat Image and its Editor tab (see on the right, this will be called Editor in this guide) is usually used to process one image. When you start Neat Image for the very first time, this window opens automatically in the Editor tab:

The filtration process is described below as a sequence of stages that need to be done to process one image.

4.1. Stage I. Open an input image

Use the Open Input Image tab:

To open an input image

- Click (the Open input image button) in the toolbar or use the File > Open Input Image... menu item. Select an image that you want to process. The supported file formats are JPEG, TIFF and PNG (see Requirements, page 5, for more information about supported file formats).
- Drag an image file from the Windows Explorer and drop it to the image viewer in Neat Image.
- Use the Edit > Paste menu item to copy-and-paste an image from another application to Neat Image through the clipboard.

When the input image is ready, the Input Image box (in the right panel) displays the full name of the image. If the image contains the metadata (such as EXIF) then the optional Image Metadata box shows the available details such as camera model, ISO rate, compression and other relevant parameters present in the metadata. Only those parameters are displayed that could be extracted from the input image and that are important for noise reduction.

To scroll and pan the image

- press the middle mouse button and then drag the image using the mouse;
- press the spacebar and the left mouse button and then drag the image using the mouse.

1 Please note that copy and pasting an image does not copy the image metadata (such as EXIF) which may be important for Neat Image noise reduction (in particular, for profile matching). In cases when the image metadata is significant, consider opening an image file manually or drag and drop it instead of copy and pasting via the clipboard.
To change zoom level

- use the mouse wheel when the mouse pointer is over the viewer;
- use the zoom control under the viewer;
- use the Ctrl-Plus, Ctrl-Minus, Ctrl-0 (zero), Ctrl-Alt-0 (zero) keyboard shortcuts.

4.2. Stage II. Prepare a device noise profile

To filter the input image, Neat Image needs to know the characteristics of noise produced by the image acquisition device (digital camera, scanner, etc.) that the image comes from. The noise characteristics of a device working in a certain mode constitute a device noise profile.

There are several ways to prepare a noise profile for the input image:

1. Auto Profile: to build a new profile by analyzing the input image itself (or a specially prepared test image);
2. Generic Profile: to create a new generic profile and manually tune it to the image;
3. Load Profile: to manually select a suitable profile from a pre-built set of profiles (when such a set is available);
4. Auto Match: to automatically select and load the most suitable device noise profile from a pre-built set of profiles (when such a set is available);
5. Smart Profile: to use both Auto Profile and Auto Match (with optional Auto Fine-Tune) to prepare two candidate profiles and then automatically select the better of two profiles.

The first option is often the easiest one provided the input image contains uniform featureless areas that include noise but no visible or important details. Auto Profile will try to automatically find such image areas and analyze them to build a noise profile. When the image does contain featureless areas, this automatic way of preparing a noise profile is the most accurate and therefore recommended. If the input image includes no such areas, then another image with featureless areas can be used to build a profile (provided both images come from the same source and therefore contain the noise with the same properties). Alternatively, a generic profile can be created and used instead.

Auto Profile and Generic Profile are often the simplest and fastest ways to prepare a noise profile, so below these methods are described first.

The options Auto Match, Smart Profile and Load Profile are only available if you already have a pre-built set of profiles. You can prepare such a set yourself or find some profile sets built by other users of the same camera or scanner. You can find more information about profiles and profiling in the Device noise profiles section, page 29.

Auto Profile: build a new profile using Auto Profile

I. Build a new profile using Auto Profile

1. Make sure you have switched to the Prepare Noise Profile tab:

2. Click (the Auto Profile button) in the toolbar, or use the Profile > Auto Profile with Regular Image menu item, or press F2.

Auto Profile function will find and select an area for main analysis. Neat Image will then automatically analyze the noise in that area to build a new noise profile. It will then analyze the rest of the image as well, but the most important part of the analysis is the area highlighted by the selection. Which is why it is important to visually control that area selected by Auto Profile.

3. Once Auto Profile selects the area used for analysis, please visually inspect it to verify that the area does indeed satisfy the following requirements (recommended to achieve the best results):

   • The area should contain visible noise;

---

1 You can see some examples of featureless image areas in the Examples section, page 64.
• The noise should look typical/representative for the current image;
• The noise should be the strongest among all such areas present in this image
  (you can use the noise strength indicator shown over the selection to check that);
• The area should contain no scene details of any kind (objects, textures, gradients, etc.);
• The area should not be very dark (near black) nor very bright (near white);
• The area should be as large as possible in that image.

Auto Profile tries to automatically find an area that satisfies these requirements but that may be
not always possible to achieve. In difficult cases, it may be not able to find a large enough area or
area without details. You will then notice that the selected area, for example, contains some details
or has some other issues. In such cases, Neat Image also warns you that the area may be not very
suitable for analysis. It may say that the selected area is not uniform in one or more channels, or is
small, or contains too weak noise or clipping in some channels.

If you receive such a warning about possible non-uniformity, clipping, small size of the area, etc.,
then you generally have two options:

• You can choose to ignore the warning and proceed using the area found by Auto Profile.
  However, the accuracy of the resulting noise profile may be lower than it could in principle
  be with that image. Technically, the filter will still work but the quality of the results may be
  lower.

• You can try to resolve the reported issue: manually move the selection (or resize, or draw
  a new one) to another area that does not have that problem (does not contain any visible
details, contains stronger noise, is larger, etc.) and then click [Build Profile button] to re-build the profile using the newly selected area.

To visually inspect areas found by Auto Profile and to manually find the most suitable areas, use
the YCrCb+ mode of the image viewer. It helps to better see any weak details that may be present
in the candidate image areas. The YCrCb+ mode emphasizes the weak details and noise present in
Luminance (Y), Cr and Cb channels, as shown in the example below:

The top image shows the original picture where details around the sun are barely visible, while
the channels in the bottom part display the image data in such a way as to emphasize those weak
details. That helps to visually verify that the selected area contains no useful details, which is very
important for accurate noise analysis.

1 The Auto Profile button will change its name to Build Profile in this situation when the selection is added manually or moved.
II. Tune the profile using Profile Check (optional)

After you have built the profile, you can visually check its accuracy and additionally tune it using a special preview mode and tuning controls. To do that please follow these steps:

1. Make sure the zoom level of the preview is set to 100-200%. Set the viewer mode to YCrCb+

2. Click [Profile Check] (the Profile Check button) in the toolbar.

   **Profile Check** will enable a special preview mode that shows the results of noise reduction being applied using the current profile in such a way as to emphasize the areas of the image where the noise is not sufficiently reduced.

   **Profile Check** intentionally applies stronger noise reduction so some details may be lost or look plastic in that preview, but that should not cause a big concern at this point.

   What is important at this point is to make sure the noise is sufficiently reduced in large empty areas within the image as well as on edges of those areas and edges of objects.

   If you see that such large empty areas or edges are not sufficiently cleaned in the Luminance (Y) channel\(^1\), then try the following measures:

   - If the remaining noise is present along edges of objects, then increase the Noise Level setting (or Noise Level > Luminance setting available in Advanced Mode) until those noise elements disappear in preview. Be careful, do not increase the Noise Level settings higher than what is needed to remove the remaining noise;
   - If the remaining noise occupies large space in empty areas, then you can simply re-build the profile using a noise sample from such an area (select it and click Build Profile);
   - If the remaining noise occupies a small area, then you can also use manual Fine-Tune on a sample of that noise (this is available in Advanced Mode only; using Fine-Tune is described in the Device noise profiles section, page 29).

3. Check preview in the chrominance (color) channels Cr and Cb (this is only available in Advanced Mode). If there is any remaining noise in those channels, then try to increase the corresponding Noise Level settings: Cr and Cb.

4. After the profile is built and tuned, check the Quality indicator in the Device Noise Profile box. A profile built using a large uniform and featureless area will usually show a high value in that indicator. That is not strictly necessary, but it is usually good to have a high value (like higher than 60%) there. High values usually lead to more accurate noise reduction.

   If the reported quality is high and you are satisfied that the noise is sufficiently reduced when you check the preview in steps 2-3 above, then you can consider the profile ready and proceed to the next stage: Stage III. Adjust filter settings, page 17.

   If the quality is not high or you clearly see that some noise elements are still present even after tuning, then you may want to re-build the profile using a different area, probably from another image shot in the same camera mode.

   If you cannot find a better area for analysis or cannot build a better noise profile using this method, then consider creating a generic profile as described in the next section.

**Generic Profile: create a generic profile**

There may be some cases when the image you are working with has no featureless areas suitable for building an accurate noise profile, and no pre-built profiles are available for that particular camera. In such cases, you can use the **Generic Profile** function to create a generic noise profile and then tune it to match the noise in your image. You can do that by following these steps:

\(^1\) At this point, check the Luminance (Y) channel only. The other channels will be checked a bit later.
I. Create a new generic profile

- Click  (the Generic Profile button).

   Generic Profile will create a new generic noise profile and that profile is then automatically loaded into this instance of Neat Image filter.

II. Tune the profile to the image

   Generic Profile creates a profile with the default noise strength that may be not right for your image and so you will most likely need to adjust it to match the actual noise present in the image.

   To help you do that, Generic Profile will open the Profile Check and Tuning section in the Device Noise Profile panel and will automatically enable the preview mode showing the results of noise reduction based on the current profile. It will help to see where the noise is not sufficiently reduced.

   - Adjust the Generic Noise setting in the Profile Check and Tuning section to make the noise fully reduced in preview, while keeping the details mostly preserved. Set it to the lowest number that is still able to reduce all noise but do not go any higher.

   The preview intentionally applies stronger noise reduction so some details may be damaged or look plastic there, but that should not cause a big concern at this point (the final results will look better).

   What is important at this point is to make sure the noise is sufficiently reduced in all areas of the image, especially in areas where the noise is strongest.

III. Further tune the profile to the image (optional)

   You can further tune the profile to the image to better match the noise in individual channels (this is only possible in Advanced Mode). This may help to improve the quality of noise reduction a bit.

   1. Make sure the viewer mode is set to YCrCb+.

   2. Check the Luminance (Y) channel to see if any remaining noise is present there, in different parts of the image. If necessary, adjust the Noise Level > Luminance setting.

   3. Similarly check the Chrominance channels Cr and Cb. If necessary, adjust the Noise Level > Cr and Cb settings.

   4. Once you are satisfied that the noise is sufficiently reduced in all channels, you can consider the profile ready and proceed to the next stage: Stage III. Adjust filter settings, page 17.

Load Profile: manually select a noise profile from a pre-built profile set

This option can be used when you already have a pre-built set of profiles and you want to manually select and load one of them to process the current image.

- Click  (the Load Profile button) or use the Profile > Load Profile... menu item. Then select a profile in the Load Device Noise Profile dialog.

   or

- Click  (the drop-down button) in the Device Noise Profile box to open the popup menu with all available profiles and then select one of the available profiles.

   Please note that you must either build your own profiles or download some pre-built profiles and place them to Neat Image’s Profile folder to make this drop-down button and popup menu truly work. By
default the **Profile folder** is located in your **Documents** folder ¹:

`Documents\Neat Image v9 Standalone\Profiles\`

If you build or download some pre-built profiles, place them to the above folder (unzip the downloaded ZIP archive to that folder). Neat Image will recognize and display those profiles in the popup menu to help you quickly load any of them when needed.

When manually selecting a profile for an input image, use the profile file names and sub-folder structure to guide your search. See Preparing profile set for different device modes: Stage III. Structuring profile set, page 40, for more information on profile set structuring.

**Auto Match: automatically select matching profile from a pre-built profile set**

This option can only be used if you already have a pre-built set of profiles. You can prepare such a set yourself or find some pre-built profile online.

- Click ![Auto Match](image) (the **Auto Match** button) or use the **Profile > Auto Match** menu item.

    The **Auto Match** function uses the EXIF data fields of the input image to automatically select and load the device noise profile that matches the device mode of the image. The most matching profile is selected from all profiles stored in the **Profile folder**. By default, this folder is in your **Documents** folder²:

    `Documents\Neat Image v9 Standalone\Profiles\`

    **Auto Match** will look for matching profiles in that folder as well as all its subfolders, where you can place profiles built by you or downloaded from the Internet.

    After a profile is loaded by **Auto Match**, the degree of match between the current input image and loaded noise profile is displayed in the **Device Noise Profile** box. Higher **Match** values mean better match, leading to more accurate filtration.

**Smart Profile: prepare two profiles and select the better one**

- Use the **Profile > Smart Profile** menu item (or press the F5 key).

    **Smart Profile** uses both **Auto Profile** and **Auto Match** (with **Auto Fine-Tune**) to prepare two candidate profiles and then selects the better of two profiles. For **Smart Profile** to be fully efficient, the input image must contain flat featureless areas with noise for **Auto Profile** to analyze, and also there must be several pre-built profiles to let **Auto Match** find the most matching noise profile, as described above.

    You can adjust settings of **Smart Profile** function in **Preferences**.

**Auto Fine-Tune: to additionally fine-tune the manually loaded or matched profile**

You may want to additionally fine-tune the profile after it has been loaded either automatically (using **Auto Match**) or manually (using **Load Profile**). Fine-tuning the profile to the current image usually makes the profile more accurate and better reflecting the image’s noise properties.

Please note that you do not need to fine-tune a profile if you have just built it using **Auto Profile**. **Auto Profile** automatically applies fine-tuning so you do not need to repeat that operation. However if you load an existing profile instead of building a new one, fine-tuning such a loaded profile can be very useful.

- Use the menu **Profile > Auto Fine-Tune** to automatically fine-tune the loaded profile to the current image.

    There is no need to select any area in the input image because **Auto Fine-Tune** automatically analyzes the whole image.

Once you have loaded the profile that matches the input image or you have just built a new profile specifically for the current input image, proceed to process the image in the Stages III-V below.

---

¹ You can check and adjust the location of the **Profile folder** using the menu **Tools > Preferences > Folders**.
² You can check and adjust the location of that folder using the menu **Tools > Preferences > Matching**.
4.3. Stage III. Adjust filter settings

As soon as the noise profile is ready, you can use the noise and sharpening filters. These filters have several adjustable settings. The default settings usually produce good results (provided the noise profile is accurate). You may want to additionally vary the filter settings to achieve the filtration results that look best to your eyes.

Switch to the Adjust and Preview tab:

4.3.1. Use preview when adjusting filter settings

The image viewer in the Adjust and Preview tab shows a part of the image processed by the noise and sharpening filters. When you change any filter settings, the preview is automatically updated. You can zoom in and out, drag, scroll and pan the image to see how the filtration affects different parts of the image. If you manually select an area in the image then only that area will be processed for preview. That can also be faster than processing the whole visible area, so if you work on a slower machine, try selecting a smaller area for preview. The simplest way to do that is to double-click the image in the area of interest: Neat Image will then add a selection around that point.

When the preview is ready (the preview area shows “Filtered”), you can click inside that preview area to temporarily switch back to the original for comparison.

4.3.2. Beginner Mode and Advanced Mode

Neat Image has two sets of filter controls available in Beginner Mode and Advanced Mode. You can select the mode using the Tools > Beginner Mode and Tools > Advanced Mode menu items or using the dedicated Beginner Mode and Advanced Mode menu in the top right corner of Neat Image’s window.

The Beginner Mode provides a simplified control set recommended for beginners who have just started using Neat Image. The Advanced Mode provides the most complete control set with the maximum control over the noise profiling and filtration processes. The Advanced Mode offers several additional filter options and modes that help to achieve better noise reduction results.

We recommend to start with the simplified control set of the Beginner Mode and later switch to the Advanced Mode to be able to utilize Neat Image to its full potential.

Adjusting filter settings in Beginner Mode and Advanced Mode is described in two separate sub-sections below.

For Beginner Mode please follow the sub-section Stage IV (a). Beginner Mode right below.

If you want to jump directly to the most complete control set in Advanced Mode then please instead follow the sub-section Stage IV (b). Advanced Mode, page 20.

4.4. Stage IV (a). Beginner Mode

Please make sure Filter Settings panel is switched to the Filter tab.

4.4.1. Beginner Mode: Adjusting filter settings

There are two main filters in Neat Image: noise reduction filter and sharpening filter. These two filters can be used together and each of them can be used independently. You can enable, disable and adjust these filters using the guidelines in the subsections below.
Filter

The noise filter itself has two main settings (when working in Beginner Mode): Noise Level and Noise Reduction Amount.

The Noise Level setting is a threshold determining which image elements are considered noise and which elements are considered true details. The Noise Reduction Amount setting determines how much reduction is applied to the elements identified as noise.

- Use the Noise Reduction Amount > Luminance control to adjust the amount of noise reduction applied to the noise elements found in the luminance component of the image data.

This control is the most important and most frequently adjusted setting of the noise filter. The higher this setting, the more of the detected noise is removed in the luminance component. Be careful, setting the noise reduction amount too high may lead to loss of fine details and/or unnaturally looking (over-smooth, plastic-like) results. Too low amounts may be not enough to sufficiently reduce the objectionable part of the noise. The default value of 60% usually provides a good balance between noise removal and preserving natural (not over-processed) appearance of filtered image. Try to adjust the setting up and down to get the results that look best to your eyes.

- Use the Noise Level control to adjust the setting (only when necessary).

Please note that if the noise profile is accurate,¹ then it is not necessary to adjust this setting. However, if the noise profile is not accurate or it was built for a different image, then the noise filter may need an adjusted estimation of the actual noise level to be able to work correctly. By adjusting the Noise Level setting, you provide the filter with such an adjusted estimation. Use the preview to visually guide yourself when making such adjustments. The right adjustment will leave no noise elements in the image yet will not destroy the actual details.

It is best to gradually increase the noise level and watch the preview to find the point where most the noise elements are already reduced and the details are still preserved. If you go beyond that point, then some details may be lost too, so make sure you do not set the noise level unnecessarily high.

Sharpening (optional)

The sharpening filter in Neat Image increases the sharpness of image details without increasing the noise strength.

The sharpening filter is disabled by default. You can enable it and adjust the sharpening amounts separately for three typical scales of details: fine, medium-sized and large.

Like any sharpening method, try to balance the amount of sharpening to avoid over-sharpening.

- Use the Sharpening > Fine, Medium and Large sliders to adjust the amount of sharpening applied to the image details of the corresponding sizes.

It is best to start with adjusting the Fine sharpening amount. If sharpening the fine details alone is not sufficient to make the image look sharp, then try to increase the Medium and Large settings too.

¹ Use the Profile Check tool and Quality indicator in the Device Noise Profile box (in the Prepare Noise Profile tab) to check the accuracy of the profile as described in the II. Tune the profile using Profile Check (optional) section, page 14. Also pay attention to the Match indicator: it should either show a high value or there should be the (AP) sign indicating that the profile has been built by Auto Profile using this very image. That ensures that the profile is not only accurate but it also matches the input image.
Use preview

While adjusting the settings, use the available preview facilities to evaluate the corresponding changes in the results of Neat Image processing:

- Click inside the preview area to temporarily switch back to the original image for comparison;
- Move the preview area from one part of the image to another to see how the Neat Image processing affects different image content;
- Create several alternative variants of filtration, compare results and select the best variant. For more information on using variants please see the Variants of filtration section, page 44.

4.4.2. Beginner Mode: Optimize performance settings (optional)

Before applying the filter to the image (especially if that is only one of many images in a large batch), you may want to measure the processing speed on that image and potentially improve the speed by optimizing the performance settings of Neat Image. This is entirely optional but in some cases, the optimization can appreciably reduce the time of batch processing.

It is generally a good idea to optimize the performance settings when you run Neat Image on that specific computer for the very first time, to adapt the filter to the current hardware (the CPUs and GPUs available in that machine).

To check the current speed and to optimize the performance settings switch to the Performance tab in the Filter Settings box.

To measure the filter speed click Neat Image will run a test and will then display the measured processing speed based on the current filter settings (as shown in the text field in the Performance tab).

To optimize the performance settings click to open the Performance tab in Neat Image Preferences. In that tab, you can inspect the available and current CPU and GPU settings.

Then click to open a specialized dialog designed to measure image processing speeds achieved with different combinations of the CPU and GPU settings. It allows to automatically benchmark all possible combinations of those settings and to identify the best combination (for the current hardware and current filter settings). You can then just click to apply the found optimal combination achieving the best performance.

Once you have completed this step, please proceed to the section Stage IV. Apply filter to the input image, page 28.

Or if you want to switch to the Advanced Mode and adjust the filters using the most complete set of controls please proceed to the next sub-section dedicated to the Advanced Mode.
4.5. Stage IV (b). Advanced Mode

As said in the previous sections, Neat Image has two sets of filter controls, that are available in the Beginner Mode and Advanced Mode (you can select the mode using the Tools > Beginner Mode and Tools > Advanced Mode menu items).

The Beginner Mode described earlier provides a simplified control set recommended for beginners who have just started using Neat Image. The Advanced Mode provides the most complete control set with the maximum control over the noise profiling and filtration processes. The Advanced Mode offers several additional filter options and modes that help to achieve better noise reduction results.

It is usually best to start learning Neat Image using the simplified control set of the Beginner Mode and later switch to the Advanced Mode to be able to utilize Neat Image to its full potential.

If you want to use the Advanced Mode then please follow this sub-section, otherwise skip it and proceed to page 27 for the next stage.

As compared with the Beginner Mode, the Advanced Mode offers a more extensive set of filter controls. There are also several quality modes allowing to opt for higher quality of image processing over processing speed or the other way around.

4.5.1. Advanced Mode: Selecting Quality Mode

Please make sure Filter Settings panel is switched to the Filter tab.

The first setting available in the Filter tab is the Quality Mode, which is a global setting affecting the way all or most parts of the filter work. Quality Mode determines whether Neat Image should generally work more accurately (but somewhat slower) or somewhat less accurately (but significantly faster).

By default, Quality Mode is set to High, which provides a good balance between processing speed and the visual quality of results. There are also Highest (slower) and Normal (faster) modes.

Use the Quality Mode control to select the preferred processing mode.

While adjusting the Quality Mode, observe how the preview progress indicator (the yellow bar at the top of the preview area) is updating to get an idea of expected processing speed in each processing mode. You may not immediately notice the difference in visual quality in preview but the speed difference should be immediately obvious.

If the preview is updating too slowly, you do not necessarily have to decrease the Quality Mode. You can simply zoom into the image or manually select a smaller part of the image to limit the preview to that smaller area. Then the preview will update faster.

Preview has to update in many situations: when you change any filter settings, move the selected area to another part of the image, zoom in or out, etc. Therefore it is important to make those updates comfortably fast.

Once you find a comfortable way to evaluate the preview results, proceed to the next steps to adjust the actual filters.
4.5.2. Advanced Mode: Adjusting filter settings

There are several sections in the Filter tab. Most of the sections are related to the noise reduction filter and the last section is about sharpening. Most of the sections can be enabled or disabled individually to achieve the desired results in different image processing situations.

**Filter**

In Advanced Mode, the main noise filter has separate settings for all (spatial) frequency and channel components of the image data. There are pairs of noise level – noise reduction amount controls for each of these components. You have access to eight such pairs – three for channel components (Luminance, Cr, Cb) and five for spatial frequency components (High, Mid, Low, Very Low, Ultra Low) of the image data.

The meaning of each noise level – noise reduction amount pair is the following:

- the noise level control adjusts the threshold determining which elements of the corresponding image component are considered noise and which elements are considered true details;
- the noise reduction amount control determines how much reduction is applied to the elements identified as noise in that component.

Thus, with a noise level – noise reduction amount pair of settings you can adjust what should be considered noise in a component of the image data and how much reduction should be applied to that noise.

The noise level settings are relative to the noise levels of the current noise profile, which have been measured during profiling. Because the noise level controls are relative to the noise profile, their default settings usually produce good results as long as the noise profile itself is accurate.2

---

1 See “What is frequency” question in page 67.
2 Use the Profile Check tool and Quality indicator in the Device Noise Profile box (in the Prepare Noise Profile tab) to check the accuracy of the profile as described in the II. Tune the profile using Profile Check (optional) section, page 14.
Noise Reduction Amount

Noise reduction amounts are the most frequently adjusted settings of the noise filter.

- Use the Noise Reduction Amount > Luminance; Chrominance > Cr, Cb and Frequencies > High, Mid, Low, Very Low, Ultra Low sliders.

You can vary the noise reduction amount for each frequency and channel component of the image data. The higher a certain noise reduction amount is, the more of the detected noise is removed in the corresponding component.

Noise reduction amounts can be in the range from 0% (none of the detected noise is removed) to 100% (all the detected noise is removed). By default, the noise filter removes 60% in the Luminance channel and 80% in the Cr, Cb channels (you can always change the defaults if necessary).

Be careful: setting the noise reduction amounts too high, especially in the Luminance channel, may lead to loss of fine details and/or unnaturally looking (over-smooth, plastic-like) results. Too low amounts may be not enough to sufficiently reduce the objectionable part of the noise. Try to balance the noise reduction amounts (most importantly, the amount of noise reduction in the Luminance channel) to get the results that look best to your eyes.

Decreasing the noise reduction amounts can have a positive effect if the image contains some natural noise. For example, when you work with an image showing asphalt, sand, or anything else that contains fine natural noise-like features, it may be helpful to reduce the amounts at least for some of the components (for example, Luminance).

Filter Tuning Assist (optional)

Filter Tuning Assist is a special tool, which facilitates adjustment of other filter settings by helping to better see the influence of those settings in preview. It is not necessary to use this tool, but it may help to speed up the adjustment process as a whole.

When you use Filter Tuning Assist, all noise reduction amounts are temporarily increased to a higher value. That makes it easier to see the difference caused by adjustments in other settings such as Noise Level, Artifact Removal, Detail Recovery and other filter settings available in Advanced Mode and described further in this section.

To use the Filter Tuning Assist tool please follow these steps:

1. Click (the Begin button) to start the tuning process. The preview image may then look unnaturally plastic, but that is just a temporary effect that will go away once tuning is complete.

2. Adjust the highlighted filter settings so that no noise is visible in preview, but details are still preserved. For example, adjust the Noise Level to make all noise elements reduced yet preserving actual details of the scene as shown in this illustration:

As human vision is not very sensitive to variations of colors, strong filtration in the chrominance channels (Cr, Cb) does not noticeably distort image, but efficiently reduces color noise.

---

1 We recommend disabling the sharpening filter when adjusting the noise filter. This can make the influence of adjustments easier to see in preview.

2 You can adjust the filter settings and then save them as a new default preset using the menu Filter > Set As Default Preset… Also see the description of the Default Filter Preset setting in Neat Image Preferences, page 55.
See the next sections below for more information on adjusting Noise Level and other filter settings.

3. Click (the Finish button) to complete the tuning process.

Please note that some noise will return to the preview image after that. This is normal. The purpose of tuning is to adjust the settings to make the noise reduction accurate, while the amount of noise reduction can be adjusted using other filter settings, if required.

**Noise Level (optional)**

*Usually it is not necessary* to change the noise level settings if the noise profile is accurate. You only need to adjust the noise levels if you see in preview that some noise elements are not reduced by the filter even if you increase the noise reduction amounts. Such incomplete reduction is usually caused by an inaccurate noise profile providing inaccurate noise level estimations to the noise filter. This may be compensated by adjusting (increasing) the noise levels in the filter settings.

- Use the Noise Level > Luminance, Cr, Cb and Frequencies > High, Mid, Low, Very Low, Ultra Low sliders.

The noise filter is applied to the five frequency components and three channel components of the image data. Corresponding sliders adjust the estimated noise levels for each of these components.

The higher a certain noise level is, the more elements in the corresponding component are considered noise. Be careful: setting a noise level too high can lead to removal of true details. Setting it too low can lead to incomplete filtration: residual noise and compression artifacts can stay in the filtered image.

As a rule, if the device noise profile has been built properly, it is not necessary to increase the noise levels by more than 50%. If the image contains strong surges of noise in the high frequency range, it is recommended to increase the high frequency noise level up to +20 to 40% and/or use the artifact filter (see below).

If the image contains strong color noise, it is recommended to increase the Cr and Cb noise levels to +30% or more. In some cases, it may be useful to increase these noise levels up to +100%.

If adjusting noise levels still does not help and some noise elements remain in the filtered image, probably the device noise profile is not good at all. Return to Stage V. Prepare a device noise profile, page 12, and additionally fine-tune the noise profile or simply rebuild it from scratch.
Artifact Removal (optional)

Neat Image has an additional filter to remove residual dot-like and line-like noise elements that may remain in image even after applying Neat Image’s regular noise filters. Such residual noise elements / artifacts are typically created by in-camera noise reduction and compression or by other post-processing. Neat Image’s noise reduction can make those elements more visible if the noise levels are underestimated during profiling.

You can see an example of such digital artifacts in the first picture on the right. The second picture shows the results of noise reduction with the Artifact Removal filter enabled.

Such artifacts are usually of digital nature. They are typically of very small size yet they are different from the regular random noise, so they require special treatment provided by the Artifact Removal filter.

You can enable and adjust this filter using the following controls in the Filter > Artifact Removal section:

- Use the Dots control to adjust the dot removal threshold. Higher values lead to stronger reduction of dot-like artifacts (less attention to details); lower values lead to weaker reduction (more attention to details).
- Use the Lines control to adjust the line removal threshold. Higher values lead to stronger reduction of line-like artifacts (less attention to details); lower values lead to weaker reduction (more attention to details).

The artifact filter additionally offers separate thresholds for three frequency components (in other words, for three typical size scales) in the Frequencies sub-section: high, mid, low.

- Use the High, Mid and Low controls to adjust the artifact removal thresholds in the corresponding frequency components. Higher values lead to stronger reduction of artifacts (less attention to details); lower values lead to weaker reduction (more attention to details).

Detail Recovery (optional)

This option allows to recover some of the fine details which might be weakened or lost due to image editing, compression, noisiness of the original image, using a less accurate noise profile, etc. The Detail Recovery function is particularly useful when you need to preserve and recover partially lost repeated patterns such as brick walls, rug patterns, cloth textures, ripples, etc.

This option is available only in the Highest quality mode and it makes processing somewhat slower.

- Enable the Detail Recovery section.
- The Sensitivity setting is a threshold that determines what should be considered true details (as compared with noise elements) and therefore recovered by the filter. Positive values of Sensitivity make the filter detect and recover more details. Negative values make it more conservative so it recovers fewer image elements.

You can also use the High, Mid and Low controls to adjust the sensitivity for the individual frequency components of the image.

Keep in mind that setting the Detail Recovery controls too high can lead to incomplete filtration: residual noise and compression artifacts can stay in the filtered image. Setting these controls too low can lead to insufficient recovery of useful details. Try to find the right balance based on visual inspection of preview.

- Use the Amount control to set the strength of Detail Recovery. The higher the Amount setting the stronger recovery of the detected details. Lower values produce weaker recovery effect.
Edge Smoothing (optional)

This option of the noise filter makes smoother the edges of the objects in the image. This can be useful when edges are significantly degraded by the noise (or by the in-camera noise reduction and sharpening) and it is preferable to restore them.

- Enable the Edge Smoothing section to enable this option in general.
- Use the High, Mid and Low controls to adjust the strength of edge smoothing in the corresponding frequency components of the image. Higher values lead to stronger smoothing of edges; lower values lead to less smoothing.

Sharpening (optional)

The sharpening filter in Neat Image increases sharpness of the details in the image without increasing the noise strength.

The sharpening filter is disabled by default. You can enable it and adjust the sharpening amounts separately for three frequency components (for three typical size scales): High, Mid, Low.

- Use the Sharpening > High, Mid and Low sliders to adjust the amount of sharpening applied to the details of the corresponding size.

0% will not sharpen the component at all. 100% is the normal and 250% is the maximum strength of sharpening in each component.

It is best to start with adjusting the amount of sharpening applied to the High frequency component. If that sharpening alone is not sufficient, try to increase the Mid and Low settings too.

Like any sharpening method, try to balance the amount of sharpening to avoid over-sharpening.

- Use the Range sliders available under each of Sharpening > High, Mid and Low controls to adjust the frequency range (typical details size) to be sharpened:
  - -1 - sharpening is applied to a narrower frequency range;
  - 0 (default) - sharpening is applied to the normal frequency range of the frequency component;
  - +1 - sharpening is applied to a wider frequency range.

You can also adjust sharpening amounts separately for three channel components – Luminance and Cr / Cb (chrominance components):

- Use the Sharpening > Channels > Luminance, Cr and Cb sliders to adjust the amount of sharpening applied to the corresponding channel components.

You can also enable the dedicated option that prevents over-sharpening:

- Use the Sharpening > Prevent Over-Sharpening option to use a higher-quality sharpening method, which tries to prevent over-sharpening and to avoid creating a halo around details.
Use preview

While adjusting the settings, use the available preview facilities to evaluate the corresponding changes in the results of Neat Image filtration:

- Click inside the preview area to temporarily switch back to the original image for comparison;
- Move the preview area from one part of the image to another to see how the Neat Image processing affects different image content;
- Use \( \text{Viewer mode button} \) in the viewer toolbar to switch to different viewer modes and to inspect the individual components of the image. Examine channel and frequency components, check the presence of noise in individual components. Identify those components that do not get enough (or get too much) noise reduction and adjust the corresponding filter settings;
- Create several alternative variants of filtration, compare results and select the best variant. For more information on using variants please see the Variants of filtration section, page 44.

If you enabled Filter Tuning Mode to facilitate adjustments of the filter settings, make sure you have disabled that mode now.

4.5.3. Advanced Mode: Optimize performance (optional)

Before applying the filter to the image (especially if that is only one of many images in a large batch), you may want to measure the processing speed on that image and potentially improve the speed by optimizing the performance settings of Neat Image.

It is generally a good idea to optimize the performance settings when you run Neat Image on that specific computer for the very first time, to adapt the filter to the current hardware (the CPUs and GPUs available in that machine).

The processing speed may also depend on the filter settings: enabling more filters makes processing slower because Neat Image has to do more work. Also, if you significantly change the filter settings, then the optimal performance settings (for example, the number of CPU cores and/or GPUs used for processing) may change as well, so it may be useful to optimize those settings before starting a large batch where many images are going to be processed using the same settings. This is entirely optional but in some cases, the optimization can appreciably reduce the time of batch processing.

To check the current speed and to optimize the performance settings switch to the Performance tab in the Filter Settings box.

- To measure the filter speed click Check Speed in the bottom of the Performance tab.
  Neat Image will run a test and will then display the measured processing speed based on the current filter settings (as shown in the text field above).
- To optimize the performance settings click Preferences to open the Performance tab in Neat Image Preferences. In that tab, you can inspect the available performance options as well as the current CPU and GPU settings.
  Then click Optimize Settings to open a specialized dialog designed to measure image processing speeds achieved with different combinations of the CPU and GPU settings. It allows to automatically benchmark all possible combinations of settings and to identify the best combination (for the current filter settings).
  You can then just click Accept Best Combination to apply the found optimal combination achieving the best performance.
4.6. Stage V. Save filter settings into a preset (optional)

This sub-section is entirely optional yet you may want to consider saving the current filter settings into a preset on the disk to be able to re-load the same customized filter settings in another image, in the same or another project.

To save the filter settings into a preset

- Click (the Save current filter settings as a preset... button) in the Filter Settings box or use the Filter > Save Filter Preset... menu item.
  
  In the Save Filter Preset As dialog box, specify the name of the file to save the preset. The filter presets are stored in *.nfp files.

The saved filter preset includes all settings of Neat Image’s noise filter, all its specialized sub-sections and options, as well as the sharpening settings.¹

You can also add some text comments to your custom preset using the Preset Description dialog:

- Use to open the Preset Description dialog and add or edit the description of the preset.
  
  The text comments are also saved into the preset on the disk when you use .

To load a previously saved filter preset

- Click (the Load filter settings from a preset... button) in the Filter Settings box or use the Filter > Load Filter Preset... menu item. In the Load Filter Preset dialog box, locate and select the filter preset to be loaded.
  
  or

- Click (the drop-down button) in the Filter Settings box to open the popup menu with all available presets and then select one of them.

There are several pre-written filter presets in your Documents folder:²

Documents\Neat Image v9 Standalone\Presets\

Please try to load those pre-written presets to see what combinations of the filter settings and their values can be used to solve typical noise reduction tasks. The names of the groups of presets and names of presets themselves explain those tasks. Also, when loading any of the pre-written filter presets supplied with Neat Image, the Preset Description dialog opens automatically³ to display the description of the preset being loaded. The description is intended to help you get a better understanding of the purpose, applicability and possible side effects of the preset.

There are two main groups of pre-written presets: General and Advanced. The presets in the first group can be used in both Beginner Mode and Advanced Mode. The presets in the second group can only be used when Neat Image is in Advanced Mode, so loading such a preset will switch Neat Image to Advanced Mode (if you currently use Neat Image in Beginner Mode).

¹ A filter preset does not include the noise profile though, so you need to save the noise profile separately. Together, a pair of noise profile and filter preset can be used to accurately reproduce the filtration results later on.

² You can check and adjust the location of the Preset folder: use the menu Tools > Preferences > Folders > Preset folder.

³ You can disable displaying that dialog using the checkbox in the bottom of the Preset Description dialog (and re-enable it later in Neat Image Preferences if necessary).
4.7. Stage VI. Apply filter to the input image

- Switch to the **Save Output Image** tab:

This will automatically start the filtration process and Neat Image will process the whole input image. Processing may take some time (from seconds to minutes, depending on the speed of your computer and size of the image).

When the filtration is completed, you can compare the output and input images. Click the output image to temporarily switch between the output and input images for comparison.

If the filtration result is not satisfactory, please return to Stage III, page 17, to change some of the filter settings, or to Stage II, page 12, to build a new or improve the current noise profile to make it better match the noise of the input image.

- In the Pro version, you can optionally select a different bitdepth of the output image using the **Filter Output** box. The output bitdepth can be made different from that of the input image. In such a case, the input image will be internally converted to the output bitdepth during processing.

4.8. Stage VII. Save the output image

- Click (the **Save output image** button) in the toolbar or use the **File > Save Output Image As...** menu item.

The available output file formats are: JPEG, TIFF and PNG (see the **Requirements** subsection, page 5, for more details).

When saving in the PNG format, you can select the compression level: 0 is for the lowest compression / large file size and 9 is for the highest compression / smallest file size.

When saving in the JPEG format, you can select the compression quality. The last used compression quality value is always used as the current default.

Neat Image uses 4:1:1 subsampling with the JPEG quality lower than 85. If the JPEG quality is set to 85 or higher then subsampling is not used.

or

- You can also use the clipboard to export the filtration results to another application. Use the **Edit > Copy** menu item for that purpose. An image put on the clipboard will be in 24-bit RGB format.
5. Device noise profiles

A *device noise profile* (or *noise profile*, or simply *profile*) describes the properties of noise produced by an imaging device (e.g., digital camera, scanner, etc.) working in a certain mode. Several noise profiles corresponding to different modes of a device constitute a *profile set*. Neat Image can use profiles from such a set to process images produced in any of the modes covered by the set.

You can find some pre-built noise profiles or build your own profiles for your camera or scanner. Learn how to find, build and use device noise profiles in Neat Image in the subsections below.

5.1. Getting ready-made noise profiles

You can find some free profile sets for different cameras and scanners in:

- Profiles section of the Neat Image web page:
  https://ni.neatvideo.com/download/noise-profiles
- Device noise profiles section of the Neat Image community forum:
  https://www.neatvideo.net/viewforum.php?f=15
- Other digital imaging forums and web pages where users of Neat Image may publish their profiles.

To use a profile set from one of these sources, download the archive with profiles and unzip all profiles to the following folder and/or its sub-folder(s) in your *Documents* folder:

```
Documents\Neat Image v9 Standalone\Profiles\
```

After that you can use individual profiles from this set in Neat Image to process images produced in device modes covered by this profile set.

Please be aware that using ready-made profiles built by other people may produce less than optimal results with your images because of possible slight differences in noise properties of cameras (scanners) as well as due to differences in imaging processing workflows used. Therefore, we advise to use ready-made noise profiles built by others only as a starting point to learn how to use Neat Image. To achieve the best results consider building your own profiles using the procedures described in the subsections below.

5.2. Building a profile for a device mode (standard profiling procedure)

In this subsection, you will find out how to build a single noise profile for an image produced in a certain shooting mode of a camera or a scanning mode of a scanner (such a profile can also be called “a profile for a certain mode of the device”).

Building a new noise profile generally consists of three stages:

- Stage I. Building a profile;
- Stage II. Documenting the profile;
- Stage III. Saving the profile.

The Stage I, building a profile, can be done using a *regular image* (for example, the image that you want to denoise or any other regular image) or using an image of the *Calibration Target* (a special test chart facilitating profiling). These two cases are described as two alternative versions of the Stage I:

- Stage I. Case of building a profile using a regular image
- Stage I. Case of building a profile using the Calibration Target

You may want to follow the case of building a noise profile using a regular image if you want to build a one-time-use noise profile to process one specific input image. In this case, the input image (or an alternative regular image from the same series, that is produced by the same device working in the same mode) should contain some uniform featureless areas for noise analysis.

A uniform area (with minor brightness variation in all channels of the image) may be overcast sky (without visually distinguishable clouds), clear sky (without clouds and birds), or any other part of the

---

1 You can check and adjust the location of the *Profile folder* using the menu *Tools > Preferences > Folders*.
image containing no visually perceptible details (except the noise). Neat Image needs uniform featureless areas of around 128x128 pixels or more (up to 512x512 pixels; larger is better), the minimum is 32x32 pixels. You can see some examples of such areas in the Examples section, page 64.

If the input image does not contain such areas and you have no suitable alternative regular image that contains such areas, you can prepare a special test image and follow the case of building a noise profile using the Calibration Target. That is also recommended if you want to prepare a reusable noise profile for a certain mode of your camera or scanner.

5.2.1. Stage I. Case of building a profile using a regular image

To build a noise profile using a regular image you must take 2 steps:

Step 1. Preparing a regular image for noise analysis;
Step 2. Analyzing the image noise.

Step 1. Preparing a regular image for noise analysis

To analyze noise in a regular image, you can use the input image or an alternative regular image that was produced by the same camera (or scanner) in the same or similar shooting (scanning) mode. Using the input image itself usually produces the most accurate noise profile that perfectly matches the noise properties of the input image. However, if there are not enough flat featureless areas in the input image, then you may have to use an alternative regular image.

Case of using the input image

In this case, simply stay with the input image that is already opened in the Editor tab. The input image is displayed in both the Open Input Image and Prepare Noise Profile tabs.

To build a profile, switch to the Prepare Noise Profile tab and proceed to the step 2 below.

Case of using an alternative image

If there is no large enough uniform featureless areas in the input image, use an alternative image. The alternative image is supposed to be produced by the same device working in the same or similar mode. This can be just another image from the same series; the image should contain at least one large enough uniform featureless area suitable for analysis.

To open the alternative image:

- Click (the Open input image button) in the toolbar or use the File > Open Input Image... menu item. Select an image to be used for profiling.
- Drag an image file from Windows Explorer and drop it to the image viewer in Neat Image.
- Use the Edit > Paste menu item to copy-and-paste an image from another application to Neat Image through the clipboard.

Use the loaded alternative image to build a noise profile in the step 2 below. Then load the original input image back to process it using the newly built profile.

Step 2. Analyzing image noise (profiling)

Analyzing noise is the main part of building a noise profile for an imaging device working in a certain mode. The current version of Neat Image standalone (Win) offers three ways of conducting the noise analysis (profiling): automatic, semi-automatic and manual one. Using automatic profiling is easier and therefore recommended for beginners. In difficult cases (for example if Neat Image cannot automatically find a uniform featureless area in an analyzed image), automatic profiling may not work well or may produce less than perfect results. You can always override automatics and use semi-automatic or manual profiling.

- Make sure you use the Prepare Noise Profile tab:
Case of automatic profiling

To analyze noise properties, Neat Image uses uniform image areas that contain noise but no visible or important details. With automatic profiling, Neat Image tries to find one such area automatically and then uses the found area to analyze image noise.

- Click the Auto Profile button in the toolbar, or use the Profile > Auto Profile with Regular Image menu item, or press F2.

Auto Profile will try to automatically find an area containing a sample of pure noise (without any details of the scene) for analysis. Neat Image will then select the found area (it will be shown in the viewer) and automatically analyze the noise in that area to build a new noise profile based on it. Neat Image will automatically analyze the rest of the image too. However, the most important part of the analysis is the selected area, which is why it is highlighted in the viewer to help you visually inspect the area.

Once Auto Profile selects the area used for analysis, please visually inspect it to verify that the area does indeed satisfy the following requirements (recommended to achieve the best results):

- The area should contain visible noise;
- The noise should look typical for the current image;
- The noise should be the strongest among all such areas present in the image; (you can use the noise strength indicator shown over the selection to check that)
- The area should contain no scene details of any kind (objects, textures, gradients, etc.);
- The area should not be very dark (near black) nor very bright (near white);
- The area should be as large as possible in that image.

Auto Profile generally tries to find areas that satisfy these requirements but that may be not always possible to achieve. In difficult cases, it may be not able to find a large enough area or area without details. You will then notice that the selected area, for example, contains some details or has some other issues. In such cases, Neat Image also warns you that the area may be not very suitable for analysis. It may say that the selected area is not uniform in one or more channels, or is small, or contains too weak noise or clipping in some channels.

If you receive such a warning about possible non-uniformity, clipping, small size of the area, etc., then you generally have two options:
You can choose to ignore the warning and proceed using the area found by **Auto Profile**. However, the accuracy of the resulting noise profile may be lower than it could in principle be with that image. Technically, the filter will still work but the quality of the results may be lower.

You can try to resolve the reported issue using the semi-automatic profiling (see below).

If you see that the area automatically selected for analysis is indeed uniform and featureless, then the resulting noise analysis is accurate. To be sure, check the **Quality** indicator in the **Device Noise Profile** box. A profile built using a uniform and featureless area will usually show a high value there.

If the profile quality is high (for example, higher than 60%), then you can be sure that the noise profile is accurate. In this case, proceed to **Stage II. Documenting noise profile**, page 36.

If the quality is not high, try to use the semi-automatic profiling instead (see below).

Besides the **Quality** indicator, Neat Image offers a few more tools to help you build accurate noise profiles.

To visually inspect areas found by **Auto Profile** and to manually find the most suitable areas, use the **YCrCb+** mode of the image viewer. It helps to better see any weak details that may be present in the candidate image areas. The **YCrCb+** mode emphasizes the weak details and noise present in **Luminance** (Y), **Cr** and **Cb** channels, as shown in the example below:

The top image shows the original picture where details around the sun are barely visible, while the channels in the bottom part display the image data in **YCrCb+** mode allowing to see those weak details much better.

That can help to verify that the selected area contains no useful details, which is very important for accurate noise analysis. If you see that some details are present in the selected area then try to use the semi-automatic profiling instead (see below).

Also, the **Device Noise Profile** box displays a histogram of the measured noise levels of the current profile’s frequency components. (In **Beginner Mode**, the histogram is shown in **Profile Viewer** only: menu **Profile > Profile Viewer**).

Normally, the histogram bars are shaded in green, which means likely-accurate measurements. Yellow or red shadings are used to indicate possibly-inaccurate measurements of the corresponding components.
It may happen that the lowest frequencies are measured inaccurately (especially when the analysis area is small). The analysis area may seem featureless, but may actually contain some gradient-like details. Their presence in the analysis area may cause the noise levels to be measured inaccurately: the noise levels may be estimated higher than they really are. An example of such a profile with inaccurate measurements is shown in the top picture on the right.

A more accurate profiling (perhaps using a larger analysis area) could potentially produce a better profile. Such a better profile would show a histogram like one shown in the lower picture on the right.

If a noise profile with inaccurately measured lowest frequencies is used to process an image, then those inaccurate measurements may lead to loss of details in the corresponding frequency components. If you disable processing those frequency components (by setting the Noise Reduction Amounts of those frequency components to 0% in the Filter > Frequencies settings), this profile can be still used to filter the other frequency components.

**Case of semi-automatic profiling**

1) **Find a uniform featureless image area**

- Manually find and select an image area that contains no visible details.1

  The area should be as large as possible (up to the maximum of 512x512 pixels). Using a large area is preferred because that allows to more accurately measure the properties of the noise. Using smaller areas is possible too, but the accuracy may be reduced. The absolute minimum size is 32x32 pixels.

  You can resize the selection frame and check the size of the selection using the **W** and **H** indicators in the bottom of the window. Also, Neat Image will indicate which frequency components can be measured using the selected area. For example, **Good (Low Freq)** would mean that all frequency components up to **Low** (specifically, **High**, **Medium**, and **Low**) can be measured using the selected area.

  Scroll, pan, zoom the image to find a uniform image area and then select this area. Use the **YCrCb+** mode of the viewer to better see the weak details and choose an area without details.

  If the noise strength varies in different parts of the image, it is better to select an area with the strongest noise. When you select an area, the indicator on top of the selection displays the noise level measured in the currently selected area. That can help to find the most noisy area for profiling. Please note that if you include any actual details in the selection, then the figure will be inaccurate. It is accurate when you select an area containing only noise.

  In **Advanced Mode**, the noise levels measured in the currently selected area as well as in the area used to build the current profile are also shown by the Noise Levels indicators in the Device Noise Profile panel. The Selection indicator shows the overall noise level of the currently selected area. The Main Sample indicator shows the noise level of the analysis area of the current profile (if any).

  If you cannot find a large enough uniform area in the input image, consider using an alternative regular image or use the Calibration Target as described in the section (Stage I. Case of building a profile using the Calibration Target, page 35).

2) **Analyze selected image area**

- Click (the Build Profile button).

  Neat Image will automatically analyze the manually selected image area and then it will also automatically analyze the rest of the image (it will automatically fine-tune the profile using the whole image).

  The profile is now ready. Please proceed to Stage II. Documenting noise profile, page 36.

1 You can find some examples of uniform featureless image areas in the Examples section, page 64.
Case of manual profiling (Advanced Mode only 1)

1) Find a uniform featureless area

- Manually find and select an area that contains no visible details.

The area should be as large as possible (up to the maximum of 512x512 pixels). Using a large area is preferred because that allows to more accurately measure the properties of the noise. Using smaller areas is possible too, but the accuracy may be reduced. The absolute minimum size is 32x32 pixels.

Scroll, pan, zoom the image to find a uniform featureless image area. Use the YCrCb+ mode of the viewer to better see the weak details and choose an area without details.

If noise strength is different in different parts of the image, it is better to select an area with the strongest noise. Use the noise level indicator on top of the selection to find such an area.

2) Analyze selected area

- Click (the Build Profile button).

Neat Image will automatically analyze the manually selected area and build a noise profile.

3) Additionally manually fine-tune the profile

Fine-tuning uses additional flat featureless image areas to make the noise profile more accurate. You can manually select and analyze several such areas one after another.

1) Find and select a uniform featureless area

- Scroll, pan, zoom the image in the viewer in the Prepare Noise Profile tab to find a new uniform area.

The size of an area may be from 16x16 to 512x512 pixels. Using larger areas makes fine-tuning more accurate. Please notice that the edges of the selection box change their thickness as the size reaches certain size thresholds. That is meant to help you select a sufficiently large area.

2) Analyze the selected area with Manual Fine-Tune

- Click (the Manual Fine-Tune button) or use the Profile > Fine-Tune Using Selected Area menu item.

The analysis results will be shown in the noise profile equalizer: the graphs of the equalizer will change some of the values (see the picture on the right) each time you add a new fine-tuning measurement. You can switch from one channel to another in the equalizer to better see a specific channel’s graph, or you can select to show them all together.

The goal of manual fine-tuning is to fill the equalizer with measured values (shown as graph-color knots) in all points of the graphs. The previous steps (specifically, the Auto Profile function) may have already filled some of the values. Manual fine-tuning can further improve the analysis by filling out the still missing or interpolated values (shown as yellow knots) and/or making some of already measured values more precise.

3) Repeat 1-2 above with other uniform areas of different brightness

To make the device noise profile more accurate, fine-tune it using several uniform image areas. Select areas of different brightness for best results. Try to choose and analyze uniform areas to cover all or most elements of the equalizer in all its color channels. The more elements of profile are analyzed, the higher is the overall quality of the profile.

---

1 You can switch using the Tools > Advanced Mode menu item.
4) Complete fine-tuning using Auto Complete

- Click (the Auto Complete button) or use the Profile > Auto Complete menu item to automatically complete the fine-tuning by adjusting the unmeasured values using interpolation based on the measured data.

At this point the profile is ready. Proceed to Stage II. Documenting noise profile, page 36.

5.2.2. Stage I. Case of building a profile using the Calibration Target

The Calibration Target has been designed to enable easy profiling of various imaging devices. It can be used to build a single profile for a certain device mode or a set of profiles for different modes.

Follow the steps below to prepare a single profile using the Calibration Target.

Step 1. Preparing the Calibration Target

To use the Calibration Target, either use the menu Tools > Calibration Target and then click (the Display target... button), or download the image of the Target from the Neat Image web page: https://ni.neatvideo.com/download/calibration-target

There are two ways of using the Calibration Target: you can open it on the screen and take a shot (with a digital or film camera, depending on your workflow) or you can print it out and shoot the hardcopy.

Shooting the Calibration Target off the screen is faster, especially with a digital camera. However, be careful when shooting it off the screen of a CRT monitor because you may occasionally capture scan bands. These bands may spoil a part of the shot. If you cannot avoid these bands, prepare a printed version of the Calibration Target or shot it off an LCD monitor, which does not produce this effect. Also, try to avoid glares when using a monitor with a glass or glossy screen.

Case of shooting the Calibration Target off the screen

- Open the Calibration Target image on the screen (menu Tools > Calibration Target and then click the Display target... button). Then use the displayed Calibration Target in the Step 2 below.

Case of shooting the printed Calibration Target

- Open the Calibration Target image in an image editor and print out the image on a sheet of white matte paper; make the image fill the whole page. Then use the printed target in the Step 2 below.

Step 2. Preparing a shot or scan of the Calibration Target

Case of digital camera

Use the displayed or printed Calibration Target to prepare a test shot for building a device noise profile for your camera:

1. Set the camera to a certain shooting mode (ISO level, etc.) you want to build a profile for;
2. Important: set the focusing system on infinity or in macro mode to get a slightly-out-of-focus image of the target;
3. Make sure the Calibration Target fills the whole frame and make a shot;
4. Open the resulting shot in Neat Image (the Step 3 below).
Case of flatbed scanner

Use the printed Calibration Target to prepare a test scan for building a device noise profile for your flatbed scanner:

1. Set the scanner to a certain scanning mode (resolution, light level, etc.) you want to build a profile for;
2. If possible set the scanner slightly out of focus (an out of focus scan is preferred for profiling); a possible way to achieve this is to raise the page over the scanner glass a bit;
3. Scan the printed Calibration Target;
4. Open the resulting scan in Neat Image (the Step 3 below).

Case of slide scanner

Use the displayed or printed Calibration Target to prepare a test scan for building a device noise profile for your film scanner:

1. Set the camera to a certain shooting mode (film type, exposure, etc.) you want to build a profile for;
2. **Important**: set the focusing system on infinity or in macro mode to get a slightly-out-of-focus image of the target;
3. Make sure the Calibration Target fills the whole frame and make a shot;
4. Develop the slide and put it into the scanner;
5. Set the scanner to a certain scanning mode (resolution, light level, etc.) that you want to build a profile for and scan the slide;
6. Open the resulting scan in Neat Image (the Step 3 below).

**Step 3. Analyzing image noise**

Open the shot or scan of the Calibration Target in Neat Image and use it to build a noise profile:

- Click (the Open input image button) in the toolbar or use the File > Open Input Image... menu item. Select the shot or scan that you have just prepared.
- Use the Profile > Auto Profile with Calibration Target menu item.

After the analysis is completed, proceed to the Stage II below.

5.2.3. Stage II. Documenting noise profile

At this point of building the noise profile for your camera or scanner, the noise analysis is done and all important noise characteristics are gathered in the profile. You may still want to manually document the profile if Neat Image has not done this automatically. With most images from digital cameras, Neat Image is able to automatically extract the crucial information about the camera mode from the EXIF data fields of the analyzed image and put this information to the noise profile (you can see that in the Device Name and Mode fields in the Device Noise Profile box.

If Neat Image has not automatically placed the required information to the Device Name and Mode fields after noise analysis, you can add those details manually.

- Use the Device Name and Mode fields in the Device Noise Profile box. Here, you can specify the model of the image acquisition device and describe the device mode, which can be something like the data in the picture above.
About the Device name and Mode notes

It is highly recommended to specify these details to keep record of devices, device modes and corresponding device noise profiles that you use.

The noise characteristics of any two devices can be extremely different. Even a single device in different modes can produce significantly different noise. Therefore, it is always better to use separate noise profiles for different devices and device modes to avoid inaccurate filtration and artifacts. Commenting on the device name and device mode parameters helps you keep track of them when you do manual profile matching, i.e., when you manually select a suitable profile to process an image.

Automatic profile matching available in Neat Image uses the EXIF information from the image files and profiles, not the Device Name and Mode fields, so filling out these fields may not be necessary for automatic profile matching. However, filling out these fields is highly advisable both for the clarity purposes and for the cases of EXIF-less input images where you have no other choice but to manually select a suitable profile based on the Device Name and Mode fields.

See the Preparing profile set for different device modes section below to find out more about camera and scanner parameters that may need to be documented in the Device Name and Mode fields.

5.2.4. Stage III. Saving the noise profile

- Use (the Save Device Noise Profile As... button) in the Device Noise Profile box or use the Profile > Save As... menu item.

In the Save Device Noise Profile As dialog box, specify the file name to save the profile. The default name is based on the device name and device mode when these are available from the EXIF data fields of the analyzed image. If the EXIF data are not available then the default profile name is based on the name of analyzed image file. Use the suggested default or change the name of the file to store the device noise profile. Device noise profiles are saved in *.dnp files.

File naming considerations

If you are going to re-use a device noise profile later on, select a good file name explaining the device name and mode so that you could easily recognize this profile by its file name. Alternatively, you can use special folder structuring to keep many device noise profiles arranged according to their device modes.

See Stage III. Structuring profile set, page 40, for additional information.

A saved noise profile includes the complete noise analysis. Therefore, by re-opening the noise profile, you can reproduce exactly the same conditions for image processing later on. Also, you can exchange noise profiles with other Neat Image users.

5.3. Preparing profile set for different device modes

Usually, an imaging device can work in several different modes. Therefore, there should be several device noise profiles corresponding to different modes to enable accurate processing of arbitrary images produced by this device. If a set of profiles covers all modes of the device then any image from this device can be processed by using one of the profiles from the set.

This subsection explains how to prepare a reusable set of profiles for a range of modes of an imaging device.

As an owner of a certain imaging device, for example a digital camera, you are in perfect position to prepare a profile set for that device because you have direct access to the device hardware. Moreover, building and using your own set of profiles makes noise reduction more accurate because such profiles better reflect the specifics of the device as well as the workflow you use.

When building a set of profiles, please follow the guidelines below that will help you structure the profile set in such a way as to make the set easy to use for you. And for other people if you decide to share your
results. Please do share because in this way you will help people with the same camera or scanner model.
You can submit a set of profiles to the Neat Image team to publish the set in the profile library by using a special form at https://ni.neatvideo.com/contacts/upload-noise-profiles or just share them with other people directly.

5.3.1. Stage I. Selecting device parameters for profile set

To build a set of profiles for particular camera or scanner, you should identify different device parameters that affect the noise characteristics and decide which of those you will take into account during profiling. There may be many device parameters but not all of them influence image noise and those that do, differ by the strength of their influence. Naturally, you are only interested in those parameters that appreciably affect noise. Different noise profiles should be prepared for different values of the most important parameters, so you should identify those parameters in the first place.

The tables below describe the parameters that appreciably affect noise characteristics (from the most to the less important ones) of digital cameras and scanners:

### Digital camera parameters in the order of decreasing importance

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Values</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>ISO rate</td>
<td>50, 100, 200, 400, etc.; depends on a camera</td>
<td>Higher ISO rates produce more noise.</td>
</tr>
<tr>
<td>Camera noise reduction</td>
<td>High, Normal, Low, etc.; depends on a camera</td>
<td>In-camera noise reduction can reduce levels of noise in photos (usually at expense of some details).</td>
</tr>
<tr>
<td>Sharpness adjustment</td>
<td>Low, Normal, High, etc.; depends on a camera</td>
<td>Internal sharpness adjustment of a camera makes noise more intensive. Using no internal sharpness adjustment produces least noise.</td>
</tr>
<tr>
<td>Compression</td>
<td>1:1 (or Uncompressed), 1:5 (or Fine), 1:10 (or Normal), 1:20 (or Basic), etc. or 2 bits/pixel, 4 bits/pixel, etc. depends on a camera</td>
<td>Strong JPEG compression typically produces more JPEG artifacts and destroys details and noise; weaker compression preserves more image elements including noise created by the image sensor. It is preferable to use the lowest amount of compression for the best results.</td>
</tr>
<tr>
<td>Resolution</td>
<td>1:1 (original resolution, like 4288x2848), 1:2 (downsized in camera, e.g., 2144x1424), 2:1 (digital zoom, 2x), etc.</td>
<td>In-camera interpolation (both downsizing and upsizing, e.g., that of digital zoom) changes many characteristics of noise.</td>
</tr>
<tr>
<td>White balance</td>
<td>Sun, Cloudy, Incandescent, Fluorescent, etc.; depends on a camera</td>
<td>White balance adjustment changes characteristics of noise (mainly of color noise) slightly.</td>
</tr>
<tr>
<td>Exposure</td>
<td>1/16s, 1.0s, 16s;</td>
<td>Long exposures produce more hot-pixel noise; also, some cameras switch on the automatic noise reduction when exposure is longer than a certain threshold, which may affect the noise levels.</td>
</tr>
</tbody>
</table>

### Scanner / camera parameters in the order of decreasing importance

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Values</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Film type</td>
<td>For example, Kodak Tmax 400, Kodak Tri-X Professional 320, Fuji Superia 200, etc.</td>
<td>Every film type produces a specific grain pattern, which depends on the film material. Strength of the grain depends on ASA/ISO rate of the film.</td>
</tr>
<tr>
<td>Scanning resolution</td>
<td>For example, 300 dpi, 3200 dpi, 4000 dpi, etc.</td>
<td>Higher scanning resolution emphasizes film grain and makes it more evident in scanned images.</td>
</tr>
<tr>
<td>Number of scan passes</td>
<td>Single pass, 2x pass, 4x pass, etc.</td>
<td>Multi-pass scanning can potentially produce less grainy images.</td>
</tr>
</tbody>
</table>

If two images were captured in the same or similar conditions (most of the above device mode parameters are the same) then the noise of these two images should be very similar. If you have built a device noise profile using one of these images, you can use this profile to filter both images with good results. If the shooting or scanning conditions were different then the noise in two images could be significantly
different. In this case, cross-use of one noise profile is not recommended. Instead, two different profiles should be built and used to filter these two images.

Based on these considerations and tables above, identify the device mode parameters of your camera or scanner that (1) are important from the noise standpoint and (2) are changed in your imaging tasks. For example, if you never change the sharpness adjustment of your digital camera then there is no need to build profiles for different values of the sharpness adjustment parameter. On the other hand, if you do shoot with different ISO rates then you should build profiles for every ISO rate you use. Some parameters are less important (for example, the White Balance or Exposure) and you may simply choose to ignore the slight differences of the noise characteristics caused by changes of those device mode parameters.

Identify and make a list of the device mode parameters that are important for your imaging tasks. For example, you could include two parameters of your digital camera: the ISO rate (ISO 100, 200, 400) and JPEG compression level (HQ, SHQ). Then it is straightforward to write down all combinations of the selected parameters:

- JPEG HQ, ISO 100
- JPEG HQ, ISO 200
- JPEG HQ, ISO 400
- JPEG SHQ, ISO 100
- JPEG SHQ, ISO 200
- JPEG SHQ, ISO 400

Then prepare an individual profile for each combination from this list. Please proceed to the Stage II to build profiles for all combinations.

5.3.2. Stage II. Building individual profiles

To build individual profiles for the profile set, you can either use the standard profiling procedure described earlier, or employ a special built-in tool – the **Batch Profiler**.

**Using standard profiling procedure**

To build individual profiles using the standard profiling procedure, follow the guidelines of the Building a profile for a device mode (standard profiling procedure) section, page 29. Using those guidelines, build a new profile for every combination of the device mode parameters included in your list (prepared in the Stage I above). The resulting set of noise profiles (several *.dnp files on the disk) can then be structured as recommended in the Stage III below.

**Using Batch Profiler**

The **Batch Profiler** is a dedicated tool that can automatically build several noise profiles using shots or scans of the Calibration Target (please note that the **Batch Profiler** is not for regular images, it is designed to work with shots or scans of the Calibration Target only). To use this tool, you must prepare several shots (scans) of the Calibration Target and then analyze them all at once using the **Batch Profiler**.

1. Preparing set of images of the Calibration Target

To prepare shot or scan of the Calibration Target for every combination of device mode parameters, please follow the two initial steps of **Stage I. Case of building a profile using the Calibration Target**:

   **Step 1. Preparing the Calibration Target**, see page 35.

   **Step 2. Preparing a shot or scan of the Calibration Target**, see page 35.

Do the Step 2 for every combination of device parameters in your list. Then place all resulting image files (*.jpg, *.tiff, *.png) to a new folder (and its subfolders if necessary) on the hard drive, for example: *Documents\Target Images*
2. Preparing profiles

To prepare profiles using the images of the Calibration Target:

1. Select the **Tools > Batch Profiler...** menu item to open the **Batch Profiler** window.

2. In the **Batch Profiler** window, specify the folder with images of the Calibration Target and the folder where the **Batch Profiler** should save the prepared device noise profiles.

3. Click the **Start** button to initiate the profiling process.
   When profiling is finished, new noise profiles are saved in the selected target folder.

4. Click the **Close** button to close the **Batch Profiler** window.

As the result, you have a set of noise profiles (several *.dnp files on the hard drive) that can be further structured as described below.

### 5.3.3. Stage III. Structuring profile set

In the Stage II, you have prepared a set of profiles on the disk. You (or Neat Image itself) have assigned names to these profiles that reflect the device modes they correspond to.

For example, profiles for Olympus Stylus SH-2 could be named like the following:

| Olympus SH-2 | 
| SH-2 (ISO125; JPEG Normal; SharpNormal; 3200x2400).dnp |
| SH-2 (ISO125; JPEG Normal; SharpNormal; 4608x3506).dnp |
| SH-2 (ISO125; JPEG Fine; SharpNormal; 3200x2400).dnp |
| SH-2 (ISO125; JPEG Fine; SharpNormal; 4608x3506).dnp |
| SH-2 (ISO200; JPEG Normal; SharpNormal; 3200x2400).dnp |
| SH-2 (ISO200; JPEG Normal; SharpNormal; 4608x3506).dnp |
| SH-2 (ISO200; JPEG Fine; SharpNormal; 3200x2400).dnp |
| SH-2 (ISO200; JPEG Fine; SharpNormal; 4608x3506).dnp |
| SH-2 (ISO400; JPEG Normal; SharpNormal; 3200x2400).dnp |
| SH-2 (ISO400; JPEG Normal; SharpNormal; 4608x3506).dnp |
| SH-2 (ISO400; JPEG Fine; SharpNormal; 3200x2400).dnp |
| SH-2 (ISO400; JPEG Fine; SharpNormal; 4608x3506).dnp |
| SH-2 (ISO800; JPEG Normal; SharpNormal; 3200x2400).dnp |
| SH-2 (ISO800; JPEG Normal; SharpNormal; 4608x3506).dnp |
| SH-2 (ISO800; JPEG Fine; SharpNormal; 3200x2400).dnp |
| SH-2 (ISO800; JPEG Fine; SharpNormal; 4608x3506).dnp |
| SH-2 (ISO1600; JPEG Fine; SharpNormal; 3200x2400).dnp |
| SH-2 (ISO1600; JPEG Fine; SharpNormal; 4608x3506).dnp |
| SH-2 (ISO3200; JPEG Fine; SharpNormal; 3200x2400).dnp |
| SH-2 (ISO3200; JPEG Fine; SharpNormal; 4608x3506).dnp |
| SH-2 (ISO6400; JPEG Fine; SharpNormal; 3200x2400).dnp |
| SH-2 (ISO6400; JPEG Fine; SharpNormal; 4608x3506).dnp |
| SH-2 (ISO125; TIFF; SharpNormal; 4608x3506).dnp |
| SH-2 (ISO3200; TIFF; SharpNormal; 4608x3506).dnp |
| SH-2 (ISO6400; TIFF; SharpNormal; 4608x3506).dnp |

- **SH-2** - disk folder
  - **SH-2** - camera name
  - **ISO###** - ISO rate of camera mode
  - **JPEG Normal / JPEG Fine / TIFF** - file format and compression level
  - **Sharp####** - sharpness adjustment
  - **####x####** - image size

When the profiles are named like this, manual selection of a suitable profile is simple. You can check the device mode of the input image (using **Image Metadata** information in the **Open Input Image** tab or using button in the bottom of the image viewer) and then select and load a profile that matches that device mode.
There is another way to select profile for an image, based on structuring the profile set using the disk folders. For example, the above Olympus Stylus SH-2 profile set could be structured like this:

<table>
<thead>
<tr>
<th>Olympus Stylus SH-2</th>
<th>- disk folder</th>
</tr>
</thead>
<tbody>
<tr>
<td>TIFF (uncompressed)</td>
<td>Olympus Stylus SH-2</td>
</tr>
<tr>
<td>4608x3506</td>
<td>JPEG/TIFF, ISO ###.dnp</td>
</tr>
<tr>
<td>ISO 125.dnp</td>
<td>- the names of disk subfolders containing device noise profiles for corresponding device modes;</td>
</tr>
<tr>
<td>ISO 200.dnp</td>
<td>ISO ###.dnp</td>
</tr>
<tr>
<td>ISO 400.dnp</td>
<td>- device noise profiles;</td>
</tr>
<tr>
<td>ISO 800.dnp</td>
<td>Note that the constant parameter (Sharpness adjustment) is not reflected in the folder structure. However, if there were profiles with different values of that parameter then an additional subfolder should be added.</td>
</tr>
<tr>
<td>ISO 1600.dnp</td>
<td>Parameters that can be disregarded, such as exposure time, are not reflected in the folder structure too.</td>
</tr>
<tr>
<td>ISO 3200.dnp</td>
<td></td>
</tr>
<tr>
<td>ISO 6400.dnp</td>
<td></td>
</tr>
<tr>
<td>JPEG</td>
<td></td>
</tr>
<tr>
<td>Fine (high quality)</td>
<td>3200x2400</td>
</tr>
<tr>
<td>4608x3506</td>
<td>ISO 125.dnp</td>
</tr>
<tr>
<td>ISO 125.dnp</td>
<td>ISO ###.dnp</td>
</tr>
<tr>
<td>ISO 200.dnp</td>
<td>-</td>
</tr>
<tr>
<td>ISO 400.dnp</td>
<td>Parameters that can be disregarded, such as exposure time, are not reflected in the folder structure too.</td>
</tr>
<tr>
<td>ISO 800.dnp</td>
<td></td>
</tr>
<tr>
<td>ISO 1600.dnp</td>
<td></td>
</tr>
<tr>
<td>ISO 3200.dnp</td>
<td></td>
</tr>
<tr>
<td>ISO 6400.dnp</td>
<td></td>
</tr>
<tr>
<td>Normal (normal quality)</td>
<td>3200x2400</td>
</tr>
<tr>
<td>4608x3506</td>
<td>ISO 125.dnp</td>
</tr>
<tr>
<td>ISO 125.dnp</td>
<td>Parameters that can be disregarded, such as exposure time, are not reflected in the folder structure too.</td>
</tr>
<tr>
<td>ISO 200.dnp</td>
<td></td>
</tr>
<tr>
<td>ISO 400.dnp</td>
<td></td>
</tr>
<tr>
<td>ISO 800.dnp</td>
<td></td>
</tr>
</tbody>
</table>

In this case, the folder tree stores device noise profiles in a structured way, which can help you to select one profile from the set given the device mode of the input image.

Note that the automatic profile matching provided by Neat Image does work well in both cases: you can keep the whole set of profiles as a flat list of files in one folder, or you can structure the files into subfolders. This choice only affects the convenience of manual selection of profiles, while automatic profile matching can handle both cases equally well.

If the automatic profile matching is not available (for example, if the images or profiles contain no EXIF information or the available EXIF details are incomplete) then you have to select profiles manually. Therefore, we recommend to structure profiles according to one of the methods above to make your manual work easier.
5.3.4. Stage IV. Documenting profile set

Along with the text comments inside individual noise profiles and their file names, we advise to document the whole profile set with a plain text file explaining the following points:

- Author of the profile set and profiling date
- Device name, firmware version
- Device modes that have been profiled in this set
  - Device mode parameters that change within the profile set
  - Device mode parameters that are constant for all profiles in the set
- Post-processing applied (after receiving an image from the imaging device and before opening it in Neat Image)

An example of such a description is below:

Olympus Stylus SH-2 noise profiles
by John Smith, July 21, 2021

A set of profiles for Olympus Stylus SH-2 TIFF and JPEG files. The profiles were built using shots of the Calibration Target for the following file formats and image sizes:
  - TIFF: 4608x3506
  - JPEG Fine / Normal: 3200x2400 / 4608x3506

For each file format and image size above, shots with different ISO rates (125, 200, 400, 800, 1600, 3200, and 6400) were made and used to build profiles.

For Normal quality JPEG images ISO rates from 1600 to 6400 were not taken.

Default camera settings were used for Sharpness, Contrast, and Saturation. In-camera noise reduction was switched off. The white balance was set to daylight.

No post processing was applied; the calibration target shots directly from the camera were opened in Neat Image to build profiles.

Such kind of summary will later help you understand any set of profiles prepared by yourself and will let other people understand and correctly use your profiles if you decide to share the profile set.

5.4. Using noise profiles

When you have a set of profiles for your camera or scanner, you can directly use these profiles to process images in Neat Image. Usually there is only one profile that is most suitable to process a given input image. Therefore it is very important to select the right profile, which would provide the best match between profile and image. Profiles in a set usually correspond to different modes of the imaging device.

To make a perfect match between a profile and image, the device mode of a profile should be the same or very close to the device mode used to capture the image.

There are two ways to select a device noise profile that matches the input image:

- To automatically select the most suitable profile from a pre-built set of profiles using Auto Match (see page 16 to learn how to use Auto Match);
- To manually select the most suitable profile from a pre-built profile set based on file name and device mode comments (see page 15 for details).

When you select and load a profile in either way, Neat Image shows the degree of match between the profile and input image. This degree is shown by the Match indicator in the Device Noise Profile box. The match degree is calculated on the basis of the image and profile’s metadata (such as the EXIF data fields in images produced by digital cameras). If the profile’s device mode is exactly the same as the device mode used to capture the image then the match is 100%. There is always a 100% match between an image and profile built using this very image (Neat Image displays that using the note “(AP)” in the Match indicator). If the device modes of a profile and image are very close then the match degree is close to 100%. The more different the device modes of profile and image are, the lower the match degree is.
Use the match degree as an indication of match accuracy. If the match degree is low then it is likely that building a new profile (using the current input image or a shot of the Calibration Target taken in current device mode) would produce better noise reduction results.

Obviously it is preferable to build a new noise profile for each new input image (unless the image does not allow building a quality profile because it contains no large uniform areas for analysis), because such a profile would perfectly match the noise of that image. Nevertheless, any noise profile can, with some degree of accuracy, be used to process other images captured by the same device working in the same or similar mode. This is less accurate than building a profile for each image but saves time because building a new quality profile can take more time than re-using a pre-built one. This is especially important if one profile is re-used many times, for example to process a series of images produced in one device mode. Also, it may not always be possible to build an accurate profile using input image when it contains no flat featureless areas.

When using pre-built profiles, you may also want to pay attention to the Quality indicator in the Device Noise Profile box. A properly-built and fine-tuned profile will show a high value in that indicator. If the profile quality is high (for example, higher than 70%) then you can be sure that the profile is accurate.

Both Quality and Match indicators should usually show high values for the noise reduction of the current input image using the current noise profile to be accurate.
6. Additional tools

6.1. Variants of filtration

When adjusting the Neat Image filter settings, you may want to compare different adjustments and select one that delivers the best visual results. You can of course manually make the adjustments and check preview after each adjustment, but it would be easier if you could prepare several variants of such adjustments and then quickly switch between their corresponding previews. Then it would be much simpler to visually evaluate and compare the results.

That is exactly what variants of filtration do in Neat Image. You can create up to four variants, each with its own set of filters settings (and possibly different noise profiles too), and quickly switch between them to evaluate their previews. This feature is available in Advanced Mode.

Here is how you can use variants of filtration (for example in the Adjust and Preview tab):

1. To enable variants click (the Variants button) in the toolbar.

2. To create a new variant click (the Make a new variant button) in the toolbar. A new variant will be a copy of the current variant (the current profile and filter settings). The new variant is added to the toolbar as a new button with the corresponding name, for example . The new variant automatically becomes current, which is indicated by a special shading on its button.

When you make any adjustments to the profile or filter settings, they are applied and kept within the current variant. So if you want to change the profile or filter settings in any other variant, then you need to select that variant first and only then make any adjustments.

3. To select a variant (to make it current) click the corresponding variant’s button in the toolbar (or press the corresponding number key on the keyboard: 1, 2, . . . ). This will switch the profile, filter settings and preview to those of the selected variant.

If you then change the profile or any filter settings, these new changes will be applied to the newly selected variant.

4. To compare two variants (their previews) you can simply click their buttons (or keys on the keyboard) to select them alternatively.

There is also an easier and quicker way. If you right-click another (not the current) variant’s button instead of doing a regular left-click, then the clicked variant is only temporarily selected and the selection returns to the previous variant once you release the right mouse button. This can be used to quickly switch between any two variants (the current one and an alternative one) for comparison purposes: the preview will change from one variant to another and you can easily compare them to decide which one is better.

5. To delete an unneeded variant use its corresponding Remove variant button ( ).

6. When you are happy with one specific variant simply keep it current and it will then be used by Neat Image for actual processing.
6.2. Alternative modes of image viewer

The image viewer in Neat Image can show the working image in several alternative modes to enable detailed examination of both channel and frequency components. Examining the components helps to find flat featureless image areas for noise analysis. Also, that allows to visually compare the original and filtered version of each component and to find optimum filter settings for the corresponding component easier and faster.

Use (Viewer mode button) in the viewer toolbar to select the desired viewer mode.

The viewer mode will change accordingly and will display the image components separately or as one composite image.

Examine individual channel and frequency components of the image, check the presence of noise in individual components. Working in the Noise Filter Settings tab, you can use the separately displayed components to identify those components that do not receive enough (or receive too much) noise reduction and adjust the corresponding filter settings.

You can also adjust the brightness of the viewer to easier see image details and noise in very dark or very bright areas of the image:

Use (the viewer brightness controls) in the viewer toolbar to adjust and/or reset the viewer brightness to better see the noise and details in very dark or very bright areas of the image.

Please note that this adjustment does not change the underlying image data in any way. The adjustment only affects the image viewer, i.e., the way the image is displayed in it.

6.3. Navigator

The image viewer has an additional Navigator panel, which offers an easy way to locate and navigate to an area of interest in a large image that does not entirely fit into the viewer, for example when you zoom into the image to see its fine details. When using Navigator you do not need to zoom out and then again zoom in (though such an approach to locating an area of interest can be used as well).

Use (the Navigator button in top-left corner of the viewer), the View > Navigator > Show Navigator menu item or press F8 to open or close the Navigator panel.

Use the mouse pointer to drag the visible area frame (the red rectangle) to the desired part of the image within the Navigator panel. This will make the main viewer navigate to the same position in the image.
6.4. Profile Viewer

The **Profile Viewer** provides detailed information about the current noise profile.

- Use ![Profile viewer button](image) (the **Profile viewer** button) in the **Device Noise Profile** box in the **Prepare Noise Profile** tab to open the **Profile Viewer** window.

The **Profile Viewer** provides the following details:

- **Image Metadata** – this box contains the metadata (such as the EXIF information) associated with the image used to build this profile. This information is used by **Auto Match** to find a profile that matches an input image.

- **Main Noise Sample** – this is a noise sample (a crop from the image used to build this profile). The noise sample allows to visually evaluate the noise described by this profile. Also, you can easily see whether any details are present in this area, which would make the profile less accurate (only flat featureless areas without any details should be used for profiling, so the sample should normally contain no visible details).

- **Clipping** – this indicator tells whether there is any clipping in the analyzed image area. Clipping occurs when the sample contains pixels that are very close to or in fact are entirely white, entirely black or have exactly the same color/tone. Clipping reduces the overall profile quality.

- **Uniformity** – these values show how uniform the noise sample is in all color channels. The uniformity is low when any details are present in the area. Low uniformity reduces the overall profile quality.

- **Overall Profile Quality** – this is an estimation of the overall quality of the noise analysis contained in this profile. The higher this value the better this profile seems to be. A quality profile is necessary for quality noise reduction.

- **Noise Levels** – these figures show the actual noise levels measured during profiling. There are the noise level of the main sample, average noise level of the whole profile and noise levels of the channel and frequency components. These figures are a good indication of how noisy the image acquisition device is.

- **Fine-Tuning Completeness** – this indicator tells how well this profile is fine-tuned. Fine-tuning is a part of profiling process (both automatic and manual) and the more complete and accurate the fine-tuning the higher the overall profiling quality. If you work with Neat Image in **Advanced Mode** then you can see that the more equalizer values are filled in with measured data the higher the overall profile quality is. You can improve the profile quality by additional fine-tuning.
7. Batch processing

Neat Image standalone (Win) can automatically process multiple images. To do that, you can create several image filtration tasks (one task corresponds to one input image to be processed) and let Neat Image process the tasks one after another.

You can create several tasks one by one and you create many tasks at once.

You can use the same filtration parameters for all tasks or customize groups of tasks or individual tasks with different filtration settings. You can modify parameters of any task at any time.

In this section, we explain in details how you can use all these capabilities of Neat Image.

7.1. All Tasks tab

When you normally start Neat Image, it usually opens with the Editor tab open. To process many images switch to the All tasks tab: [All tasks] (if there is no All tasks tab, press the Esc button).

Then you can process many images using the tools available there. This is how it looks like:

![All tasks tab](image)

The All tasks tab contains the list of image filtration tasks (in the central part of the window), a set of tools to create, edit, configure, remove, start and stop tasks, and the panel on the right with detailed information about the currently selected task(s).
7.2. Creating new image filtration tasks

Each filtration task in Neat Image includes one input image and one customized set of filtration settings. To process many images you must create many image filtration tasks using the available methods:

To create one image filtration task

- Click (the Add new task(s) button) in the toolbar and then select Add Image(s)... in the popup menu; or use the Task > Add Image(s)... item in the main menu.

Neat Image will then open the Select input image(s) dialog to let you select the input image to be processed. Select an image on the disk and click the Open button.

A new filtration task with the selected image will be created and added to the list of tasks. The left panel of the Neat Image window will also show the thumbnail of the added input image.

At this point you can proceed to work with this new task in a single-task manner (using the workflow described in the Filtration process details section, page 11; to do that just click in the toolbar or click the Edit this task icon inside the thumbnail of the task in the left panel).

Instead of going to Editor to work with new task, you may also want to create more filtration tasks using the same procedure described above and later configure the created tasks all at once and let Neat Image process them all together. Or you can also create several more new filtration tasks in a more automated ways as described below.

To create several image filtration tasks

Method 1: select several images

- Click (the Add new task(s) button) in the toolbar and then select Add Image(s)... in the popup menu; or use the Task > Add Image(s)... item in the main menu.

In the Select input image(s) dialog, select several images instead of one (you can hold the Shift or Ctrl key pressed to select multiple images) and then click the Open button.

A new filtration task will be created for every selected image. All newly created tasks will be added to the list in the All tasks tab. The left panel of the Neat Image window will also show thumbnails of the added input images. The settings of new tasks will be based on the Defaults specified in the Preferences.

Method 2: select a folder with images

- Click (the Add new task(s) button) in the toolbar and then select Add Folder... in the popup menu; or use the Task > Add Folder... item in the main menu.

In the Browse For Folder dialog, specify the folder with images that you want to process and then click the OK button.

A new filtration task will be created for every image found in the specified folder and all its sub-folders. The new tasks will be added to the list in the All tasks tab. The left panel will also show thumbnails of the added input images. The settings of new tasks will be based on the Defaults specified in the Preferences.
Method 3: select any combination of images and folders and customize task settings

- Click (the Add new task(s) button) in the toolbar and then select Batch... in the popup menu; or use the Task > Batch... item in the main menu.

Neat Image will then open the Batch dialog to let you specify the input images, device noise profiles to be used, filter settings, output settings, etc.

- Locate the images to be processed using the browser in the Input Images box (left side of the dialog). Check boxes against individual image files to be processed and/or against folders with images (then all images in checked folders and sub-folders will be selected for processing as well).

To check the boxes use the mouse or press the Space button on the keyboard.

When selecting individual images you can see their thumbnails and metadata in the Image metadata box in the central part of the dialog window. Use that preview to select right images for processing.

- In the Device Noise Profiles box, specify how noise profiles should be prepared for the images selected in the Input Images box:
  - Do not prepare profile - to not automatically prepare any profile(s); do that later manually
  - Auto Profile - to automatically build a profile for each image
  - Auto Match - to find the best matching profile for every image
  - Smart Profile - to try both Auto Profile and Auto Match and select the best profile
  - Use specified profile - to use a specified profile for all images

When Use specified profile is selected, click (blue folder) or the popup menu (click ) to specify the noise profile to be used.

When available, check the Auto fine-tune option to automatically fine-tune selected profile(s) during processing. When Auto profile image is selected auto fine-tuning is applied automatically.

- In the Filter Settings box, select the filter preset to process the images selected in the Input Images box:
  - Use default filter preset - to use the default preset specified in Preferences > Defaults;
  - Use spec. custom preset - to use a custom preset loaded from the disk.

When Use specified custom preset is selected, click (pink folder) or the popup menu (click ) to select a filter preset to be used to process the selected images.
In the **Output Images** box, specify the **Bitdepth** using the drop-down list. Select **8 bits per channel**, **16 bits per channel**, **32 bits per channel** or **Match input**. In the latter case, the output images will have the same bitdepth as the corresponding input images.

Select the way the output image should be saved when filtration is finished:

- **Do not auto save output.** - to not automatically save output images (save manually)
- **Save to folder(s) of input.** - to automatically save the output images next to the input images
- **Save to specified folder** - to automatically save the output images into one specified folder

With **Save to specified folder**, you can select the target folder using (the **Browse** button).

Select the output **File format**: JPEG, TIFF, PNG or BMP. When JPEG is selected, you can also adjust the JPEG **Quality** level (50-100; 100 is the highest for the best quality, 50 is the lowest for the smallest file size). With PNG, you can select the Compression level (0 is for the lowest compression and 9 is for the highest compression / smallest file size).

Below the **Output Images** box, check **Auto remove completed tasks** if you want to automatically remove completed tasks from the list of the filtration tasks. This is only possible if Neat Image is instructed to automatically save the output images (otherwise the output images would be lost). Once the output images are saved, the tasks can be removed from the list.

Click **Add tasks** to add new image filtration tasks to the task list. Several new filtration tasks will be created in the list.

Neat Image may then automatically start processing these new tasks, provided:
1. The new tasks are ready for processing (contain valid input images and noise profiles)
2. Processing is not generally suspended.

Please see the Processing image filtration tasks section, page 51, for further workflow details.

**Method 4: use drag and drop**

Drag one or several image files from another application (for example, from Windows Explorer) and drop them in Neat Image window. Neat Image will automatically create new filtration tasks for each dropped file. The settings of new tasks will be based on the **Defaults** specified in the **Preferences**.

**Method 5: use Send To command in Windows Explorer**

Select one or several image files in Windows Explorer, right click on them and use **Send To > Neat Image**. Neat Image will automatically create a new image filtration task for each selected image file. The settings of new tasks will be based on the **Defaults** specified in the **Preferences**.

### 7.3. Configuring image filtration tasks

You can change the parameters (such as noise profile, filter preset, etc.) of any filtration task available in the list of tasks. Usually, you will change some parameters during or after adding new tasks. For example, after adding some new tasks you may want to instruct Neat Image to use **Auto Profile** to prepare noise profiles for all these tasks. Or you may specify a fixed noise profile available on the disk. Or assign a specific custom filter preset to process all selected tasks. All that can be done directly in the **All tasks** tab using the controls available around the task list. Below you will find a description of all these controls. To use any of them to adjust parameters of one or several tasks, select some tasks in the list of tasks and then use the tools as described below.

**To assign a noise profile to selected task(s)**

Select one or several tasks in the list of tasks and:

- Click (the **Auto Profile** button) in the toolbar or use the **Task > Auto Profile** menu item to instruct Neat Image to use Auto Profile to automatically build a new noise profile for every selected task.
- Click (blue folder) in the toolbar or use the **Device noise profile** popup menu in the **Filtration Task** box (or use the **Task > Set Profile...** menu item) to specify a noise profile to be used in all selected tasks.

- Click (the **Profile Matcher** button) in the toolbar or use the **Task > Match Profile** menu item to automatically find and assign matching profiles to selected tasks.

- Click (the **Auto Fine-Tune** button) in the toolbar or use the **Task > Auto Fine-Tune** menu item to make Neat Image automatically fine-tune the assigned noise profile to the input image for every selected task.

### To assign a filter preset to selected task(s)

Select one or several tasks in the list of tasks and:

- Click (pink folder) in the toolbar or use the **Filter preset** popup menu in the **Filtration Task** box (or use the **Task > Set Preset...** menu item) to assign a filter preset to all selected tasks.

### To edit a selected task in Editor

Please note that you can apply only most general changes to the tasks using the tools available in the **All tasks** tab. For example, you can assign a specific noise profile to a group of tasks. However, to do any more subtle modifications like manual profiling with some manual tuning of filter settings requires using the **Editor**. To do that simply select any task and open it in the **Editor** tab for detailed examination:

- Select a task in the list and click (the **Edit selected filtration task** button) or use the **Task > Edit...** menu item.

Neat Image will open the selected task in the **Editor** tab to let modify all details of the test: input image, device noise profile and filter settings. You can then use the tools and workflow described earlier (the **Filtration process details** section, page 11).

At any moment, you can switch back to the **All tasks** tab, select another task, apply any changes, etc.

It is also possible to switch to another task directly within the **Editor** tab using the thumbnail panel in the left part of the window: double-click the thumbnail of the desired task to switch **Editor** to that task or use the buttons and in the top to switch to the previous and next task in the list.

It is also possible to switch to the previous and next task using the keyboard shortcuts (see the **Edit** menu for details).

### 7.4. Processing image filtration tasks

As soon as you have created one or more filtration tasks, Neat Image will try to automatically process them, unless processing is manually suspended. You can control that using the buttons in the left bottom corner of the Neat Image window, right above the **All tasks** tab:

- Click the (the **Suspend All** button) to suspend processing all tasks in the list.

- Click the (the **Resume All** button) to resume processing all tasks in the list.

Not every task can be automatically processed though. To be processed automatically, a task must be configured, which means it should have an input image and noise profile specified. While an input image is almost always available, a noise profile may be in some cases not available. A newly created task may get a noise profile from the **Defaults** section of Neat Image **Preferences** (menu **Tools > Preferences > Defaults**), or you may specify it manually when creating or configuring the task.

If some of the tasks do not yet have any assigned noise profile (they show the status “**profile not ready**” in the **Profile** column in the list of tasks) you can assign a profile using one of the options described the previous section (**Configuring image filtration tasks**, page 50).

As soon as a task is provided with a profile, it can be automatically processed and Neat Image will immediately try to do that. You will then see running progress indicators, changing statuses of profile, its quality, match level, output image, etc.
You can stop processing at any moment using the above Suspend All button and resume it later.

7.5. Reviewing processing results

When image processing is completed and several tasks already contain some results (such as newly built noise profiles and output images produced by the filter), you may want to quickly review the results to verify the visual quality of the output images and if necessary to check the areas used by Auto Profile. To do that open the Editor tab, switch to the Output Image tab in there, and then visually inspect the output image in that task. Then you can switch to the previous or next task using the buttons and in the top of the thumbnail panel or using the keyboard shortcuts (see the Edit menu for details). In this way, you can inspect the processing results for all tasks and if necessary adjust those tasks where results are not fully satisfactory. For example, you can adjust the filter settings or re-build the noise profiles in those tasks.

Because building noise profiles using noise-only areas is very important for accurate noise reduction, it may also be useful to directly review the image areas found and used by Auto Profile: switch to the Prepare Noise Profile tab and then check the selected area (it should contain visible noise and no useful details). Then do the same for all other tasks by switching from one task to another using the buttons and or keyboard shortcuts. If you see that the area selected by Auto Profile contains any details or is otherwise not good for profiling (for example, if it shows some clipping or contains no visible noise at all), select another area manually, re-build the profile and then re-process the image to get better results.

7.6. Saving output images

When an image filtration task is completed, Neat Image will try to automatically save the output image (if you instructed it to do so or if the Output settings in Preferences instruct it to save output images automatically). You can also save the output image manually, either from the Editor tab or directly from the All tasks tab. In the All tasks tab, you can save several output images at once.

To automatically or manually save output image(s) of filtration task(s)

- Select one or several tasks (they do not need to be fully processed yet) and click (the Save output image as button) in the toolbar or use the Task > Save Output... menu item.

    Neat Image will open a dialog to let you specify how you want to save the output images of all selected tasks (when these output images will be ready, if they are not prepared yet).

    Neat Image may ask about particular image saving properties, e.g., the JPEG quality level, about the folder where you want to save the output images.

    In some cases, you can additionally select the option called Auto remove completed tasks. When that option is enabled, Neat Image will remove (in other words close) the tasks from the list of tasks after saving the output images to the disk. If it is not selected, you can later remove the completed tasks manually.

    You can instruct Neat Image to always automatically save output images (use the menu Tools > Preferences > Output > Auto save output images). In this case, you will not have to manually save output images; Neat Image will do that for you automatically whenever possible.
7.7. Removing image filtration tasks

To remove image filtration task(s) from the list

When you finished working with an image filtration task and saved the filtered output image to the disk, you may not need this task anymore and may want to remove it from the list of tasks.

- Select one or more filtration tasks in the list that you want to remove and click (the Remove selected filtration task button) or use the Task > Remove menu item or just press the Delete button on the keyboard.
8. Preferences

There are several preferences that adjust the behavior of Neat Image standalone (Win).

Use the Tools > Preferences... menu item to open the Preferences dialog box.

8.1. General preferences

Auto zoom to fit on image open

Check this option to make the image viewer automatically adjust zoom level to fit the image into the window.

Show hints over interface controls

This option switches on/off the hints. The hints are displayed when the mouse pointer is placed over any control in the Neat Image interface.

Show splash screen at startup

This controls whether the splash screen (the Neat Image logo) is displayed at the application startup.

Color Theme

Normal brightness

Neat Image will display its interface elements using the color theme with normal brightness.

Reduced brightness

Select this option to switch Neat Image to a custom color theme with reduced brightness.

Auto-detect brightness

Neat Image will try to detect the system color theme and adjust its own color theme accordingly.

Updates

Periodically check for software updates

Neat Image can automatically access the Internet to check whether an updated version of the software is available on the webpage of Neat Image.

Unless this option is disabled, Neat Image will automatically look for updates every few days.

You can also manually run such a check using the Check Now button available there.

Neat Image will display the currently installed version of the software as well as the latest available version of the product that can be downloaded. When a newer version is available you can use the provided download link to visit the download area to download and install the updated version.
8.2. Defaults

Default Device Noise Profile

There are several possible ways to assign a noise profile to a newly created image filtration task:

- **Do not prepare noise profile automatically**
  If this variant is selected then no device noise profile is loaded when a new task is created. You will have to manually assign or build a noise profile for the input image.

- **Auto Profile**
  If this variant is selected then a new profile is automatically built by analyzing the input image. This provides the most accurate noise analysis but takes a bit more time and may not always work (if the input image does not contain enough flat featureless areas for analysis).

- **Auto Match**
  If this variant is selected then the Auto Match function tries to select the most matching profile (matching the input image) from a pre-built set of profiles. This provides shorter overall processing times when pre-built noise profiles are available and can be matched against the input image (matching requires both profiles and images to contain EXIF metadata).

- **Smart Profile (Auto Profile and Auto Match)**
  If this variant is selected then Neat Image uses both Auto Profile and Auto Match to prepare two noise profiles and then selects the better one of those two profiles. This provides higher overall quality at expense of slightly longer processing time. To be fully efficient, this option also needs a pre-built set of noise profiles (for Auto Match to work). You can configure the behavior of the Smart Profile function in the Smart Profile section of the Profiling tab.

- **Use specified default profile**
  If this variant is selected and a valid profile is specified then it is automatically loaded when a new image filtration task is created. Useful when all input images (in a series you need to process) have been produced by the same device working in the same or very similar device modes.

- **Auto fine-tune**
  If this option is checked then Neat Image additionally fine-tunes the assigned noise profile by analyzing the input image. This provides higher accuracy of resulting noise reduction when the input image contains flat featureless areas suitable for fine-tuning analysis.

Default Filter Preset

There are two ways to assign a filter preset to a newly created image filtration task:

- **Program’s default settings**
  If this variant is selected then no custom preset is loaded from the hard drive when a new filtration task is created. Instead, Neat Image uses its pre-programmed default filter settings. You still can adjust the filter settings manually or assign a different filter preset for the filtration task after the task is created with these default settings.

- **Specified custom preset**
  If this variant is selected and a valid filter preset is specified then it is automatically loaded when a new task is created. This setting is useful when you want to apply filtration using the same custom default filter settings to all input images. You still can adjust the filter settings manually or assign a different filter preset for the filtration task after the task is created with the defaults from this custom preset.
8.3. Profiling preferences

Save noise samples in profiles

Enable this option to make Neat Image save a noise sample from the analyzed image area into device noise profile (*.dnp file). This will increase the size of the *.dnp file, but will also improve the compatibility with the future versions of the software (Neat Image will be able to re-build the profile using the saved noise sample).

Show warnings about selected image area

Enable this option to let Neat Image display possible warnings about the selected image area during profiling. For example, Neat Image may warn you about clipping or non-uniformity detected in the selected area, thus helping you select a better area for profiling.

Smart Profile

Smart Profile is one of the possible ways to prepare a noise profile for an image filtration task. Smart Profile uses both Auto Profile and Auto Match (with Auto Fine-Tune) to prepare two candidate profiles and then selects the better one of two profiles.

Use the settings in the Smart Profile box to configure the behavior of the Smart Profile function.

Automatically select the best profile

Use this option to let Neat Image automatically decide which noise profile to use.

Prefer profile prepared by Auto Profile

Let Neat Image preferably select the profile prepared by Auto Profile when it can find a good area for analysis in the input image. When the area is not very good then Neat Image will use the profile prepared by Auto Match with Auto Fine-Tune.

Prefer profile prepared by Auto Match and Auto Fine-Tune

Let Neat Image preferably select the profile prepared by Auto Match when it can find a matching profile among the pre-built noise profiles, even when Auto Profile provides a good profile as well.

8.4. Matching preferences

8.4.1. Profile Matching

Use profile matching preferences to adjust the way Neat Image matches noise profiles to input images.

Look for noise profiles in the following folder

If you select this option then Neat Image will look for matching noise profiles in the specified folder. If you have several sub-folders with profiles, select the topmost folder of all those subfolders to let Neat Image search in all of them.

By default, the folder used to store profiles (see the Folders > Profile folder setting in the same Preferences window) is used for matching. You can use any other (sub-)folder for profile matching as well.

Look for noise profiles in folders of input images

If this option is selected then Neat Image will look for matching profiles in the folders of the input images. If you put desired noise profile to a folder with input images and select this option then Neat Image will select this profile for every image from that folder. If there are several profiles in such a folder then the best matching will be selected for every input image.
Matching Parameter Priorities

To automatically match profiles for the input image, Neat Image compares the device parameters of the input image and candidate profiles selected from the folder specified by the above options. Different parameters usually have to be matched with different priorities. Using Matching Parameter Priorities controls, you can select the priorities of such parameters as Input device, ISO rate, Compression, Resolution, Sharpness, Exposure:

- **Match** - the parameter must match exactly;
- **High** - it is highly important that the parameter is very close or matches exactly;
- **Low** - it is preferable that the parameter is close or matches exactly;
- **Ignore** - the parameter is not important at all.

8.5. Filtration preferences

Main Window

**Auto restore on finish** is to restore the application window (if it was minimized during processing) when all filtration tasks are done.

Processing Priority

Use this option to adjust the priority to the Neat Image filtration process running in a multitasking environment:

- **Idle** - lowest priority; filtration gives way to other applications when necessary;
- **Below** - priority below normal; provides the smoothest performance for all applications; this may slow down Neat Image a bit, but will allow you to work normally with other applications, especially if the computer is not fast;
- **Normal** - normal priority; filtration may somewhat slow down other applications.

Preview

**Preview cache size**

This option allows to set the size of the preview cache memory. Using large preview cache allows to update the preview faster when you adjust the filter settings and try different variants and options. However, this also requires more memory for the cache. You can adjust this parameter to achieve the right balance between update speed and memory use.

**Limit preview size**

This option allows to limit the maximum size of the automatic preview area (the preview area selected by Neat Image itself when you do not select any area manually). Limiting the preview size can be useful because updating a smaller area is faster than updating preview for the whole image. Also, preparing a larger preview requires more memory resources, which may be a significant factor on machines with small amounts of memory resources.

By default, this option is enabled, so if you work with a large image, then the preview is limited to a part of the image. That limitation only affects the preview, while the final image is processed fully. You can always adjust the limit upwards or downwards, depending on your needs.

If you disable this option completely, then there will be no limit at all and the whole image will be processed for preview.
8.6. Performance preferences

The first group of settings in this tab selects the computing devices to be used for image processing. This group of settings is optional, it is shown only if at least one supported GPU (graphics processing unit) is available along with the regular CPU (central processing unit, or processor). This group includes the following items:

**Use CPU only**

This option makes Neat Image perform all image processing using CPU only.

**Use GPU only**

This option makes Neat Image perform all image processing using GPU only, when possible.

**Use CPU and GPU**

If you select this option then Neat Image will process images using both CPU and GPU.

Depending on individual performance of each computing device (CPU and GPU), each of the above options may be the most efficient. You can try different settings and measure the resulting speed using the **Check Speed** tool below.

**CPU**

**Number of used cores**

This option adjusts the number of CPU cores used by Neat Image for processing. The number of used cores can go up to the total number of cores in all CPUs in your computer (like 4 cores in Core i3 with enabled hyperthreading, 8 cores in a desktop version of Core i7, etc.). If the computer includes two physical CPUs then the number of cores is correspondingly higher. Ideally, using all cores should provide the best overall performance. In some cases however, the best processing speed may be achieved if fewer cores are used (especially on CPUs with hyperthreading). For example, using fewer than all 8 virtual cores in a Core i7 is in some cases faster, so you may want to test different values of this setting.

**GPU**

In this box, you can specify which of the available computation-capable GPU devices (CUDA-capable NVIDIA cards and/or supported OpenCL-capable AMD cards) should be used for image processing (in addition to CPU or instead of CPU). When you have one or more GPUs, you can allow Neat Image to use it and specify how much GPU memory may be used for Neat Image’s image processing. When you also run other software that uses the GPU, you may want to allow Neat Image to use only a part of the available GPU memory and leave some part of it free for the other software. When you are not sure, try different values and see which setting gives the best overall results in terms of performance.

**GPU Advanced Settings**

Use the **Advanced Settings** button to open a specialized dialog and verify the GPU detection log for errors or problems reported there. That can help in a situation when one or more of the GPUs of your computer are not visible in Neat Image or cannot be enabled. The GPU detection log may offer some insight into the possible causes.

Also, you can completely disable GPU support via CUDA / OpenCL using the corresponding checkboxes available in that dialog. You can use that for troubleshooting purposes.

**Check Speed**

Use the **Check Speed** button to measure the image processing speed with the current settings specified in the CPU and GPU boxes.
Optimize Settings

Use the Optimize Settings... button to open a specialized dialog designed to measure image processing speeds achieved with different combinations of the CPU and GPU settings. It allows to automatically benchmark all possible combinations of settings and to identify the best combination. This is the easiest way to optimize the performance of Neat Image for specific CPU and GPU hardware.

GPU Advanced Settings

Use the Advanced Settings... button to open a specialized dialog and verify the GPU detection log for errors or problems reported there. That can help in a situation when one or more of the GPUs of your computer are not visible in Neat Image or cannot be enabled. The GPU detection log may offer some insight into the possible causes.

Also, you can completely disable support for NVIDIA and/or AMD GPUs using the corresponding checkboxes available in that dialog. You can use that for troubleshooting purposes.

8.7. Folder preferences

Profile Folder

Select the folder where Neat Image must look for device noise profiles. This should be the topmost folder of all the (sub)folders with device noise profiles. Neat Image will display all profiles (stored in all subfolders of the specified folder) in the popup menu in the Device Noise Profile panel of the application window and in other parts of Neat Image.

By default, the Profile Folder is located in your Documents folder: Documents\Neat Image v9 Standalone\Profiles\ You can select another location to store and use your Neat Image profiles if you prefer.

Preset Folder

Select the folder where Neat Image must look for filter presets. This should be the topmost folder of all the (sub)folders with filter presets. Neat Image will display all presets (stored in all subfolders of the specified folder) in the popup menu in the Filter Settings panel of the application window and in other parts of Neat Image.

By default, the Preset Folder is located in your Documents folder: Documents\Neat Image v9 Standalone\Presets\ You can select another location to store and use your Neat Image presets if you prefer.

Show preset description on load

Enable this option to make Neat Image show the description of the filter preset when you load it from the disk. The descriptions available in some presets (for example, in presets supplied with Neat Image) is intended to help you get a better understanding of the purpose, applicability and possible side effects of the preset.

Temporary Folder

Select the folder that Neat Image must use to store its temporary files.

Folder History

Use independent load and save folders

Enable this option to make Neat Image use independent folders in its file open and save dialogs. If disabled (the default setting), a save dialog will show the folder where the object (for example, a noise profile) was loaded from.
Use independent folders for images/profiles/presets

Enable this option to make Neat Image use independent folders in its file dialogs for different types of objects: images, noise profiles and filter presets. If disabled, Neat Image’s file dialogs will open the same folder when working with different types of objects. By default, this option is enabled.

8.8. Output preferences

8.8.1. Save Settings

Allow overwriting existing image files

Enable this option to allow Neat Image overwrite existing image files when output images are auto saved by the application (for example, when Neat Image automatically processes multiple images). Overwriting may be required when you process the same image several times and want to replace the previous result. Or if you need to save the output image with the same file name as the name of the input image.

Preserve image metadata in output image files (when possible)

Enable this option to make Neat Image preserve the EXIF, IPTC and other metadata by copying these from the input to output images. Note that copying the metadata to the output image is not always possible. This depends on both input and output file types used and on type of metadata as well. The EXIF data are copied with the following combinations of input and output file types: JPEG-> JPEG, JPEG-> TIFF, TIFF-> TIFF, and TIFF-> JPEG. The IPTC data are copied with the following combinations: JPEG-> JPEG and TIFF-> TIFF.

Preserve original timestamp in output image files

Enable this option to make Neat Image preserve the original image’s file timestamp (the date and time when the image file was created and/or modified) by copying it from the input to the output image file. This will keep the output images in the same relative order as the input images when sorted by date and time.

Important note: Do not enable this option if you use Neat Image as an external editor in Lightroom. Otherwise Lightroom will not recognize that the image has been successfully processed by Neat Image.

Output bitdepth

This option controls the bitdepth of the images processed by the filter. For example, if the input image has 8 bits per channel and the output bitdepth is selected to be 16 bits per channel, then the input image will be converted to 16-bit representation, processed with the filter, and the output image will be 16-bit. If ‘Match input’ is selected then the output bitdepth will match the input bitdepth.

Output file name suffix

Select the suffix added to the output image file name by default (to differentiate processed images from originals). Note that the suffix can be empty only if the Allow overwriting existing image files option is enabled (see above).

Auto save output images

Enable this setting to let Neat Image automatically save output images when they are ready.

Save Filtered Images To

Folder(s) of input images

Enable this option to save each output image beside the corresponding input image.
**Specified folder**

Enable this option and specify a folder to make Neat Image save all output images to that folder.

**Output File Format**

**Format**

Select the output file format to be used by default when the output image is saved by Neat Image.

**Quality / Compression**

Select the JPEG quality level (or PNG compression level) to be used by default when the output image is saved by Neat Image in the JPEG (or PNG) format.

**Auto remove completed tasks**

Enable this option to automatically remove from the list of tasks (in other words, close) image filtration tasks that have been fully processed and saved.

**Use settings above to save output images (do not ask every time)**

Enable this option to make Neat Image automatically save output images using the settings from this tab. Neat Image will then silently save output images without opening the Save Settings dialog for every image. In this way you can set the desired output settings once here and not be asked to adjust them each time you save an output image.
9. Command line version

Besides the GUI (graphical user interface) version of Neat Image, there is also a separate command line (CL) version. It can also build noise profiles and filter one or more images.

To see how to use the command line version of Neat Image, open Windows Command Prompt and execute the following command:

```
"C:\Program Files\Neat Image v9 Standalone\NeatImageCL.exe"
```

This will display the description of command line format of the CL version. Use the description to formulate new commands for the CL version.

Please note that the CL version of Neat Image uses the settings specified in the Preferences of the GUI version. Therefore, if you want to adjust any of those settings please start the GUI version, adjust the settings and apply, close the GUI version, and then use the CL version.
10. Using Neat Image with Lightroom

Neat Image standalone can be used with Lightroom in two different ways:

1. You can manually save and load intermediate files to exchange images between Lightroom and Neat Image.

2. Neat Image can be used via the “External Editor” facility available in Lightroom (this option is available with Home and Pro edition of Neat Image standalone, Demo will not work).

To use the second method with either Home or Pro edition of Neat Image standalone (Win) you must set up Neat Image as an external editor in Lightroom using the following steps:

1. In Lightroom, go to menu Edit > Preferences... > External Editing.
   In Additional External Editor box, click Choose and select NeatImage.exe (in C:\Program Files\Neat Image v9 Standalone).  

2. In the same Additional External Editor box, select File Format: TIFF; Bit Depth: 8 or 16 bits/component (depending on your images); Adjust Color Space, Resolution and Compression as desired.

3. In the top of the Additional External Editor box, click the Preset drop-down and select the option: Save Current Settings as New Preset.
   Enter the name “Neat Image” and click the Create button.

4. Click OK to save changes.

From now on, you can use Neat Image as an external editor using the following steps:

1. Go to menu Photo (or right-click the image) and select Edit In > Neat Image.

2. In the Edit Photo with Neat Image dialog, select Edit a Copy or Edit a Copy with Lightroom Adjustments (and uncheck Stack with original if that option is available in your version of Lightroom); then click Edit.

   Lightroom will then save the image into a new TIFF file and invoke Neat Image for that file. Please note that image will be converted to specified format (for example, to 16-bit TIFF, if that was specified above) only when you select “Copy with Lightroom Adjustments”, otherwise Lightroom will just copy the original image file.

   Neat Image will add that new file as a new image filtration task and it will appear in the list of tasks in Neat Image. If Neat Image has been already running, you may need to select that new task in the list and click (the Edit selected filtration task button) or use the Task > Edit... menu item.

3. Process the image using the regular Neat Image workflow (see the section Filtration process details, page 11, for more details).
   In the end of the workflow, save the filtered image into the same TIFF file overwriting the input image file (the file exported by Lightroom to Neat Image for processing).
   Note: to facilitate overwriting input images, adjust the output settings in Neat Image Preferences: go to menu Tools > Preferences > Output, make the Output file name suffix field empty and enable the Allow overwriting existing image files option.


5. You are now back in Lightroom and the TIFF image filtered by Neat Image is now also returned to Lightroom. You can further work with that new image in your regular workflow.

Please note that you can also send several images to Neat Image instead of just one. To do that, select the files you want to process and follow steps 1-5 above.
11. Examples

11.1. Images to build a noise profile

The image below contains examples of areas that are “good” and “bad” from the standpoint of profiling. Here, "good" image areas are highlighted in green, these should be at least 32x32 pixels large, preferably more than 128x128 pixels; “bad” ones are highlighted in red. If the input image you have does contain similar “good” flat featureless noise-only areas as shown in the example then you can be sure that Auto Profile will produce an accurate noise profile. However, if there are no such flat featureless areas in the input image, then Auto Profile will not work well because building a profile using an area containing details produces an inaccurate profile that will then lead to very inaccurate filtration. In such a case, you can build a noise profile using an alternative image containing flat featureless areas or you can use a shot of the Calibration Target taken by the same camera working in the same mode or you can build a generic profile.

Additional comments regarding the “good” and “bad” areas in this example are available in the next page.
These image areas are good to build device noise profiles, as they contain no visible details

— **GOOD**, because this area contains no important details

— **GOOD**, no important details (this area is from another image)

Examples of “bad” areas that contain visible details:

— **BAD**, because this area contains a detail: corner – junction of wall and ceiling

— **UNACCEPTABLE**, because this area contains many details

— **BAD**, because this area contains some details: some gradients caused by differences in illumination of the area

See more examples of building noise profiles on the Neat Image web page:
https://ni.neatvideo.com/support/how-to-use/device-noise-profiling
11.2. Filtration results

Here are some examples of Neat Image performance.

This is a small portion of a digital photo taken with a compact digital camera. The original image contains easily visible noise. In this case, the source of noise is the camera’s image sensor (CCD) working in high ISO mode.

This image was also taken with a different digital camera. Along with the strong high ISO noise, there is an image degradation caused by the JPEG compression. Even though Neat Image tries to do its best to clean up such images, please avoid using strong JPEG compression.

See more filtration examples in the Neat Image web page: https://ni.neatvideo.com/examples
12. Questions and answers

12.1. General questions

Q What is the difference between Neat Image Demo, Home and Pro editions of Neat Image?
A Different editions have different functional capabilities and limitations as described by the Detailed feature map, page 70.

Q Should I uninstall Demo edition prior to installing the Home / Pro edition?
A This is not necessary. You can install the Home / Pro edition over the Demo edition. Please make sure Neat Image is completely closed when you install the Home / Pro edition.

Q Should I uninstall the older version of Neat Image prior to installing a newer one?
A This is not necessary. You can simply install a newer version of Neat Image. It will either replace the old one or will be available along with the old one (depending on the version).

Q I think I have found a bug. How can I submit a bug report?
A Please use the online bug report form: https://ni.neatvideo.com/support/report-bug
Please fill it out to let us know all the details necessary to reproduce the problem.

See more information about bugs in the Known issues section in Neat Image webpage (https://ni.neatvideo.com/support/known-issues) and about bug fixes in the WhatsNew.txt file supplied with the software (also see the history section on the web page for the most up to date information: https://ni.neatvideo.com/features/version-history/ni9sl?os-tab=win).

Q What about batch processing?
A Neat Image supports batch processing. Please see the Batch processing section, page 47.

12.2. Filtration-related questions

Q Why do I receive some crystal-like artifacts in the filtered image?
A The crystal-like artifacts (usually these are the residual compression artifacts or residual noise) look like thin lines in the filtered image. They can be eliminated by increasing the (high frequency) noise level in the filter settings or by using the dedicated Artifact Removal filter described in page 24.

Note: presence of many residual artifacts may be caused by using a poorly built, inaccurate noise profile or a profile built for another device and/or device mode. Therefore the solution could be re-building the noise profile.

Q Filtered image looks ‘plastic’. Why?
A The reason is that too much filtration has been applied. Let Neat Image keep some noise to produce more natural-looking results. Adjust the noise reduction amounts; for example, set the Noise Reduction Amount > Luminance control to 30-50%. Also, make sure the device noise profile does match the input image processed. Using an incorrectly chosen or poorly built noise profile can either produce plastic-looking results or leave residual artifacts (see the previous question).

Q What is frequency?
A The term (spatial) frequency is used in Neat Image to denote elements of an image (both important details and noise/grain) of certain size.

High frequency corresponds to elements of smallest size. Medium (mid) frequency corresponds to elements of medium size. Low, Very Low and Ultra Low frequency correspond to elements of correspondingly larger sizes.

For reference, see the noise samples of different frequencies in the Noise Filter Settings tab of the Neat Image window.

Q The filtration process is not very fast, is this normal?
A This is normal, because the Neat Image noise reduction algorithms are quite complex. We work on further optimization to provide better performance.
Q How to filter only the color noise (not the luminance noise)?
A Set the **Noise Reduction Amount > Luminance** control to 0%. This will disable the noise filter in the luminance (brightness) channel.

Q What is YCrCb?
A YCrCb is the name of a family of color models widely used in digital imaging, television, video, etc. In ‘YCrCb’, ‘Y’ corresponds to the luminance channel, ‘Cr’ – to the Cr chrominance channel covering the red to blue-green color range, ‘Cb’ – to the Cb chrominance channel covering the blue to yellow color range. Because this color model separates the luminance and chrominance information, it is used for noise reduction where different processing is required in the luminance and chrominance channels.

Q Is processing via Neat Image best done before or after any other processing (i.e. tonal/color correction)?
A Such operations as tonal/color correction are quite conservative from the standpoint of noise, that is they do not significantly change the noise characteristics of the image. Therefore, reducing noise before or after makes little difference – as long as the noise profile is built and applied at the same stage of your workflow. For example, do not use a noise profile built with an unprocessed (the color correction is not yet applied) image to filter the same image after the color correction has been applied.

On the other hand, certain effects, like sharpening or resampling, applied to a noisy image may considerably change its noise properties. In this sense, it is generally better to use Neat Image noise reduction before applying such effects.
13. Tips and tricks

13.1. Preventing banding

In some cases, the banding effect may appear when applying the noise filter to images with faint brightness gradients. This effect is quite rare for normal images.

To avoid banding, try to reduce the noise reduction amount for the high frequency component to 50% or lower to preserve some high frequency noise in the image.

Another option is to process the image in higher bitdepth.

13.2. Filtration of shadow areas

In some situations, it is preferable to filter only the shadow areas of images leaving bright areas intact. You can do this by using the noise profile equalizer (available in the Device Noise Profile panel when working in Advanced Mode) to limit or stop filtration of bright image areas.

The graph nodes in the noise profile equalizer correspond to particular ranges of brightness (individually for each color channel) of the RGB color model. The vertical position of each node reflects the noise level in the corresponding range of brightness. So, the lower a node is, the less filtration will eventually be applied to image elements that belong to the corresponding range of brightness.

Therefore, to filter only shadows you can manually move all the ‘bright’ nodes down (refer to the gradients in the bottom of the noise profile equalizer to see which brightness level they correspond to). For example, move down all but the three ‘darkest’ nodes in each RGB channel.

Using this method, you can effectively prevent filtration of the bright image areas.

13.3. Partial filtration

Some images contain both noisy and clean areas and it may be preferable to filter only noisy areas. This can be manually done by combining two images – original and filtered one – in an image editor. For example, the following steps can be used:

1. Filter the input image in Neat Image (so that noisy areas are cleaned) and save the output image to a new file;
2. Open this new file in your image editor;
3. Place the filtered image in a new layer on top of the original image;
4. Adjust the transparency of the top layer so that noisy areas look fine;
5. Select and delete the areas of the top layer where filtration is not necessary or excessive (you may want to use the eraser tool with adjustable transparency and shape).
14. Information

14.1. Detailed feature map

<table>
<thead>
<tr>
<th>Features</th>
<th>Neat Image</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Demo</td>
</tr>
<tr>
<td>Use for commercial purposes</td>
<td>not allowed</td>
</tr>
<tr>
<td>Optional GPU acceleration</td>
<td>+</td>
</tr>
<tr>
<td>Ability to use two or more GPUs</td>
<td>–</td>
</tr>
<tr>
<td>simultaneously</td>
<td></td>
</tr>
<tr>
<td>Image processing</td>
<td></td>
</tr>
<tr>
<td>8 bit/channel (24-bit RGB, 8-bit Grayscale)</td>
<td>+</td>
</tr>
<tr>
<td>16 bit/channel (48-bit RGB, 16-bit Grayscale)</td>
<td>–</td>
</tr>
<tr>
<td>32 bit/channel (96-bit RGB, 32-bit Grayscale)</td>
<td>–</td>
</tr>
<tr>
<td>Standalone version of the filter</td>
<td>+</td>
</tr>
<tr>
<td>Maximum batch size</td>
<td>10</td>
</tr>
<tr>
<td>Command line support in GUI version</td>
<td>–</td>
</tr>
<tr>
<td>Command line version</td>
<td>+</td>
</tr>
<tr>
<td>JPEG</td>
<td>8 bits/channel</td>
</tr>
<tr>
<td>TIFF (single image, no layers, no mask)</td>
<td>8 bits/channel</td>
</tr>
<tr>
<td>16 / 32 bits/channel</td>
<td>+/-</td>
</tr>
<tr>
<td>BMP (uncompressed)</td>
<td>8 bits/channel</td>
</tr>
<tr>
<td>PNG</td>
<td>8 bits/channel</td>
</tr>
<tr>
<td>16 bits/channel</td>
<td>+/-</td>
</tr>
<tr>
<td>Windows clipboard</td>
<td>8 bits/channel</td>
</tr>
<tr>
<td>Drag and drop (from Windows Explorer)</td>
<td>–</td>
</tr>
<tr>
<td>Preserving image EXIF data in processed files</td>
<td>–</td>
</tr>
<tr>
<td>Device noise profiling</td>
<td>+</td>
</tr>
<tr>
<td>Automatic profiling of cameras and scanners</td>
<td>+</td>
</tr>
<tr>
<td>Manual profiling of any imaging devices</td>
<td>+</td>
</tr>
<tr>
<td>Automatic matching profiles to input images</td>
<td>+</td>
</tr>
<tr>
<td>Noise reduction</td>
<td>+</td>
</tr>
<tr>
<td>Channel components (Luminance, Cr, Cb)</td>
<td>+</td>
</tr>
<tr>
<td>Frequency components (High, Mid, Low, Very low, Ultra low)</td>
<td>+</td>
</tr>
<tr>
<td>Smart sharpening</td>
<td>+</td>
</tr>
<tr>
<td>Channel components (Luminance, Cr, Cb)</td>
<td>+</td>
</tr>
<tr>
<td>Frequency components (High, Mid, Low)</td>
<td>+</td>
</tr>
<tr>
<td>Filter presets (reusable filter settings)</td>
<td>+</td>
</tr>
</tbody>
</table>

14.2. Issues and bugs

Please report any bugs or issues you encounter while working with Neat Image. Use the online bug report form: https://ni.neatvideo.com/support/report-bug.

Your feedback will greatly help us to improve the software and provide you with newer and better versions of Neat Image.

---

1. The JPEG compression is set to a fixed high quality level in Demo edition; the level is adjustable in Home and Pro editions.
2. Here, +/- means that input is supported and output is not.
3. Whenever possible. Please see Preserve image metadata in output image files (when possible) section, in page 60 for more details.
4. Whenever possible, based on availability of profile and image metadata.
14.3. Plans

The current version of Neat Image is the result of our ongoing research on noise filtration. We continue to work on the core noise reduction algorithms to improve the quality and speed of noise reduction.

Please let us know if you have ideas that can make Neat Image better. Please participate in the discussions taking place in the Neat Image forum: https://www.neatvideo.net/.

14.4. Contacts

We really appreciate your opinion of Neat Image. Please let us know what you think about the software. Feel free to ask questions regarding Neat Image. You can contact us using the following means:

E-mails

- info@neatimage.com for general inquiries about Neat Image
- standalone-win@neatimage.com for technical questions regarding Neat Image standalone (Win)
- sales@neatimage.com for inquiries regarding purchase and licensing of Neat Image

Forum

Register in the Neat Image community forum (https://www.neatvideo.net/) and participate in discussions related to the use and development of Neat Image. The discussions there cover such topics as:

- announcements of new and updated version of the software;
- questions about use of Neat Image;
- examples of using Neat Image with comments and suggestions;
- feedback from the users: suggestions of new features and improvements;
- general comments;
- backup contacts.

Web page

https://ni.neatvideo.com

14.5. Legal information

Copyright

Neat Image © 1999-2023 Neatlab, ABSoft. All rights reserved.

License agreement

You can find the End-User License Agreement (EULA) covering this product – Neat Image standalone (Win) – in the file Legal.txt supplied with the product.
14.6. Purchase

To become a licensed user and to get a fully functional copy of Neat Image Home or Pro edition you need to purchase a license for this product. Please find the detailed information in the Purchase section of the Neat Image web page: https://ni.neatvideo.com/purchase

After purchasing a license, you receive an e-mail from the Neat Image team with detailed download and registration instructions. Using those you will be able to download, install and register the software on your computer.

By becoming a licensed user of Neat Image Home or Pro edition you will:

• Encourage the authors to further improve the software and make it better suited for your needs;
• Get access to all functions of Neat Image Home or Pro edition (see the Detailed feature map, page 70);
• Pro edition only: be able to use Neat Image for commercial purposes;
• Get free updates of the software (minor modifications with the same major version number, for example, updates from the version v9.0 to any v9.x);
• Enjoy reduced upgrade prices for new major versions of Neat Image, for example when upgrading from v9 to v10;
• Receive the primary attention of Neat Image support group;
• Receive the primary attention of Neat Image development group (tell us what you want to see in the next update or new major version).

Message from Neat Image team

By purchasing our product you are helping us to further develop and improve the software. Become a registered user and we will make Neat Image better for YOU!

14.7. Acknowledgments

Neat Image utilizes the IJG JPEG library developed by the Independent JPEG Group. Neat Image utilizes the openTIFF library developed by George Sotak. Neat Image utilizes the zlib library developed by Jean-loup Gailly and Mark Adler. Neat Image utilizes the libpng library developed by Glenn Randers-Pehrson.

Thank you to all the users who contribute by proposing improvements and new features. Thanks to all the people who help us to find bugs in Neat Image. Thank you to all the users who stimulate the development of Neat Image by their word and deed. It wouldn’t be Neat without all of you!

Neat Image team
Index

Artifact Removal, 24
Auto Profile, 12
Check Speed, 19, 26
Edge Smoothing, 25
Filter Tuning Assist, 22
Filter, 18, 21
Noise Level, 18, 21, 23
Noise Reduction Amount, 18, 21, 22
Optimize Settings, 19
Optimize, 26
Sharpening, 18, 25
artifact removal, 24
batch processing, 47
color model
  chrominance, 68
  luminance, 68
  YCrCb, 68
color noise, 23, 68
color tint, 10
color tint model, 10
color vision, 10
component viewer, 45
color space, 68
color temperature, 68
color management, 70
color profile, 70
color profile, 70
detail recovery, 24
device noise profile, 12
device noise profile, 12
device noise profile, 12
device noise profile, 12
device noise profile, 12
device noise profile, 12
device noise profile, 12
device noise profile, 12
device noise profile, 12
device noise profile, 12
device noise profile, 12
device noise profile, 12
device noise profile, 12
device noise profile, 12
device noise profile, 12
filter, 18, 21
  noise level, 18, 21
  noise reduction amount, 18, 21
filter preset, 27
  description, 27
  load, 27
  save, 27
filter settings, 17
  frequency, 67
  high, 23, 67
  low, 67
  mid, medium, 67
  frequency range, 7, 65
equality indicator, 14, 32
  ready-made, 29
equality indicator, 14, 32
equality indicator, 14, 32
equality indicator, 14, 32
equality indicator, 14, 32
GPU acceleration
  CUDA, 5
  OpenCL, 6
  high ISO noise, 7, 66
  image filtration job, 47
  defaults, 55
  editing, 50
  removing, 53
license agreement, 71
noise filter, 7, 21
noise level, 21, 23
noise reduction amount, 21, 22
partial filtration, 69
performance settings
  optimize, 19, 26
preferences, 54
preview, 19, 26
profile matching, 16, 42
purchase, 72
quality mode, 20
sharpening, 18, 25
system requirements, 5
variants of filtration, 44