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1. Introduction 

1.1. Overview 
Neat Image is a digital filter software designed to 
reduce visible noise in digital photographic images. 

Neat Image detects, analyzes, and reduces image 
noise. The filtration quality is higher than that of other 
methods because Neat Image takes into account 
specific characteristics of particular image acquisition 
devices, making the filtration more accurate. Using 
device noise profiles, Neat Image adapts itself to 
almost any input device – digital camera, scanner, etc. 
Neat Image incorporates the most advanced noise 
reduction algorithms in the industry. 

The rich control set of the filter allows you to easily achieve the desired 
level of noise reduction. In addition, Neat Image can make images look 
sharper without any degradation of image quality (which is usually 
inevitable with noisy images). The combination of the sharpening and 
noise filter makes such an effect possible. 

Neat Image standalone (Win) is currently produced in three editions: 

 Demo is a freeware edition of the software with limited functionality 
 Home edition supports 8-bit images, and limited batching (up to 100 images in one batch) 
 Pro edition supports 8-bit, 16-bit and 32-bit images and unlimited batching 

 

1.2. Features 

Noise Reduction and Image Sharpening 
 Advanced noise filter to reduce noise and grain in digital images 
 Complete control over the filter settings to achieve the desired level of noise reduction 
 Smart sharpening filter to make images look sharper without amplification of noise 
 8-bit, 16-bit and 32-bit image support to fully utilize capabilities of modern image acquisition 

devices and support HDR post-processing workflows 
 CUDA and OpenCL acceleration to speed up processing using computation-capable GPUs 

Device Noise Profiles 
 Auto Profile to build noise profiles for your camera or scanner on the fly 
 Rich set of pre-built noise profiles in the online profile library 
 Auto Match to select the most suitable pre-built noise profiles for input images 
 Batch profiler to automate profiling with the Calibration Target 

Batch Processing 
 Batch functionality to process many images automatically 
 Background processing: multiple images are processed in background as you prepare new 

images or work in another application 

Preview 
 Embedded preview for any selected image area 
 Preview of filtration results separately for each channel and frequency component 

Some features are only available in certain editions of Neat Image. Detailed feature map (page 52) 
explains the differences between Neat Image editions in details. 

 

 

Noise is a serious problem that hinders 
high-quality digital image processing. In digital 
photography, the consumer- and prosumer-level 
cameras produce images with an easily noticeable 
noise component. This component is especially 
strong in images shot at high ISO rates. The noise 
reduces the visual quality of digital images and 
resulting printouts. Some image processing 
operations, like sharpening, make quality of noisy 
images even worse. 

See online examples of 
Neat Image noise reduction: 

www.neatimage.com  
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1.3. Requirements 

1.3.1. Hardware requirements 
System requirements for practical use of Neat Image depend on size of input images. The more system 
RAM is available the larger images can be processed. The processing speed is determined primarily by 
the processor number-crunching power (clock frequency, number of cores/processors, cache size) and 
memory speed. 

Recommended system configuration to process photos produced by modern digital cameras: 

 Windows 8, Windows 7, Vista, XP; 64-bit or 32-bit 
 Core Duo class machine or better 
 1 GB RAM or more 
 True color display, resolution 1280x800 or more 

 

Optional CUDA acceleration requires: 

 CUDA-capable NVIDIA video card; 
 Recent video driver supporting CUDA v4.2 or newer. 

(you can download the latest versions of the video drivers from http://www.nvidia.com) 
 

Optional OpenCL acceleration requires: 

 Supported video card: 
  ATI   Radeon HD 57xx/58xx/59xx; 
 AMD Radeon HD 67xx/68xx/69xx; 
 AMD Radeon HD 77xx/78xx/79xx; 
 AMD Radeon HD 87xx/88xx/89xx; 
 AMD Radeon R7 260X; 
 AMD Radeon R9 270X/280X/290X; 
 Another AMD/ATI GPU based on one of the following chip series: 

Juniper, Cypress, Barts, Cayman, Cape Verde, Pitcairn, Tahiti, Bonaire, Hainan, Hawaii 
 AMD Catalyst Driver 12.4+ 

 

1.3.2. Supported types of images 
Neat Image supports the following formats of input images (the same formats are supported to save 
output images1): 

 TIFF (single image, no layers, no 
alpha channel, no mask) 
8/16/32-bit per channel 

RGB and grayscale 

 JPEG 
8-bit per channel 

RGB and grayscale 

 

 PNG 
8/16-bit per channel 

RGB and grayscale 

 BMP (uncompressed, Win3x) 
8-bit per channel 

RGB 

 

RAW images can be processed after they are converted to TIFFs (using TIFF is recommended to avoid 
quality loss due to compression) or to JPEGs (this involves quality loss, because JPEG is a lossy 
format). 

Color input images are supposed to be in an RGB color space (for example, AdobeRGB, sRGB, and the 
like). If an input image is in some type of RGB color space then Neat Image produces the output image 
in exactly the same type of RGB color space. 

Minimum size of the input images is 40x40 pixels; maximum size is usually limited by the amount of 
system RAM available. 

                                                           
1 

There are some limitations in the Demo edition. Please see Detailed feature map, page 52, for more information. 
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2. Key concepts 

2.1. What it can do – functionality of Neat Image 
Neat Image is a digital image filter. Its main function is to reduce noise in digital images. 

Neat Image can work with images produced by any imaging devices – digital cameras, scanners, etc. 
Neat Image can be adjusted to a particular device by means of a device noise profile, which describes 
the noise characteristics of the device working in a certain mode. 

A device noise profile is built by analyzing featureless image areas that contain no visible (or important) 
details. Usually the software can find such areas completely automatically. In a difficult case, you can 
assist it and select featureless areas manually. Finding such areas is very easy for human eyes but may 
sometimes be a bit difficult for software. 

By analyzing found or specified featureless areas, the Auto Profile function in Neat Image builds a profile 
which describes the noise in these areas. Using this profile, Neat Image’s noise filter can efficiently 
reduce noise in the whole image. 

When several such profiles for different device modes are available, the Auto Match function can 
automatically select the profile that matches given input image. In this way, you can skip noise analysis 
and simply re-use one of profiles built earlier. 

Smart Profile combines the power of Auto Profile and Auto Match by preparing two candidate profiles and 
then selecting the better one for actual image processing. This improves automated image processing 
and helps to achieve great results in more cases. 

The noise filter processes images in three spatial frequency ranges. This makes possible reducing noise 
in one frequency range even if details are present in other ranges. The filter can also selectively process 
any of the color channels components of the input images. 

In addition to the noise filter, there is the smart sharpening filter, which only sharpens important image 
details without increasing the level of noise. This filter also uses the noise profile to tell noise from 
details, so applying the noise and sharpening filters together saves time and produces better overall 
results. 

2.2. When it works – types of input images 
Neat Image is designed to reduce noise in images produced by digital cameras and scanners, and can 
also be used to process images from other sources. An input image should satisfy the following 
requirements: 

 Noise must be uniformly distributed throughout the image, i.e., there should be no strong 
surges of noise intensity in some areas of the image or significant changes of noise characteristics 
across the image. 
 
Neat Image works fine, for example, on images with high ISO noise because such noise usually 
uniformly covers the whole image area. However, ‘hot’ or ‘dead’ pixels (produced by single 
‘broken’ elements of image sensor) do not satisfy the uniformity condition and, therefore, are not 
efficiently removed by Neat Image. 
 
Another frequent source of noise is JPEG compression. The JPEG noise is approximately uniform 
when high quality setting (low compression rate, larger file size) is used. However, low 
compression quality makes noise non-uniform. Therefore, we recommend using the highest 
quality levels whenever possible. Try to avoid visible artifacts ('squares' or ‘blocks’ introduced by 
JPEG compression) in input images beginning from the early stages of image processing. If you 
can, use lossless file formats such as TIFF. 
 

 Noise should be concentrated in high and medium spatial frequencies. This condition is 
usually met by images produced by modern digital cameras. This condition may not be completely 
satisfied if you use the strong (e.g., x2-x3 and more) digital zoom features of digital cameras. 
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3. Filtration process overview 

3.1. Overview of Neat Image filtration process 
When you start Neat Image, the main Neat Image window opens automatically and then you can take 
the following steps to process one image: 

 

1. Open an input image 

 

- the image viewer 
will display the input image; 

 

- the information panel 
will display relevant image data; 

  

 

2. Prepare a device noise profile – noise 
analysis necessary to filter the image 

- load a pre-built profile 
 or 
build a new one on the spot; 

- to build a new profile 
click the Auto Profile button; 
this will automatically select and 
analyze a featureless (noise-only) 
image area; 
 
if you see that automatic selection 
includes any important image details 
then move the selection to an area 
without details and click the Auto 

Profile button again; 

  

Continued on the next page…  
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…continued from the previous page  

  

 

3. Adjust the noise filter and sharpening 
settings to achieve desired level of noise 
reduction and sharpening 

- adjust the filter settings to achieve 
desired level of noise reduction: 

- try to vary the setting: 
Noise Reduction Amounts: Luminance 
and see how the preview changes; 

- when you are happy with the preview 
proceed to the next stage; 

  

 

4. Switch to the Output Image tab and 
let Neat Image process the image; 

- when processing is finished, evaluate 
the resulting output image by 
comparing it with the input image: 
click the image to switch to the 
original for comparison; 

5. Save the output image to a file on the 
hard drive. 

 

3.2. Running Neat Image on a sample image 
There is a test-kit prepared to help you start using Neat Image. You can download it from the Neat 
Image web page: http://www.neatimage.net/files/Testkit5.zip, 250KB. Having downloaded, please 
unzip it to a new folder on the hard drive. 

The test-kit contains a sample image: the SampleImage.jpg file. This image is a part of typical photo 
taken with a digital camera. The detailed information about the test image is available in the 
SampleImageInfo.txt file. 

Please start Neat Image and go through the stages below to see how it can improve the image: 

Stage 1. Open the sample image 

1. Click    in the toolbar in the Input Image tab:  
 

2. In the Open input image file dialog, navigate to the folder where the sample image has been 
unzipped and double click on the SampleImage.jpg file. 

Neat Image will open the sample image. 

You will see that there is strong noise in the image, especially in the sky area (use zoom and scroll to see 
it). This is the typical noise produced by the Nikon CoolPix 950 digital camera. The task of Neat Image 
is to reduce this noise. To do that the software generally needs a noise profile describing the noise 
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properties of the image. We have prepared such a noise profile in advance. The profile is supplied with 
the test-kit in the SampleProfile.dnp file. Using the noise profile, Neat Image can efficiently reduce the 
noise in the image. 

 

Stage 2. Load the sample noise profile 

1. Switch to the Device Noise Profile tab:  
 

2. Click    in the toolbar; 
 

3. In the Load Device Noise Profile dialog, navigate to the folder where the sample device noise 
profile has been unzipped and double click on the SampleProfile.dnp file. 

 

Now the sample device noise profile is loaded and Neat Image is almost ready to filter the sample 
image. Usually, you would adjust the filter settings at this stage. To make things easier for the first run 
of Neat Image, we have prepared a sample preset file that stores “good” filter settings suitable for the 
sample image. 

 

Stage 3. Load the sample filter preset 

1. Switch to the Noise Filter Settings tab:  
 

2. Click    (pink folder) in the Filter Preset box on the right panel; 
 

3. In the Load filter preset dialog, navigate to the folder where the sample filter preset has been 
unzipped and double click on the SamplePreset.nfp file. 

Now the sample filter preset is loaded and the filter settings are adjusted to process the sample image. 

 

Stage 4. Apply the filter 

1. Switch to the Output Image tab:  
 

2. Wait until the progress indicator disappears. 

Processing may take a few seconds. Then the filtered output image is displayed. You can click the 
output image to compare it with the input image. Notice that the noise – especially in the sky area – has 
been significantly reduced while the image details have been preserved. 

 
Please note that the sample noise profile and sample filter preset supplied with the test-kit are suitable 
only for images taken with that particular digital camera working in the same or similar mode. Neat 
Image can perform similar noise reduction on images captured or acquired by any other camera or 
scanner working in any mode. To be able to do that Neat Image needs device noise profiles that describe 
the noise characteristics of those devices. With Neat Image you can build these profiles yourself. The 
software can completely automatically build a profile given an input image. Also, you can find pre-built 
device noise profiles for many digital cameras and scanners in the Profiles section of Neat Image web 
page: http://www.neatimage.com/win/standalone/profiles.html 

The next sections – Filtration process details, page 9, and Device noise profiles, page 19,– contain 
detailed descriptions of the filtration and profiling processes. There are also several examples of 
profiling and filtration in the examples section of Neat Image web page: 
http://www.neatimage.com/win/standalone/examples.html. 
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4. Filtration process details 
Neat Image can be used to filter a single 
image or to automatically process multiple 
images. This section describes the single 
image workflow. Processing multiple 
images is detailed in the Batch processing 
section, page 33. 

The main window of Neat Image and its 
Editor tab (see on the right, this will be 
called Editor in this guide) is usually used 
to process one image. When you start Neat 
Image for the very first time, this window 
opens automatically in the Editor tab: 

 

The filtration process is described below 
as a sequence of stages that need to be done to process one image. 
 

4.1. Stage I. Open an input image 

Use the Input Image tab:  

To open an input image 

 Click    (the Open input image button) in the toolbar or use the File > Open Input Image… 
menu item. Select an image that you want to process. 
The supported file formats are BMP, TIFF, PNG and JPEG (see Requirements, page 4, for more 
information about supported file formats). 

 Drag an image file from the Windows Explorer and drop it to the image viewer in Neat Image. 

 Use the Edit > Paste menu item to copy-and-paste an image from another application to Neat Image 
through the Windows clipboard.1 

When the input image is ready, the Input Image box (in the right 
panel) displays the full name of the image. If the image contains 
the EXIF data then the optional Image Metadata box shows the 
available details such as camera model, ISO rate, compression and 
other relevant parameters present in the EXIF fields. Only those 
parameters are displayed that could be extracted from the input 
image and that are important for noise reduction. 

 

To scroll and pan the image 
 drag the image using the middle mouse button; 
 press the spacebar and drag the image with the left mouse button. 

To change the image zoom level 
 use the mouse wheel when mouse is over the viewer; 
 use the zoom control under the image viewer; 
 use the Ctrl+Plus, Ctrl+Minus, Ctrl+0 (zero), Ctrl+Alt+0 (zero) keyboard shortcuts. 

                                                           
1
 Please note that copy and pasting an image does not copy the EXIF information which may be important for Neat 
Image noise reduction (in particular, for profile matching). In cases when the EXIF information is significant, 
consider opening an image file manually or drag and drop it instead of copy and pasting. 
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4.2. Stage II. Prepare a device noise profile 
To filter the input image, Neat Image needs to know the characteristics of noise produced by the image 
acquisition device (digital camera, scanner, etc.) that the image comes from. The noise characteristics of 
a device working in a certain mode are stored in a device noise profile. 

There are several ways to get a device noise profile that suits the input image: 

1. Auto Profile: to build a new profile by analyzing the input image (or a specially prepared test 
image); 

2. Auto Match: to automatically select the most suitable device noise profile from a pre-built set of 
profiles (when it is available); 

3. Smart Profile: to use both Auto Profile and Auto Match (with Auto Fine-Tune) to prepare two 
candidate profiles and then automatically select the better of two profiles; 

4. Load Profile: to manually select a suitable profile from a pre-built set of profiles. 

The first option is often the easiest one provided the input image includes uniform featureless areas that 
contain noise but no visible or important details.1 Auto Profile will try to automatically find such image 
areas and analyze them to build a noise profile. When the image does contain featureless areas, this 
automatic way of preparing a noise profile is the most accurate and therefore recommended. If the input 
image includes no such areas, another image with featureless areas can be used to build a profile. 

The other options are available once you have a pre-built reusable set of profiles. You can find some 
pre-built profile sets for different cameras and scanners in: 

 Profiles section of the Neat Image web page: 
 http://www.neatimage.com/win/standalone/profiles.html 
 

 Device noise profiles section of the Neat Image community forum: 
http://www.neatimage.net/forum/viewforum.php?f=5 
 

 Other digital imaging forums and web pages from users of Neat Image 

If you cannot find a pre-built set of profiles for your camera or scanner, you can easily build such 
profiles yourself. Moreover, please be aware that using profiles built by other people may produce less 
than optimal results with your images because of possible slight differences in noise properties of 
cameras (scanners) as well as due to different image processing workflows used. Therefore, we advise 
to use profiles built by others only as a starting point to learn how to use Neat Image. To achieve better 
results consider building your own reusable profiles. 

You can build a set of profiles for different device modes or just one profile to process one image. You 
can find more details about profiling in the Device noise profiles section, page 19. 

Once you have a set of profiles for different modes of your imaging device, you can (automatically or 
manually) select a profile that matches the input image. Or if you have just built a singe profile 
specifically for the input image, then you can directly use the profile to process the image in the Stages 
III-V below. 

Auto Profile: build a new profile using the input image 

 Make sure you have switched to the Device Noise Profile tab:  

 Click    (the Auto Profile button) in the toolbar, or use the Profile > Auto Profile with 

Regular Image menu item, or press F2. 

Neat Image will find and highlight the image area selected by Auto Profile for main analysis. Neat 
Image will then automatically analyze the noise in that area as well as in the whole image and will 
build a new noise profile. 

To build a profile, Neat Image is looking for a flat uniform featureless area in the input image. In 
difficult cases, Neat Image may have trouble finding a uniform featureless area in the input image 
and then the auto-selected area will contain some important image details. In such a case, move the 
selection to an area that does not contain any image details (you can make a new selection or resize 
the old one) and then click the same Auto Profile button again. 

                                                           
1
 You can see some examples of featureless image areas in the Examples section, page 44. 
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After the profile is built, check the Profile Quality indicator in the Device Noise Profile box. A profile 
built using a uniform and featureless image area will show a high value in this indicator. If the 
profile quality is high (for example, higher than 75%) then you can be sure that the noise profile is 
accurate. In this case, consider the noise profile ready and proceed to Stage III. Adjust filter 
settings, page 12. 

If the quality is not high, try to select another uniform image area and use Auto Profile once again. 
That may not help still, especially if the input image contains only a few featureless areas. In this 
case, consider building a noise profile using an alternative image or special test image prepared 
with the Calibration Target. Please see the Device noise profiles section, page 19, to learn how to 
use the Calibration Target to build device noise profiles. You can also try to load some pre-built 
profile using one of the methods described below. 
 

Auto Match: select matching noise profile from a pre-built profile set 

 Click    (the Auto Match button) or use the Profile > Auto Match menu item. 

The Auto Match function uses the EXIF data fields of the input image to automatically select and load 
the device noise profile that matches the device mode of the image. The most matching profile is 
selected from profiles stored in a special folder. By default, this folder is in your Documents1: 
  Documents\Neat Image Standalone\Profiles\ 

Auto Match will look for matching profiles in that folder as well as all its subfolders (where you can 
place profiles built by you or downloaded from the Internet). 

After a profile is loaded by Auto Match, the degree of match between the current input image and 
loaded noise profile is displayed in the Device Noise Profile box. Higher Match values mean better 
match, leading to more accurate filtration. 
 

Smart Profile: prepare two profiles and select the better one 

 Use the Profile > Smart Profile menu item (or press the F5 key). 

Smart Profile uses both Auto Profile and Auto Match (with Auto Fine-Tune) to prepare two candidate 
profiles and then selects the better of two profiles. For Smart Profile to be fully efficient, the input 
image must contain flat featureless areas with noise for Auto Profile to analyze, and also there must be 
several pre-built profiles to help Auto Match find the most matching noise profile, as described 
above. You can adjust settings of Smart Profile function in Preferences. 
 

Load Profile: manually load a noise profile from a pre-built profile set 

 Click    (the Load Profile button) or use the Profile > Load Profile… menu item. Then 
select a profile in the Load Device Noise Profile dialog. 
 
or 

 Click    (the drop-down button) in the Device Noise Profile box to open the popup menu with all 
available profiles and then select one of the available profiles. 

Please note that you have either to build your own profiles or download some pre-built profiles and 
place them to the Neat Image’s Profile folder to make this drop-down button and popup menu truly 
work. By default the Profile folder is located in the Documents folder2: 
  Documents\Neat Image Standalone\Profiles\ 

If you build or download some pre-built profiles, place (unzip the profile set if necessary) them to 
the above folder. Neat Image will recognize and display those profiles in the popup menu to help 
you quickly load any of them when needed. 

When manually selecting a profile for input image, use the profile file names and sub-folder 

                                                           
1
 You can check and adjust the location of that folder using the menu Tools > Preferences > Matching. 

2
 You can check and adjust the location of the Profile folder using the menu Tools > Preferences > Folders. 



User Guide Neat Image standalone (Win) 
  

  
© 1999-2013 Neat Image team, ABSoft. All rights reserved.  12 24-Oct-13

structure to guide your search. See Preparing profile set for different device modes: Stage III. 
Structuring profile set, page 27, for more information on profile set structuring. 
 

To additionally fine-tune the loaded or matched profile 

You may want to additionally fine-tune the profile after it has been loaded either automatically 
(using Auto Match) or manually (using Load Profile). Fine-tuning the profile to the current image 
usually makes the profile more accurate and better reflecting the image’s noise properties. Please 
note that you do not need to fine-tune a profile if you have built it using Auto Profile. Auto Profile 
automatically applies fine-tuning so you do not need to repeat it. 

 Click    (the Auto Fine-Tune button) or use the Profile > Auto Fine-Tune menu item to 
fine-tune the profile to the current input image. 

There is no need to select any area in the input image because Auto Fine-Tune automatically analyzes 
the whole image. 
 

Once you have loaded the profile that matches the input image or you have just built a new profile 
specifically for the current input image, proceed to process the image in the Stages III-V below. 
 

4.3. Stage III. Adjust filter settings 
As soon as the noise profile is ready you can use the noise and sharpening filters. These filters have 
several adjustable settings. The default settings usually produce good results. You may want to 
additionally vary the filter settings to achieve the filtration results that look best to your eyes. 

 Switch to the Noise Filter Settings tab:  

4.3.1. Use preview when adjusting filter settings 
The image viewer in the Noise Filter Settings tab shows a part of the image processed by the noise and 
sharpening filters. If you change any filter settings then the preview is automatically updated (provided 

 (the Preview button) in the toolbar is depressed). You can zoom in and out, drag, scroll 
and pan the image to see how the filtration affects different parts of the image. If you manually select an 
area in the image then only the selected area will be processed for preview. 

When the preview is ready (the preview area shows “Filtered”), you can click inside the preview image 
area to temporarily switch back to the original for comparison. 

4.3.2. Standard and Advanced modes 
Neat Image has two sets of filter controls; they are available in the Standard mode and Advanced mode 
(you can select the mode using the Tools > Standard mode and Advanced Mode menu items). The Standard 

mode provides a simple control set, recommended for beginners who just start using Neat Image. The 
Advanced mode provides the most complete control set with maximum manual control over noise 
profiling and filtration processes. The Advanced mode is recommended for power users. Adjusting filter 
settings is described below separately for the Standard and Advanced mode. We recommend starting with 
the part about the Standard mode and then proceeding to the part about the Advanced mode if you are going 
to use the complete control set. 

4.3.3. Adjust filter settings in Standard mode 
There are two main filters in Neat Image: noise reduction filter and sharpening filter. These two filters 
can be used together and each of them can be used independently. You can enable, disable and adjust 
these filters using the guidelines in the subsections below. 

Adjusting noise filter settings in Standard mode 

If you work with a color image then two major image components can be distinguished: the luminance 
and chrominance component. This distinction is very useful from the standpoint of noise reduction 
because it allows processing luminance and chrominance information separately. 
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Some color images are represented in color spaces that enable 
direct separation of the luminance and chrominance components 
(for example, Lab, YCrCb, etc.). Other images (including RGB 
images that Neat Image takes as input) have to be converted to 
another representation to enable separation of the luminance and 
chrominance components. Neat Image applies an internal color 
space conversion to achieve that. Once luminance and 
chrominance components of the input image are separated, Neat 
Image can treat them individually. Neat Image provides separate 
luminance and chrominance settings in the noise filter (see the 
figure on the right). 

In the Standard mode, the noise reduction applied to each image component (either luminance or 
chrominance component) is controlled by the corresponding noise reduction amount setting. 

A noise reduction amount tells the filter how much of the detected noise should be reduced. For 
example, if the noise reduction amount is set to 50% then all image elements that are considered (by the 
filter) to be noise are reduced (made weaker or less visible) in half. The noise reduction amount value of 
100% tells the filter to remove the detected noise completely. 

The default noise reduction amounts usually produce good filtration results provided the noise profile is 
accurate1. By default, the noise filter removes 60% of detected noise in the luminance component of the 
input image and 100% of noise in the chrominance component. Our experience shows that the default 
noise reduction amounts usually provide a good balance between noise removal and preserving natural 
(not over-processed) appearance of filtered images. 

Decreasing the noise reduction amounts may have a positive effect if the input image contains some 
natural noise. For example, when you filter images of asphalt, sand, or anything else that contains fine 
natural noise-like features, it may be helpful to reduce amounts down to 30-50%. 

Adjust noise reduction amounts2 

 Use the Noise Reduction Amounts: Luminance and Chrominance sliders. 

You can vary the noise reduction amount for both luminance 
and chrominance component of the input image. The higher a 
certain noise reduction amount, the more of the detected noise is 
removed in the corresponding image component. Be careful, 
setting the noise reduction amounts too high, especially in the 
luminance component, may lead to loss of fine details and 
unnaturally looking (over-smooth, plastic-like) results. Too low 
amounts may be not enough to sufficiently reduce the objectionable part of the noise. You have to 
balance the noise reduction amounts (most importantly, the amount of noise reduction in the 
luminance component) to get the result that looks best to your eyes. 

Use preview 

As you make changes in the noise filter parameters, check preview on different parts of the image to 
get a better feeling for the prospective results of noise reduction. 

If the noise filtration looks too strong try to decrease the noise reduction amounts. If the noise 
filtration is not sufficient then increase the amounts. 

 

Adjusting sharpening settings in Standard mode (optional) 

The sharpening filter in Neat Image increases image sharpness without increasing the noise strength. 

The sharpening filter is disabled (sharpening amount is set to 0%) by default. Increase the sharpening 

                                                           
1
 Use the Quality and Match indicators in the Device Noise Profile box to estimate the accuracy of the profile. The 
Quality indicator shows how accurate and complete is the noise analysis itself. The Match indicator shows how closely 
this profile corresponds to the current input image. Both indicators have to show high values for the noise reduction to 
be accurate. 

2
 We recommend disabling the sharpening filter when adjusting the noise filter. To disable the sharpening filter, set the 
Sharpening: Amount to 0%. 

As human vision is not very 
sensitive to variations of colors, 
strong filtration in the 
chrominance component does 
not noticeably distort image, but 
efficiently removes color noise. 
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amount to sharpen the image. Like with any sharpening method, you have to balance the sharpening 
amount to avoid over-sharpening. 

Use the preview when adjusting the sharpening settings. 

Adjust sharpening amount 

 Use the Sharpening: Amount slider. 

Specify how much sharpening should be applied to the input image. 

Use preview 

As you make changes to the sharpening setting, check preview on different parts of the image to get 
a better feeling for the results of sharpening. 

 

As soon as you are happy with the preview results regarding both noise reduction and sharpening, 
proceed to save the filter settings into a preset (page 17), or directly to the Stage IV. Apply filter to the 
input image (page 17). 

 

4.3.4. Adjust filter settings in Advanced mode 
As said above, Neat Image has two sets of filter controls, that are available in the Standard mode and 
Advanced mode (you can select the mode using the Tools > Standard mode and Advanced Mode menu items). 
The Standard mode described above provides a simple control set, recommended for beginners who just 
start using Neat Image. The Advanced mode provides the most complete control set with maximum 
manual control over noise profiling and filtration processes. The Advanced mode is recommended for 
power users. If you want to use the Advanced mode then please read this sub-section, otherwise skip it 
and proceed to page 17 for the next stage. 

As compared with the Standard mode, the Advanced mode offers a more extensive set of filter controls. 
There are also two filters – noise reduction filter and sharpening filter – but these have more settings 
now. Please follow the guidelines below to adjust both filters. 

Adjusting noise filter settings in Advanced mode 

In Advanced mode, the noise filter has separate settings for all frequency and channel components of the 
input image. There are also pairs of noise level - noise reduction amount controls for each of these 
image components. The meaning of each noise level - noise reduction amount pair is the following: 

 a noise level control adjusts the threshold that determines 
which image elements are considered noise in the 
corresponding image component and which elements are 
considered not noise; 

 a noise reduction amount control determines how much 
reduction is applied to the image elements identified as noise 
in the same image component. 

In Advanced mode, you can adjust the noise levels as well as noise 
reduction amounts for each image component. The noise levels are 
adjusted relative to the noise levels of the current noise profile that 
have been measured during profiling. 

For example, the noise level of the Y (luminance) channel could be 
measured in the noise profile at 8.55 units.1 This number tells the 
noise filter which image elements should be considered noise and 
which – image details: the image elements that are weaker than 
8.55 units are considered noise and reduced by the noise filter; the 
image elements that are stronger than 8.55 units are considered 
details and not reduced. 

If you do not change the default noise filter settings (Noise Levels: 

                                                           
1
 All measured noise levels are shown in the Profile Viewer (use the menu Profile > Profile Viewer to open it). 
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As human vision is not very sensitive to 
variations of colors, strong filtration in the Cr 
and Cb channels does not noticeably distort an 
image, but efficiently removes color noise.

Y: +0%) then noise reduction in the Y channel is completely determined by the measured number from 
the noise profile (8.55 units). However, if you do adjust the filter setting for the Y noise level then this 
adjustment is also taken into account. For example, if you set the Noise Levels: Y control to +15% then 
what is considered by the noise filter as the actual noise level is: 

 8.55 * (100% + 15%) => 9.83 units 

With this adjustment, the image elements in the Y channel that are weaker than 9.83 units are considered 
noise and reduced, and elements that are stronger than 9.83 units are preserved. 

Thus, with a noise level - noise reduction amount pair of settings you can adjust what should be 
considered noise in a component of the input image and how much of this noise should be reduced. You 
have access to six such pairs – three for channel components (Y, Cr, Cb) and three for spatial frequency 
components (High, Mid, Low) of the input image. 

Because the noise level controls are relative to the device noise profile, the default filter settings usually 
produce good results when the noise profile is accurate1. The noise level defaults are 0%, which means 
the noise levels are completely determined by the noise profile. When you adjust the level controls, the 
noise level estimations are raised or lowered accordingly. A noise level control can be in the range from 
–100%, which means no image elements are considered noise, and therefore, no noise reduction is 
applied in the corresponding image component; to +150%, which means noise reduction is applied to 
the image elements that are weaker than 250% of the noise profile’s noise level. 

Noise reduction amounts can be in the range from 0% (none of the detected noise is removed) to 100% 
(all the detected noise is removed). By default, the noise filter removes 100% of detected noise in all but 
the luminance (Y) channel where only 60% of detected noise is removed. 

Decreasing the noise reduction amounts can have a positive effect if the input image contains some 
natural noise. For example, when you filter images of asphalt, sand, or anything else that contains fine 
natural noise-like features, it may be helpful to reduce amounts down to 30-50%. Our experience shows 
that these values generally provide a good balance between preserving image details and noise removal. 

Adjust noise reduction amounts2 

 Use the Noise Reduction Amounts: High, Mid, 
Low; Y, Cr, Cb sliders. 

You can vary the noise reduction amount 
for each frequency and channel component 
of the input image. The higher a certain noise 
reduction amount, the more of the detected noise is 
removed in the corresponding image component. Be 
careful, setting the noise reduction amounts too high 
can lead to unnaturally looking (over-smooth, 
plastic-like) results. Too low amounts may be not enough to sufficiently remove the objectionable 
part of the noise. You have to balance the noise reduction amounts (most importantly, the amount of 
noise reduction in the Y channel) to get the result that looks best to your eyes. 

If the input image has only fine (high frequency) noise then you can utilize only the high frequency 
filter and switch off the filters for other frequencies by setting their amounts to 0%. 

Adjust additional filter settings (optional) 

 If the input image contains strong low frequency noise (for example, a very coarse-grained color 
splotches) then you may want to switch on the very low frequency filter (check the Very low freq 
checkbox in the Filter Settings box). 

 Check the Smooth edges checkbox to make edges and lines look smoother. 

                                                           
1
 Use the Quality and Match indicators in the Device Noise Profile box to estimate the accuracy of the profile. The 
Quality indicator shows how accurate and complete is the noise profile itself. The Match indicator shows how closely 
this profile corresponds to the input image. Both indicators have to show high values for the noise reduction to be 
accurate. 

2
 We recommend disabling the sharpening filter when adjusting the noise filter. To disable the sharpening filter, 
uncheck all channels in the Sharpening Settings box. 

Noise samples of different frequency/size 
are shown in the Noise Filter Settings box. 
These are examples of grainy structures 
typically regarded as noise.  
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 Check the High quality checkbox to enable the higher-quality noise reduction filter. This will slightly 
slow down processing but will deliver the most accurate results in return. 

 Check the High resolution checkbox to enable the higher-resolution noise filter. This may be useful 
when processing images with very fine details that should be better preserved by the filter. 

Use preview 

As you make changes to the noise filter parameters, check preview on different parts of the image to 
get a better feeling for the results of noise reduction. 

If the noise filtration looks too aggressive try to decrease the noise reduction amounts for 
appropriate channels or frequency components. If the noise filtration is not sufficient then increase 
the amounts. 

Adjust noise levels (only when necessary) 

Usually it is not necessary to change the noise levels if the noise profile is accurate. You only have 
to adjust the noise levels if you see that some noise elements are not reduced even if you set the 
noise reduction amounts to 100%. Such residual noise elements are usually caused by inaccurate 
noise profile (providing inaccurate estimations of actual noise levels). This may be compensated by 
adjusting (increasing) the noise levels in the filter settings. 

 Use the Noise Levels: High, Mid, Low; Y, Cr, Cb sliders. 

The noise filter has access to three frequency components and three channel components of the 
input image. The corresponding sliders adjust the estimated noise levels of these components. 

The higher a certain noise level, the more image elements in the corresponding image component 
are considered noise. Be careful, setting a noise level setting too high can lead to removal of 
important image details. Setting a noise level setting too low can lead to incomplete filtration: 
residual noise and compression artifacts can stay in the output image. 

As a rule, if the device noise profile has been built properly, it is not necessary to increase the noise 
levels by more than 50%. If the input image contains strong surges of noise in the high frequency 
range, it is recommended to increase the high frequency noise level up to +20 to 40%. 

If the input image contains strong color noise, it is recommended to increase the Cr and Cb noise 
levels to +30%. In some cases, it may be useful to increase these noise levels up to +100%. 

If adjusting noise levels still does not help and some noise elements remain visible in the preview 
and output image, probably the device noise profile is not good at all. Return to Stage II, page 10, 
and additionally fine-tune the device noise profile or simply rebuild the profile from scratch. 
 

Adjusting sharpening settings in Advanced mode (optional) 

The sharpening filter is designed to increase image sharpness without increasing the noise strength. 

The default values of the sharpening settings should produce satisfactory results (when sharpening is 
enabled for any of the channel components) but you are encouraged to vary the settings to find values 
that produce the desired level of sharpness. Zero sharpening amounts will not sharpen the image at all. 
The non-zero sharpening amounts will apply sharpening of the specified strength. Use sharpening 
controls for different frequency components to sharpen fine, medium or large image details. As with 
any other sharpening method, you have to balance the amounts to avoid over-sharpening. 

Use the preview when adjusting the sharpening settings. 

Select color channels where sharpening should be applied 

 Use checkboxes in the Sharpening section. 

Usually you only want to sharpen the luminance channel – Y. 

Select sharpening mode 

 Check the Conservative checkbox to enable more accurate 
sharpening, which produces much less halo effect around sharpened image details. 
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Adjust sharpening amounts 

 Use the High, Mid and Low sliders in the Sharpening section. 

Specify how much sharpening should be applied to each frequency component of the image. 

The standard sharpening settings used by many graphic editors are 100% for high frequency and 
0% for medium and low frequencies (used by default). 

As soon as you are happy with the preview results regarding both noise reduction and sharpening, 
proceed to save the filter settings into a preset (see the subsection below), or directly to the Stage IV. 
Apply filter to the input image, page 17. 

4.3.5. Save filter settings into a preset (optional) 

To save the current filter settings into a preset 

 Click    (the Save filter settings as preset… button, pink disk) in the Filter Settings box or use 
the Filter > Save Filter Preset… menu item. 

In the Save Filter Preset As dialog box, specify the name of the file to save the preset. The filter 
presets are stored as *.nfp files. 

Saved filter preset includes the noise filter and sharpening settings. By re-opening a preset, you can 
reproduce exactly the same filter settings later on. Also, you can exchange filter presets with other 
users of Neat Image. Together, a device noise profile and a filter preset can be used to precisely 
reproduce the filtration results. 

To load a previously saved filter preset 

 Click    (the Load filter preset… button, pink folder) in the Filter Preset box or use the Filter > Load 

Filter Preset…  menu item. In the Load Filter Preset dialog box, specify the name of the filter preset to be 
loaded. 

 or 

 Click    (the drop-down button) in the Filter Settings box to open the popup menu with all 
available presets and then select one of them. 

There are several pre-written filter presets in the following sub-folder1 in your Documents folder: 
   Documents\Neat Image Standalone\Presets\ 

Please explore these presets to see what combinations of the noise and sharpening filter’s settings 
can be used to solve typical tasks (names of the presets explain these tasks). 
 

4.4. Stage IV. Apply filter to the input image 

 Switch to the Output Image tab:  

This will automatically start the filtration process and Neat Image will process the whole input 
image. 

Processing may take some time (from seconds to minutes, depending on the speed of your 
computer's processor and size of the image).  

When the filtration is completed, you can compare the output and input images. Click the output 
image to temporarily switch between the output and input images for comparison. 

If the filtration result is not satisfactory, please return to Stage III, page 12, to change some of the 
filter settings, or to Stage II, page 10, to build a new or improve the current noise profile to make it 
better match the noise of the input image. 

                                                           
1
 You can check and adjust the location of that folder using the menu Tools > Preferences > Folders > Preset folder. 
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 In Pro version, you can optionally select a different bitdepth of the output image using the Filter 

Output box. The output bitdepth can be made different from that of the input image. In such a case, 
the input image will be internally converted to the output bitdepth during processing. 
 

4.5. Stage V. Save the output image 

 Click    (the Save output image button) in the toolbar or use the File > Save Output 

Image As… menu item. 

The available output file formats are: BMP, TIFF, PNG and JPEG (see the Requirements 
subsection, page 4, for more details). 

When saving in the PNG format, you can select the compression level: 0 is for the lowest 
compression / large file size and 9 is for the highest compression / smallest file size. 

When saving in the JPEG format, you can select the compression quality. The last used 
compression quality value is always used as the current default. 

Neat Image uses 4:1:1 subsampling with the JPEG quality smaller than 85. If the JPEG quality is set 
to 85 or higher then subsampling is not used. 

 or 

 You can also use the Windows clipboard to export the filtration results to another application. Use 
the Edit > Copy menu item for that purpose. An image put on the clipboard will be in 24-bit RGB 
format. 
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5. Device noise profiles 
A device noise profile (or noise profile, or simply profile) describes the properties of noise produced by 
an imaging device (e.g., digital camera, scanner, etc.) working in a certain mode. Several noise profiles 
corresponding to different modes of a device constitute a profile set. Neat Image can use profiles from 
such a set to process images produced in any of the modes covered by the set. 

You can find some pre-built noise profiles or build your own profiles for your camera or scanner. Learn 
how to find, build and use device noise profiles in Neat Image in the subsections 5.1-5.4 below. 

5.1. Getting ready-made noise profiles 
You can find some pre-built profile sets for different cameras and scanners in: 

 Profiles section of the Neat Image web page: 
http://www.neatimage.com/win/standalone/profiles.html 
 

 Device noise profiles section of the Neat Image community forum: 
http://www.neatimage.net/forum/viewforum.php?f=5 
 

 Other digital imaging forums and web pages from users of Neat Image. 

To use a profile set from one of these sources, download the archive with profiles and unzip all profiles 
to the following folder1 and/or its sub-folder(s) in your Documents folder: 
  Documents\Neat Image Standalone\Profiles\ 

After that you can use individual profiles from this set in Neat Image to process images produced in 
device modes covered by this profile set. 

Please be aware that using ready-made profiles built by other people may produce less than optimal 
results with your images because of possible slight differences in noise properties of cameras (scanners) 
as well as due to different imaging processing workflows used. Therefore, we advise to use ready-made 
noise profiles built by others only as a starting point to learn how to use Neat Image. To achieve the best 
results consider building your own profiles as explained in the subsections below. 

5.2. Building a profile for a device mode (standard 
profiling procedure) 

In this subsection, you will find out how to build a single noise profile for an image produced in a 
certain shooting or scanning mode (such a profile can also be called “a profile for a certain mode of the 
device”). 

Building a new noise profile generally consists of three stages: 

Stage I. Building a profile; 
Stage II. Documenting the profile; 
Stage III. Saving the profile. 

The Stage I, building a profile, can be done with the use of a regular image (for example, the image that 
you want to denoise or any other regular image) or with the use of the Calibration Target. These two 
cases are described as two alternative versions of the Stage I: 

Stage I. Case of building a profile using a regular image 
Stage I. Case of building a profile using the Calibration Target 

You may want to follow the case of building a noise profile using a regular image if you only need a 
single-use profile to process selected input image. In this case, the input image (or an alternative regular 
image from the same series; it should be produced by the same device working in the same mode) 
should contain enough uniform featureless areas for noise analysis. 

A uniform area (with minor variation in all channels of the image) may be overcast sky, clear sky 
(without clouds and birds), or any other part of the image, where there are no visually perceptible details 
(except the noise). Neat Image needs uniform featureless areas of around 128x128 pixels (the minimum 
is 32x32 pixels). You can see some examples of such areas in the Examples section, page 44. 

                                                           
1
 You can check and adjust the location of the Profile folder using the menu Tools > Preferences > Folders. 
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If the input image does not contain such areas and you have no suitable alternative regular image that 
contains such areas, you can prepare a special test image and follow the case of building a noise profile 
using the Calibration Target. That is also recommended if you want to prepare a reusable noise profile 
for a certain mode of your camera or scanner. 

5.2.1. Stage I. Case of building a profile using a regular image 
To build a noise profile using a regular image you have to take 2 steps: 

Step 1. Preparing a regular image for noise analysis; 
Step 2. Analyzing the image noise. 
 

Step 1. Preparing a regular image for noise analysis 

To analyze noise in a regular image, you can use the input image or an alternative regular image that 
was produced by the same camera (or scanner) in the same or similar shooting (scanning) mode. Using 
the input image usually produces most accurate noise profile that perfectly matches the noise properties 
of this input image. However, if there are not enough flat featureless areas in the input image then you 
have to use an alternative regular image. 

Case of using the input image 

In this case, simply stay with the input image that is already opened in the Editor tab. The input 
image is displayed in both the Input Image and Device Noise Profile tabs. 

To build a profile, switch to the Device Noise Profile tab and proceed to the step 2 below. 

Case of using an alternative image 

If there is no large enough uniform featureless areas in the input image, use an alternative image. 
The alternative image is supposed to be produced by the same device working in the same or similar 
mode. This can be just another image from the same series; the image should contain at least one 
large enough uniform featureless area suitable for analysis. 

To open the alternative image: 

 Click    (the Open input image button) in the toolbar or use the File > Open Input Image… 
menu item. Select an image to be used for profiling. 

 Drag an image file from Windows Explorer and drop it to the image viewer in Neat Image. 

 Use the Edit > Paste menu item to copy-and-paste an image from another application to Neat Image 
through the Windows clipboard. 

 
Use the loaded alternative image to build a noise profile in the step 2 below. Then load the original 
input image back to process it using the newly built profile. 

 

Step 2. Analyzing image noise (profiling) 

Analyzing noise is the main part of building a noise profile for an imaging device working in a certain 
mode. The current version of Neat Image plug-in for Photoshop offers three ways of conducting the 
noise analysis (profiling): automatic, semi-automatic and manual one. Using automatic profiling is 
easier and therefore recommended for beginners. In difficult cases (for example if Neat Image cannot 
automatically find a uniform featureless area in analyzed image), automatic profiling may not work well 
or may produce less than perfect results. You can always override automatics and use semi-automatic or 
manual profiling. 

 Make sure you use the Device Noise Profile tab:  
 

Case of automatic profiling 

To analyze noise properties, Neat Image uses uniform image areas that contain noise but no visible 
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or important details. With automatic profiling, Neat Image tries to find one such area automatically 
and then uses this area to analyze image noise. 

 Click    (the Auto Profile button) in the toolbar, or use the Profile > Auto Profile with 

Regular Image menu item, or press F2. 

Neat Image will try to automatically find image areas suitable for analysis and will analyze them, 
first the primary selected area and then the rest of the image. If the primary selected area shown in 
viewer indeed contains no visible details then the resulting noise profile will be accurate. 

To be sure, check the profile Quality indicator in the bottom of the Device Noise Profile box. A profile 
built using a uniform and featureless image area will show a high value in this indicator. 

If the profile quality is high (for example, higher than 75%) then you can be sure that the noise 
profile is accurate. Please proceed to Stage II. Documenting noise profile, page 24. 

If the automatically-selected image area does contain visible details or the profile quality is not very 
high then try to use the semi-automatic profiling instead (see below). 
 

Case of semi-automatic profiling 

1) Find a uniform featureless image area 

 Manually find and select an image area that contains no visible details.1 

The area should be at least 32x32 pixels large. That is the minimum size; the recommended size is 
128x128 pixels or more (you can resize the selection frame). 
 
Scroll, pan, zoom the image to find a uniform image area and then select this area for analysis. 
 
If you cannot find a large enough uniform area in the input image, consider using an alternative 
regular image or use the Calibration Target as explained in the next section (Stage I. Case of 
building a profile using the Calibration Target, page 22). 
 

2) Analyze selected image area 

 Click    (the Auto Profile button). 

Neat Image will automatically analyze the selected image area and the rest of the image. 

The profile is now ready. Please proceed to Stage II. Documenting noise profile, page 24. 
 

Case of manual profiling (Advanced Mode only2) 

1) Find a uniform featureless area 

 Manually find and select an area that contains no visible details. 

The area should be at least 32x32 pixels large. This is the minimum size; the recommended size is 
128x128 pixels or more (you can resize the selection frame). 
 

2) Analyze selected area 

 Click    (the Auto Profile button). 

Neat Image will automatically analyze the selected area and build a noise profile. 
 

3) Additionally manually fine-tune the profile 

Fine-tuning uses additional flat featureless frame areas to make the noise profile more accurate. 

                                                           
1
 You can find some examples of uniform featureless image areas in the Examples section, page 44. 

2
 You can enable Advanced mode using the Tools > Advanced Mode menu item. 
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You must manually select and analyze several such areas one after another. 
 

1) Find and select a uniform featureless area 

 Scroll, pan, zoom the frame in the viewer in the Device Noise Profile tab to find a new uniform area. 

The size of an area may be from 16x16 to 256x256 pixels. Using larger areas makes fine-tuning 
more accurate. The selection edges will change their thickness according to the selection size. 
 

2) Analyze selected area with Manual Fine-Tune 

 Click    (the Manual Fine-Tune button) or use the Profile > Fine-Tune Using Selected Area menu item. 

The analysis results will be shown in the noise profile equalizer: the graphs of the equalizer will 
change some of the values (see the picture on the right). You can switch from one channel to 
another in the equalizer to better see a specific channel’s 
graph, or select to show them all together. 

The goal of manual fine-tuning is to fill the equalizer with 
measured values (shown as graph-color knots) in all points of 
the graphs. The previous steps (specifically, the Auto Profile 
function) may have already filled some of the values. Manual 
fine-tuning can further improve the analysis by filling out the 
still missing or interpolated values (shown as yellow knots) 
and/or making some of already measured values more precise. 
 

3) Repeat 1-2 above with other uniform areas of different brightness 

To make the device noise profile more accurate, fine-tune it using several uniform image areas. 
Select areas of different brightness for best results. Try to choose and analyze uniform areas to 
cover all or most elements of the equalizer in all its color channels. The more elements of profile are 
analyzed, the higher is the quality of the profile. 
 

4) Complete fine-tuning using Auto Complete 

 Click  (the Auto Complete button) or use the Profile > Auto Complete menu item to automatically 
complete the fine-tuning by adjusting the unmeasured values using interpolation based on the 
measured data. 

At this point the profile is ready. Proceed to Stage II. Documenting noise profile, page 24. 
 

5.2.2. Stage I. Case of building a profile using the Calibration 
Target 

The Calibration Target is specially designed to enable easy profiling of various imaging devices. It can 
be used to build a single profile for a certain device mode or a set of profiles for different modes. 

Follow the steps below to prepare a single profile using the Calibration Target. 

Step 1. Preparing the Calibration Target 

To use the Calibration Target, either go to menu Tools > Calibration Target and then click  
(the Display target… button), or download the image of the Target from the Neat Image web page: 
http://www.neatimage.com/win/standalone/testtarget.html 

There are two ways of using the Calibration Target: you can open it on the screen and take a shot (with 
a digital or film camera, depending on your workflow) or you can print it out and shoot the hardcopy. 

Shooting the Calibration Target off the screen is faster, especially with a digital camera. However, be 
careful when shooting it off the screen of a CRT monitor because you may occasionally capture scan 
bands. These bands may spoil a part of the shot. If you cannot avoid these bands, prepare a printed 
version of the Calibration Target or shot it off an LCD monitor, which does not produce this effect. 
Also, try to avoid glares when using a monitor with a glass or glossy screen. 



User Guide Neat Image standalone (Win) 
  

  
© 1999-2013 Neat Image team, ABSoft. All rights reserved. 23 24-Oct-13 

Case of shooting the Calibration Target off the screen 

 Open the Calibration Target image on the screen (menu Tools > Calibration Target and then click the 
Display target… button). Then use the displayed Calibration Target in the Step 2 below. 

Case of shooting the printed Calibration Target 

 Open the Calibration Target image in an image editor and print out the image on a sheet of white 
matte paper; make the image fill the whole page. Then use the printed target in the Step 2 below. 
 

Step 2. Preparing a shot or scan of the Calibration Target 

Case of digital camera 

Use the displayed or printed Calibration Target to prepare a test shot for building a device noise 
profile for your camera: 

1. Set the camera to a certain shooting mode (ISO level, etc.) you want to build a profile for; 

2. Important: set the focusing system on infinity or in macro mode to get a 
slightly-out-of-focus image of the target; 

3. Make sure the Calibration Target fills the whole frame and make a shot; 

4. Open the resulting shot in Neat Image (the step 3 below). 
 

Case of flatbed scanner 

Use the printed Calibration Target to prepare a test scan for building a device noise profile for your 
flatbed scanner: 

1. Set the scanner to a certain scanning mode (resolution, light level, etc.) you want to build a 
profile for; 

2. If possible set the scanner slightly out of focus (an out of focus scan is preferred for 
profiling); a possible way to achieve this is to raise the page over the scanner glass a bit; 

3. Scan the printed Calibration Target; 

4. Open the resulting scan in Neat Image (the step 3 below). 
 

Case of slide scanner 

Use the displayed or printed Calibration Target to prepare a test scan for building a device noise 
profile for your film scanner: 

1. Set the camera to a certain shooting mode (film type, exposure, etc.) you want to build a 
profile for; 

2. Important: set the focusing system on infinity or in macro mode to get a 
slightly-out-of-focus image of the target; 

3. Make sure the Calibration Target fills the whole frame and make a shot; 

4. Develop the slide and put it into the scanner; 

5. Set the scanner to a certain scanning mode (resolution, light level, etc.) that you want to 
build a profile for and scan the slide; 

6. Open the resulting scan in Neat Image (the step 3 below). 

 

Step 3. Analyzing image noise 

Open the shot or scan of the Calibration Target in Neat Image and use it to build a noise profile: 

 Click    (the Open input image button) in the toolbar or use the File > Open Input Image… 
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menu item. Select the shot or scan that you have just prepared. 

 Use the Profile > Auto Profile with Calibration Target menu item. 

After the analysis is completed, proceed to the Stage II below. 

 

5.2.3. Stage II. Documenting noise profile 
At this point of building the noise profile for your camera or 
scanner, the noise analysis is done and all important noise 
characteristics are gathered in the profile. You may still want to 
manually document the profile if Neat Image has not done this 
automatically. With most images from digital cameras, Neat Image 
is able to automatically extract the crucial information about the 
camera mode from the EXIF data fields of the analyzed image and 
put this information to the noise profile (you can see that in the 
Device Name and Mode fields in the Device Noise Profile box. 

If Neat Image has not automatically placed any information to the 
Device Name and Mode fields after noise analysis, you can fill out 
these fields manually.  

 Use the Device Name and Mode fields in the Device Noise Profile box. Here, you can specify the model 
of the image acquisition device and describe the device mode, which can be something like the data 
in the picture on the right. 

About the Device name and mode notes 

It is highly recommended to specify these details to keep record of devices, device modes, and 
corresponding device noise profiles that you use. 

The noise characteristics of any two devices can be extremely different. Even a single device in 
different modes can produce significantly different noise. Therefore, it is always better to use 
separate noise profiles for different devices and device modes to avoid inaccurate filtration and 
artifacts. Commenting on the device name and device mode parameters helps you keep track of 
them when you do manual profile matching, i.e., when you manually select a suitable profile to 
process an image. 

Automatic profile matching available in Neat Image uses the EXIF information from the image 
files and profiles, not the Device Name and Mode fields, so filling out these fields may not be 
necessary for automatic profile matching. However, filling out these fields is highly advisable 
both for the clarity purposes and for the cases of EXIF-less input images (in such cases, you have 
to manually select a suitable profile based on the Device Name and Mode fields). 

See the Preparing profile set for different device modes section below to learn more about camera 
and scanner parameters that may need to be documented in the Device Name and Mode fields. 

 

5.2.4. Stage III. Saving the noise profile 

 Use    (the Save Device Noise Profile As… button, blue disk) in the Device Noise Profile box or use the 
Profile > Save As… menu item. 

In the Save Device Noise Profile As… dialog box, select the desired file name for this profile. The 
default name is based on the device name and device mode when these are available from the EXIF 
data fields of the analyzed image. If the EXIF data are not available then the default profile name is 
based on the name of analyzed image file. Use the suggested default or change the name of the file 
to store the device noise profile. Device noise profiles are saved as *.dnp files. 

File naming considerations 

If you are going to re-use a device noise profile later on, select a good file name explaining the 
device name and mode so that you could easily recognize this profile by its file name. 
Alternatively, you can use special folder structuring to keep many device noise profiles arranged 
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according to their device modes. 

See Preparing profile set for different device modes: Stage III. Structuring profile set, page 27, 
for additional information. 

A saved noise profile includes the complete noise analysis. Therefore, by re-opening the noise 
profile, you can reproduce exactly the same conditions for image processing later on. 

5.3. Preparing profile set for different device modes 
Usually an imaging device can work in several different modes. Therefore, there should be several 
device noise profiles covering different modes to enable accurate processing of arbitrary images 
produced by this device. If a set of profiles covers all modes of the device then any image from this 
device can be processed by using one of the profiles from the set. 

This subsection explains how you can prepare a reusable set of profiles for a range of modes of an 
imaging device. 

As an owner of a certain imaging device you are in perfect position to prepare a profile set because you 
have direct access to the device hardware, you can adjust its shooting mode and take test shots. 
Moreover, using your own set of profiles makes noise reduction more accurate because such profiles 
better reflect the specifics of the camera or scanner as well as the workflow you use. 

When building a set of profiles, please follow the guidelines below that will help you structure the 
profile set in such a way as to make consequent reuse of the set easy for you1. 

5.3.1. Stage I. Selecting device parameters for profile set 
To build a set of profiles for particular camera or scanner, you must identify the device parameters that 
affect the noise characteristics and that you will take into account during profiling. There may be many 
device parameters but not all of them influence image noise and those that do differ by the strength of 
their influence. Naturally, you are only interested in those parameters that appreciably affect noise. 
Different noise profiles should be prepared for different values of important parameters, so you have to 
identify these parameters in the first place. 

The tables below describe the parameters that appreciably affect noise characteristics (from the most to 
the less important ones) of digital cameras and scanners: 

Digital camera parameters in the order of decreasing importance 

ISO rate 50, 100, 200, 400, etc.; depends 
on a camera 

Higher ISO rate produces more noise. 

Camera noise 
reduction 

High, Normal, Low, etc.; 
depends on a camera 

In-camera noise reduction can reduce levels of noise in 
photos (usually at expense of some details). 

Sharpness 
adjustment 

Low, Normal, High, etc.; depends 
on a camera 

Internal sharpness adjustment of a camera makes noise 
more intensive. Using no internal sharpness 
adjustment produces least noise. 

Compression 1:1 (or Uncompressed), 
1:5 (or Fine), 1:10 (or Normal), 
1:20 (or Basic), etc. 
or 
2 bits/pixel, 4 bits/pixel, etc. 
depends on a camera 

Strong JPEG compression typically produces more 
JPEG artifacts and destroys image elements including 
noise; weaker compression preserves more image 
elements including noise created by the image sensor. 
It is preferable to use the lowest amount of 
compression for the best results. 

Resolution 1:1 (original resolution, like 
4288x2848), 1:2 (downsized in 
camera, e.g., 2144x1424), 2:1 
(digital zoom, 2x), etc. 

Camera’s internal interpolation (both downsizing and 
upsizing, e.g., that of digital zoom) changes many 
characteristics of noise. 

                                                           
1
 ...and other people if you decide to share your results. Please do share because in this way you will help people with 
the same camera or scanner model. You can submit a set of profiles to the Neat Image team to publish the set in the 
profile library in www.neatimage.com (see Contacts, page 52) or just share them with other people directly. 
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White balance Sun, Cloudy, Incandescent, 
Fluorescent, etc.; 
depends on a camera 

White balancing changes characteristics of noise 
(mainly of color noise) slightly. 

Exposure 1/16s, 1.0s, 16s; Longer exposures produce more hot-pixel noise; also, 
some cameras switch on the automatic noise reduction 
when exposure is longer than a certain threshold – this 
may affect the noise levels. 

 

Scanner / camera parameters in the order of decreasing importance 

Film type For example, Kodak Tmax 400, 
Kodak Tri-X Professional 320, 
Fuji Superia 200, etc. 

Every film type produces specific grain pattern, which 
depend on film materials. Strength of the grain depends 
on ASA/ISO rate of the film. 

Scanning 
resolution 

For example, 300 dpi, 3200 dpi, 
4000 dpi, etc. 

Higher scanner resolution emphasized film grain and 
makes it more evident in the scanner image. 

Number of 
scan passes 

Single pass, 
2x pass, 
4x pass, etc. 

Multi-pass scanning can potentially produce less grainy 
images.  

If two images were captured in the same or similar conditions (most of the above device mode 
parameters are the same) then the noise of these two images should be very similar. If you have built a 
device noise profile using one of these images, you can use this profile to filter both images with good 
results. If the shooting or scanning conditions were different then the noise in two images could be 
significantly different. In this case, cross-use of one noise profile is not recommended. Instead, two 
different profiles should be built and used to filter these two images. 

Based on these considerations and tables above, identify the device mode parameters of your camera or 
scanner that (1) are important from the noise standpoint and (2) are changed in your imaging tasks. For 
example, if you never change the sharpness adjustment of your digital camera then there is no need to 
build profiles for different values of the sharpness adjustment parameter. On the other hand, if you do 
shoot with different ISO rates then you have to build profiles for every ISO rate you use. Some 
parameters are less important (for example, the White Balance or Exposure) and you may simply 
choose to ignore the difference in noise characteristics caused by such device mode parameters. 

Identify and make a list of the device mode parameters that are important for your needs. For example, 
you could include the ISO rate: ISO 100, 200, 400; and JPEG compression level: HQ, SHQ. Then it is 
straightforward to write down all combinations of the selected parameters: 

JPEG HQ, ISO 100 
JPEG HQ, ISO 200 
JPEG HQ, ISO 400 
JPEG SHQ, ISO 100 
JPEG SHQ, ISO 200 
JPEG SHQ, ISO 400 

Now you must prepare an individual profile for each combination from this list. Please proceed to the 
Stage II to build profiles for all combinations. 

 

5.3.2. Stage II. Building individual profiles 
To build individual profiles for the profile set, you can either use the standard profiling procedure 
described earlier, or employ a special Neat Image tool – the Batch Profiler. 

Using standard profiling procedure 

To build individual profiles using the standard profiling procedure, follow the guidelines of the 
Building a profile for a device mode section, page 19. Using those guidelines, build a new profile for 
every combination of the device mode parameters included in your list as described in the Stage I above. 
The resulting set of noise profiles (several *.dnp files on the disk) can be further structured as explained 
in the Stage III below. 
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Using Batch Profiler 

The Batch Profiler is a dedicated tool that can automatically build several noise profiles using shots or 
scans of the Calibration Target (please note that the Batch Profiler is not for regular images). To use this 
tool, you must prepare several shots (scans) and then analyze them all at once using the Batch Profiler. 

1. Preparing set of images of the Calibration Target 

To prepare shot or scan of the Calibration Target for every combination of device mode parameters, 
please follow the two initial steps of Stage I. Case of building a profile using the Calibration Target: 

Step 1. Preparing the Calibration Target, see page 22. 
Step 2. Preparing a shot or scan of the Calibration Target, see page 23. 

Do the Step 2 for every combination of device parameters in your list. Then place all resulting image 
files (*.jpg, *.tiff, *.png) to a new folder (and its subfolders if necessary) on the hard drive, for example: 
 Documents\Target Images\ 

2. Preparing profiles 

To prepare profiles using the images of the Calibration Target: 

1. Select the Tools > Batch Profiler… menu item to open the Batch Profiler window. 
 

2. In the Batch Profiler window, specify the folder with images of the Calibration Target and the folder 
where the Batch Profiler should save prepared device noise profiles. 
 

3. Click the Start button to initiate profiling process. 
When profiling is finished, new noise profiles are saved in the selected target folder. 
 

4. Use the Close button to close the Batch Profiler window. 

As the result, you have a set of noise profiles (several *.dnp files on the hard drive) that have to be 
structured as described in the Stage III below. 

5.3.3. Stage III. Structuring profile set 
In the Stage II, you have prepared a set of profiles, they are now saved on the disk. You have assigned 
names to these profiles that reflect the device modes they correspond to. 

For example, profiles for Olympus C5050Z could be named like the following: 

 Olympus C5050Z 

 C5050Z (ISO100; JPEG HQ; SharpNormal; 2560x1696).dnp 

 C5050Z (ISO100; JPEG HQ; SharpNormal; 2560x1920).dnp 

 C5050Z (ISO100; JPEG SHQ; SharpNormal; 2560x1696).dnp 

 C5050Z (ISO100; JPEG SHQ; SharpNormal; 2560x1920).dnp 

 C5050Z (ISO200; JPEG HQ; SharpNormal; 2560x1696).dnp 

 C5050Z (ISO200; JPEG HQ; SharpNormal; 2560x1920).dnp 

 C5050Z (ISO200; JPEG SHQ; SharpNormal; 2560x1696).dnp 

 C5050Z (ISO200; JPEG SHQ; SharpNormal; 2560x1920).dnp 

 C5050Z (ISO400; JPEG HQ; SharpNormal; 2560x1696).dnp 

 C5050Z (ISO400; JPEG HQ; SharpNormal; 2560x1920).dnp 

 C5050Z (ISO400; JPEG SHQ; SharpNormal; 2560x1696).dnp 

 C5050Z (ISO400; JPEG SHQ; SharpNormal; 2560x1920).dnp 

 C5050Z (ISO100; TIFF; SharpNormal; 2288x1712).dnp 

 C5050Z (ISO100; TIFF; SharpNormal; 2560x1696).dnp 

 C5050Z (ISO100; TIFF; SharpNormal; 2560x1920).dnp 

 C5050Z (ISO200; TIFF; SharpNormal; 2288x1712).dnp 

 C5050Z (ISO200; TIFF; SharpNormal; 2560x1696).dnp 

 C5050Z (ISO200; TIFF; SharpNormal; 2560x1920).dnp 

 C5050Z (ISO400; TIFF; SharpNormal; 2288x1712).dnp 

 C5050Z (ISO400; TIFF; SharpNormal; 2560x1696).dnp 

 C5050Z (ISO400; TIFF; SharpNormal; 2560x1920).dnp 

 – disk folder 
 

C5050Z 
 – camera name 

 
ISO ### 
 – ISO rate of camera mode 

 

JPEG SHQ / JPEG HQ / 
TIFF 

– file format and 
compression level 

 

Sharp##### 
 – sharpness adjustment 

 

#### x #### 
 – image size 
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When the profiles are named like this, manual selection of a suitable profile is simple. You can check 
the device mode of the input image (using the Image Metadata information in the Input Image tab or using 

 button in the bottom of image viewer) and then select a profile for this mode from the popup menu. 

 
There is another way to select profile for an image, based on structuring the profile set using the disk 
folders. For example, the above Olympus C5050Z profile set could be structured like this: 

 Olympus C5050Z 

  TIFF (Uncompressed) 

   2048x1536 

   ISO 100.dnp 

   ISO 200.dnp 

   ISO 400.dnp 

   2288x1712 

   ISO 100.dnp 

   ISO 200.dnp 

   ISO 400.dnp 

   2560x1696 

   ISO 100.dnp 

   ISO 200.dnp 

   ISO 400.dnp 

   2560x1920 

   ISO 100.dnp 

   ISO 200.dnp 

   ISO 400.dnp 

  JPEG 

   HQ (2bpp) 

    2560x1696 

    ISO 100.dnp 

    ISO 200.dnp 

    ISO 400.dnp 

    2560x1920 

    ISO 100.dnp 

    ISO 200.dnp 

    ISO 400.dnp 

   SHQ (5bpp) 

    2560x1696 

    ISO 100.dnp 

    ISO 200.dnp 

    ISO 400.dnp 

    2560x1920 

    ISO 100.dnp 

    ISO 200.dnp 

    ISO 400.dnp 

 – disk folder 
 

Olympus C5050Z, 
 JPEG  / TIFF, 
#### x #### 
- the names of disk subfolders containing 
device noise profiles for corresponding 
device modes; 

 
ISO ###.dnp 
- device noise profiles;  
  

Note that constant parameter (Sharpness 
adjustment) is not reflected in the folder 
structure. However, if there were profiles 
with different values of these parameters 
then additional subfolder should be added. 

Parameters that can be disregarded, such 
as exposure time, are not reflected in the 
folder structure too. 

In this case, the folder tree stores device noise profiles in a structured way, which helps to select one 
profile from the set given the device mode of the input image. 

Note that the automatic profile matching provided by Neat Image does work well in both cases: you can 
keep the whole set of profiles as a flat list of files in one folder, or you can structure the files into 
subfolders. This choice only affects the convenience of manual selection of profiles, while automatic 
profile matching can handle both cases equally well. 

If the automatic profile matching is not available (for example, if the images or profiles contain no EXIF 
information or the available EXIF details are incomplete) then you have to select profiles manually. 
Therefore, we recommend to structure profiles according to one of the methods above to make your 
manual work easier. 
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5.3.4. Stage IV. Documenting profile set 
Along with the text comments inside the device noise profiles and their file names, we recommend to 
document the whole profile set with a plain text file explaining the following points: 

 Author of the profile set and profiling date 
 Device name, firmware version 
 Device modes that have been profiled in this set 
 Device mode parameters that change within the profile set 
 Device mode parameters that are constant for all profiles in the set 

 Post-processing applied (after receiving image from imaging device and before Neat Image) 

An example of such a description is below: 

Olympus C5050Z noise profiles 

by John Smith, October 24, 2013 

 

A set of profiles for Olympus C5050Z TIFF and JPEG files. The profiles were built using shots of the Calibration Target for 
the following file formats and image sizes: 

 TIFF: 2048x1536 / 2288x1712 / 2560x1696 / 2560x1920 

 JPEG HQ / SHQ: 2560x1696 / 2560x1920 

 

For each file format and image size above, shots with different ISO rates (100, 200 and 400) were made and used to build 
profiles. 

Default camera settings were used for Sharpness, Contrast, and Saturation. In-camera noise reduction was switched off. The 
white balance was set to daylight. 

No post processing was applied; the calibration target shots directly from the camera were opened in Neat Image to build 
profiles. 

Such kind of summary would help you figure out any set of profiles you prepared as well as let other 
people understand your results if you decided to share your profiles. 

5.4. Using noise profiles 
When you have a set of profiles for your camera or scanner, you can directly use these profiles to 
process images in Neat Image. Usually there is only one profile that is most suitable to process a given 
input image. Therefore it is very important to select the right profile, which would provide the best 
match between profile and image. Profiles in a set usually correspond to different modes of the imaging 
device. To make a perfect match between a profile and image, the device mode of a profile should be the 
same or very close to the device mode used to capture the image. 

There are two ways to select a device noise profile that matches the input image: 

 To automatically select the most suitable profile from a pre-built set of profiles using Auto Match 
(see page 11 to learn how to use Auto Match); 
 

 To manually select the most suitable profile from a pre-built profile set based on mode 
comments (see page 11 for details). 

When you select and load a profile in either way, Neat Image shows the degree of match between the 
profile and input image. This degree is shown by the Match indicator in the Device Noise Profile box. The 
match degree is calculated on the basis of the image and profile’s metadata (the EXIF data fields). If the 
profile’s device mode is exactly the same as device mode used to capture the image then the match is 
100%. There is always 100% match between an image and profile built using this very image (Neat 
Image displays that using the note “(AP)” in the Match indicator). If the device modes of a profile and 
image are very close then the match degree is close to 100%. The more different the device modes of 
profile and image, the lower the match degree. Use the match degree as an indication of match accuracy. 
If the match degree is low then it is likely that building a new profile (using the current input image or 
the Calibration Target shot in current device mode) would produce better noise reduction results. 

Obviously it is preferable to build a new noise profile for each new input image (unless the image does 
not allow building a quality profile because it contains no large uniform areas for analysis), because 
such a profile would perfectly match the noise of that image. Nevertheless, any noise profile can, with 
some degree of accuracy, be used to process other images captured by the same device working in the 
same or similar mode. This is less accurate than building a profile for each image but saves time because 
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building a new quality profile can take more time than re-using a pre-built one. This is especially 
important if one profile is re-used many times, for example to process a series of images produced in 
one device mode. Also, it may not always be possible to build an accurate profile using input image 
when it contains no flat featureless areas. 

When using pre-built profiles, you may also want to pay attention to the Quality indicator in the Device 

Noise Profile box. A properly-built and fine-tuned profile will show a high value in this indicator. If the 
profile quality is high (for example, higher than 75%) then you can be sure that the profile is accurate. 

Both Quality and Match indicators should usually show high values for the noise reduction of the current 
input image using the current noise profile to be accurate. 



User Guide Neat Image standalone (Win) 
  

  
© 1999-2013 Neat Image team, ABSoft. All rights reserved. 31 24-Oct-13 

6. Additional tools 

6.1. Alternative modes of image viewer 
The image viewer in Neat Image can show the currently processed image in several alternative modes to 
enable detailed examination of both channel and frequency components. Examining the components 
helps to find flat featureless image areas for noise analysis. Also, that allows to visually compare the 
original and filtered version of each component and to find optimum filter settings for the corresponding 
component easier and faster. 

 Use  (Viewer mode button) in the viewer toolbar to select the desired 
viewer mode. 

The viewer mode will change accordingly and will display the image 
components separately or as one composite image. 

Examine individual channel and frequency components of the image, check the 
presence of noise in individual components. Working in the Noise Filter Settings 
tab, you can use the separately displayed components to identify those components that do not get 
enough (or get too much) noise reduction and adjust the corresponding filter settings. 
 

You can also adjust the brightness of the viewer to easier see the image details and noise in very dark or 
very bright areas of the image: 

 Use  (the viewer brightness controls) in the viewer toolbar to adjust and/or reset the 
viewer brightness to better see the noise and details in very dark or very bright areas of the image. 

Please note that this adjustment does not change the underlying image data in any way. The 
adjustment only affects the image viewer, i.e., the way the images are displayed in it. 

 

6.2. Navigator 
The image viewer has an additional Navigator panel, which offers an easy way to locate and navigate to 
an area of interest in a large image that does not entirely fit into the viewer, for example when you zoom 
into the image to see its fine details. When using Navigator you don't need to zoom out and then again 
zoom in (though such an approach to locating an area of interest can be used as well). 

 Use   (the Navigator button in top-left corner of the viewer), the Tools > Navigator menu item or 
press F8 to open or close the Navigator panel. 

 Use the mouse pointer to drag the visible area frame to the desired image position within the 
Navigator panel. This will make the main viewer navigate to the same position in the image. 

 

6.3. Profile Viewer 
The Profile Viewer provides detailed information about the currently used noise profile.  

 Use  (the Profile viewer button) in the Device Noise Profile box in the Device Noise Profile tab to open 
the Profile Viewer window. 

The Profile Viewer provides the following details: 

 Overall Profile Quality – this is an estimation of the overall quality of the noise analysis contained 
in this profile. The higher this value the better this profile seems to be. A quality profile is 
necessary for quality noise reduction. 
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 Noise Sample – this is an optional noise 
sample (a crop from the image used to 
build this profile). The noise sample 
helps you visually evaluate the noise 
described by this profile. Also, you can 
easily see whether any details are present 
in this area, which makes the profile less 
accurate (only flat featureless areas 
without any details should be used for 
profiling, so the sample should contain 
no visible details). 
 

 Clipping – this indicator tells whether 
there is any clipping in the analyzed 
image area. Clipping occurs when the 
sample contains pixels that are very close 
to or in fact are entirely white (or entirely black). Clipping reduces the overall profile quality. 
 

 Uniformity – these values show how uniform the noise sample is in all color channels. The 
uniformity is low when any details are present in the area. Low uniformity reduces the overall 
profile quality. 
 

 Fine-Tuning – this indicator tells how well this profile is fine-tuned. Fine-tuning is a part of 
profiling process (both automatic and manual) and the more complete and accurate the 
fine-tuning the higher the overall profiling quality. If you work with Neat Image in Advanced 

mode then you can see that the more equalizer values are filled in with measured data the higher 
the overall profile quality is. You can improve the profile quality by additional fine-tuning. 
 

 Noise Levels – these figures show the actual noise levels measured by the noise analyzers during 
profiling. There are the overall noise level and noise levels in channel and frequency 
components. These figures are a good indication of how noisy an image source is. 
 

 Image Metadata – this box contains the EXIF information associated with the image used to build 
this profile. This information is used by Neat Image to find a profile that matches an input 
image. 
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7. Batch processing 
Neat Image standalone can automatically process multiple images. To do that, you can create several 
image filtration tasks (one task is one input image to be processed) and let Neat Image process the tasks 
one after another. 

You can create several tasks one by one, and you create many tasks at once. 

You can use the same filtration parameters for all tasks or customize groups of tasks or individual tasks 
with different filtration settings. You can modify parameters of any task at any time. 

In this section, we explain in details how you can use all these capabilities of Neat Image. 

7.1. All Tasks tab 
When you normally start Neat Image, it usually opens with the Editor tab open. To process many images 

switch to the All tasks tab:  (if there is no All tasks tab, press the Esc button). 

Then you can process many images using the tools available there. This is how it looks like: 

 

The All tasks tab contains the list of image filtration tasks (in the central part of the window), a set of 
tools to create, edit, configure, remove, start and stop tasks, and the panel on the right with detailed 
information about the currently selected image filtration task(s). 
 

7.2. Creating new image filtration tasks 
Each filtration task in Neat Image includes one input image and one customized set of filtration settings. 
To process many images you must create many image filtration tasks using the available methods: 

To create one image filtration task 

 Click    (the Add new task(s) button) in the toolbar and then select Add Image(s)… in the popup 
menu; or use the Task > Add Image(s)… item in the main menu. 

Neat Image will then open the Select input image(s) dialog to let you select the input image to be 
processed. Select an image on the disk and click the Open button. 

A new filtration task with the selected image will be created and added to the list of tasks. The left 
panel of the Neat Image window will also show the thumbnail of the added input image. 



User Guide Neat Image standalone (Win) 
  

  
© 1999-2013 Neat Image team, ABSoft. All rights reserved.  34 24-Oct-13

At this point you can proceed to work with this new task in a single-task manner (using the workflow 

described in the Filtration process details section, page 9; to do that just click  in the toolbar or 
click the Edit this task icon inside the thumbnail of the task in the left panel). 

Instead of going to Editor to work with new task, you may also want to create more filtration tasks using 
the same procedure described above and later configure all created tasks all at once and let Neat Image 
process them all together. Or you can also create several more new filtration tasks in a more automated 
ways as described below. 

To create several image filtration tasks 

Method 1: select several images 

 Click    (the Add new task(s) button) in the toolbar and then select Add Image(s)… in the popup 
menu; or use the Task > Add Image(s)… item in the main menu. 

In the Select input image(s) dialog, select several images instead of one (you can hold the Shift or Ctrl 
key pressed to select multiple images) and then click the Open button. 

A new filtration task will be created for every selected image. All newly created tasks will be added 
to the list in the All tasks tab. The left panel of the Neat Image window will also show thumbnails of 
the added input images. The settings of new tasks will be based on the Defaults specified in the 
Preferences. 

Method 2: select a folder with images 

 Click    (the Add new task(s) button) in the toolbar and then select Add Folder… in the popup 
menu; or use the Task > Add Folder… item in the main menu. 

In the Browse For Folder dialog, specify the folder with images that you want to process and then 
click the OK button. 

A new filtration task will be created for every image found in the specified folder and all its 
sub-folders. The new tasks will be added to the list in the All tasks tab. The left panel will also show 
thumbnails of the added input images. The settings of new tasks will be based on the Defaults 
specified in the Preferences. 

Method 3: select any combination of images and folders and customize task settings 

 Click    (the Add new task(s) button) in the toolbar and then select Batch… in the popup menu; or 
use the Task > Batch… item in the main menu. 

Neat Image will then open the Batch dialog to let you specify the input images, device noise profiles 
to be used, filter settings, output settings, etc. 
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 Locate the images to be processed using the browser in the Input Images box (left side of the dialog). 
Check boxes against individual image files to be processed and/or against folders with images (then 
all images in checked folders and sub-folders will be selected for processing as well). 

To check the boxes use the mouse or press the Space button on the keyboard. 

When selecting individual images you can see their thumbnails and metadata in the Image Information 
box in the central part of the dialog window. Use that preview to select right images for processing. 

 In the Device Noise Profiles box, specify how noise profiles should be prepared for the images 
selected in the Input Images box: 

 Do not prepare noise profile - to not automatically prepare any profile(s); do that later manually 
 Auto Profile - to automatically build a profile for each image 
 Auto Match - to find the best matching profile for every image 
 Smart Profile - to try both Auto Profile and Auto Match and select the best profile 
 Use specified profile - to use a specified profile for all images 

When Use specified profile is selected, click    (blue folder) or the popup menu (click ) to 
specify the noise profile to be used. 

When available, check the Auto fine-tune option to automatically fine-tune selected profile(s) during 
processing. When Auto profile image is selected auto fine-tuning is applied automatically. 

 In the Filter Settings box, select the filter preset to process the images selected in the Input Images box: 

 Use program’s default settings - to use the filter settings pre-programmed by default; 
 Use specified custom preset - to use a custom preset loaded from the disk. 

When Use specified custom preset is selected, click    (pink folder) or the popup menu 
(click ) to select a filter preset to be used to process the selected images. 

 In the Output Images box, specify the Bitdepth using the drop-down list. Select 8 bits per channel, 16 bits 

per channel, 32 bits per channel, or Match input. In the latter case, the output images will have the same 
bitdepth as the corresponding input images. 

 Select the way the output image should be saved when filtration is finished: 

 Do not auto save output images   - to not automatically save output images (save manually) 
 Save to folder(s) of input images - to automatically save the output images next to the input images 
 Save to specified folder  - to automatically save the output images into one specified folder 

When Save to specified folder is selected, select the folder using  (the Browse button). 

 Select the output File format: JPEG, TIFF, PNG or BMP. 
When JPEG is selected, you can also adjust the JPEG Quality level (50-100; 100 is the highest for 
the best quality, 50 is the lowest for the smallest file size). With PNG, you can select the 
Compression level (0 is for the lowest compression and 9 is for the highest compression / smallest 
file size). 

 Below the Output Images box, check Auto remove completed tasks if you want to automatically remove 
completed tasks from the list of the filtration tasks. This is only possible if Neat Image is instructed 
to automatically save the output images (otherwise the output images would be lost). Once the 
output images are saved, the tasks can be removed from the list. 

 Click    to add new image filtration tasks to the task list in the All tasks tab. 

Several new image filtration tasks will be created in the list. 

Neat Image may then automatically start processing these new tasks, provided: 
 (1) the new tasks are ready for processing (contain valid input images and noise profiles) and 
 (2) processing is not generally suspended. 

Please see the Processing image filtration tasks section, page 37, for further workflow details. 
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Method 4: use drag and drop 

 Drag one or several image files from another application (for example, from Windows Explorer) 
and drop them in Neat Image window. Neat Image will automatically create new filtration tasks for 
each dropped file. The settings of new tasks will be based on the Defaults specified in the 
Preferences. 

Method 5: use Send To command in Windows Explorer 

 Select one or several image files in Windows Explorer, right click on them and use Send To > Neat 

Image. Neat Image will automatically create a new image filtration task for each selected image file. 
The settings of new tasks will be based on the Defaults specified in the Preferences. 
 

7.3. Configuring image filtration tasks 
You can change the parameters (such as noise profile, filter preset, etc.) of any filtration task available 
in the list of tasks. Usually, you will change some parameters during or after adding new tasks. For 
example, after adding some new tasks you may want to instruct Neat Image to use Auto Profile to 
prepare noise profiles for all these tasks. Or you may specify a fixed noise profile available on the disk. 
Or assign a specific custom filter preset to process all selected tasks. All that can be done directly in the 
All tasks tab using the controls available around the task list. Below you will find a description of all 
these controls. To use any of them to adjust parameters of one or several tasks, select some tasks in the 
list of tasks and then use the tools as described below. 

To assign a noise profile to selected task(s) 

Select one or several tasks in the list of tasks and: 

 Click  (the Auto Profile button) in the toolbar or use the Task > Auto Profile menu item to instruct 
Neat Image to use Auto Profile to automatically build a new noise profile for every selected task. 

 Click    (blue folder) in the toolbar or use the Device noise profile popup menu in the Filtration Task 
box (or use the Task > Set Profile… menu item) to specify a noise profile to be used in all selected 
tasks. 

 Click    (the Profile Matcher button) in the toolbar or use the Task > Match Profile menu item to 
automatically find and assign matching profiles to selected tasks. 

 Click    (the Auto Fine-Tune button) in the toolbar or use the Task > Auto Fine-Tune menu item to 
make Neat Image automatically fine-tune the assigned noise profile to the input image for every 
selected task. 
 

To assign a filter preset to selected task(s) 

Select one or several tasks in the list of tasks and: 

 Click    (pink folder) in the toolbar or use the Filter preset popup menu in the Filtration Task box (or 
use the Task > Set Preset… menu item) to assign a filter preset to all selected tasks. 
 

To edit a selected task in Editor 

Please note that you can do only most general changes to the tasks using the tools available in the All 

tasks tab. For example, you can assign a specific noise profile to a group of tasks. However, to do any 
more subtle modifications like manual profiling with some manual tuning of filter settings requires 
using the Editor. To do that simply select any task and open it in the Editor tab for detailed examination: 

 Select a task in the list and click    (the Edit selected filtration task button) or use the Task > Edit… 
menu item. 

Neat Image will open the selected task in the Editor tab to let modify all details of the test: input 
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image, device noise profile and filter settings. You can then use the tools and workflow described 
earlier (the Filtration process details section, page 9). 

At any moment, you can switch back to the All tasks tab, select another task, apply any other 
changes, etc. 
 

7.4. Processing image filtration tasks 
As soon as you have created one ore more filtration tasks, Neat Image will try to automatically process 
them, unless processing is manually suspended. You can control that using the buttons in the left bottom 
corner of the Neat Image window, right above the All tasks tab: 

 Click the  (the Suspend All button) to suspend processing all tasks in the list. 

 Click the  (the Resume All button) to resume processing all tasks in the list. 

Not every task can be automatically processed though. To be processed automatically, a task must be 
configured, which means it should have an input image and noise profile specified. While an input 
image is almost always available, a noise profile may be in some cases not available. A newly created 
task may get a noise profile from the Defaults section of Neat Image Preferences (menu Tools > Preferences 

> Defaults), or you may specify it manually when creating or configuring the task. 

If some of the tasks do not yet have any assigned noise profile (they show the status “profile not ready” in 
the Profile column in the list of tasks) you can assign a profile using one of the options described the 
previous section (Configuring image filtration tasks, page 36). 

As soon as a task is provided with a profile, it can be automatically processed and Neat Image will 
immediately try to do that. You will then see running progress indicators, changing statuses of profile, 
its quality, match level, output image, etc. 

You can stop processing at any moment using the above Suspend All button and resume it later. 
 

7.5. Saving output images 
When an image filtration task is completed, Neat Image will try to automatically save the output image 
(if you instructed it to do so or if the Output settings in Preferences instruct it to save output images 
automatically). You can also save the output image manually, either from the Editor tab or directly from 
the All tasks tab. In the All tasks tab, you can save several output images at once. 

To automatically or manually save output image(s) of filtration task(s) 

 Select one or several tasks (they do not need to be fully processed yet) and click    (the Save 

output image as button) in the toolbar or use the Task > Save Output… menu item. 

Neat Image will open a dialog to let you specify how you want to save the output images of all 
selected tasks (when these output images will be ready, if they are not prepared yet). 

Neat Image may ask about particular image saving properties, e.g., the JPEG quality level, about 
the folder where you want to save the output images. 

In some cases, you can additionally select the option called Auto remove completed tasks. When that 
option is enabled, Neat Image will remove (meaning close) the tasks from the list of tasks after 
saving the output images to the disk. If it is not selected, you can later remove the completed tasks 
manually. 

You can instruct Neat Image to always automatically save output images (use the menu Tools > 

Preferences > Output > Auto save output images). In this case, you will not have to manually save output 
images; Neat Image will do that for you automatically whenever possible. 
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7.6. Removing image filtration tasks 

To remove image filtration task(s) from the list 

When you finished working with an image filtration task and saved the filtered output image to the disk, 
you may not need this task anymore and may want to remove it from the list of tasks. 

 Select one or more filtration tasks in the list that you want to remove and click    (the Remove 

selected filtration task button) or use the Task > Remove menu item or just press the Delete button on 
the keyboard. 
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8. Preferences 
There are several preferences that adjust the behavior of Neat Image standalone. 

Use the Tools > Preferences… menu item to open the Preferences dialog box. 

8.1. General preferences 

Auto zoom to fit on image open 

Check this option to make the image viewer automatically adjust zoom level to fit the image into the 
window. 
 

Show hints over interface controls 

This option switches on/off the hints. The hints are displayed when the mouse pointer is placed over any 
control in the Neat Image interface. 
 

Show splash screen at startup 

This controls whether the splash screen (the Neat Image logo) is displayed at the application startup. 
 

8.2. Defaults 

Default Device Noise Profile 

There are several possible ways to assign a noise profile to a newly created image filtration task: 

 Do not prepare noise profile automatically 
If this variant is selected then no device noise profile is loaded when a new task is created. 
You will have to manually assign or build a noise profile for the input image. 
 

 Auto Profile 
If this variant is selected then a new profile is automatically built by analyzing the input image; 
This provides the most accurate noise analysis but takes a bit more time and may not always work 
(if the input image does not contain enough flat featureless areas for analysis). 
 

 Auto Match 
If this variant is selected then the Auto Match function tries to select the most matching profile 
(matching the input image) from a pre-built set of profiles; 
This provides shorter overall processing times when pre-built noise profiles are available and can 
be matched against the input image (matching requires both profiles and images to contain EXIF 
metadata). 
 

 Smart Profile (Auto Profile and Auto Match) 
If this variant is selected then Neat Image uses both Auto Profile and Auto Match to prepare two noise 
profiles and then selects the better of two resulting profiles. This provides higher overall quality at 
expense of slightly longer processing time. To be fully efficient, this option also needs a pre-built 
set of noise profiles (for Auto Match to work). You can configure the behavior of the Smart Profile 
function in the Smart Profile section of the Profiling tab. 
 

 Use specified default profile 
If this variant is selected and a valid profile is specified then it is automatically loaded when a new 
image filtration task is created. 
Useful when all input images were produced by the same device working in the same or similar 
device modes. 
 

 Auto fine-tune  
If this option is checked then Neat Image additionally fine-tunes the assigned noise profile by 
analyzing the input image. 
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This provides higher accuracy of resulting noise reduction when the input image contains flat 
featureless areas suitable for fine-tuning noise analysis. 
 

Default Filter Preset 

There are two ways to assign a filter preset to a newly created image filtration task: 

 Use program’s default settings  
If this variant is selected then no custom preset is loaded from the hard drive when a new filtration 
task is created, instead Neat Image uses its pre-programmed default filter settings. You will still be 
able to manually assign a filter preset for the input image. 
 

 Use specified custom preset 
If this variant is selected and a valid filter preset is specified then it is automatically loaded when a 
new task is created. 
This setting is useful when you want to apply filtration using the same custom filter settings to all 
input images. 
 

8.3. Profiling preferences 

Save noise samples in profiles 

Enable this option to make Neat Image save a noise sample from the analyzed image area into device 
noise profile (*.dnp file). This will increase the size of the *.dnp file but will also improve the 
compatibility with the future versions of the software (Neat Image will be able to re-build the profile 
using the saved noise sample). 
 

Show warnings about selected image area 

Enable this option to let Neat Image display warnings about selected image area during profiling. For 
example, Neat Image may warn you about clipping or non-uniformity detected in the selected area, thus 
helping you select a better area for profiling. 
 

Smart Profile 

Smart Profile is one of the possible ways to prepare a noise profile for an image filtration task. Smart Profile 
uses both Auto Profile and Auto Match (with Auto Fine-Tune) to prepare two candidate profiles and then 
selects the better of two profiles. 

Use the settings in the Smart Profile box to configure the behavior of the Smart Profile function. 

Automatically select the best profile 

Use this option to let Neat Image automatically decide which noise profile to use. 

Prefer profile prepared by Auto Profile 

Let Neat Image preferably select the profile prepared by Auto Profile when it can find a good area for 
analysis in the input image. When the area is not very good then Neat Image will use the profile 
prepared by Auto Match with Auto Fine-Tune. 

Prefer profile prepared by Auto Match and Auto Fine-Tune 

Let Neat Image preferably select the profile prepared by Auto Match when it can find a matching profile 
among the pre-built noise profiles, even when Auto Profile provides a good profile as well. 
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8.4. Matching preferences 

8.4.1. Profile Matching 
Use profile matching preferences to adjust the way Neat Image matches noise profiles to input images. 

Look for noise profiles in the following folder: 

If you select this option then Neat Image will look for matching noise profiles in the specified folder. If 
you have several sub-folders with profiles, select the topmost folder of all those subfolders to let Neat 
Image search in all of them. 

By default, the folder used to store profiles (see the Folders > Profile folder setting in the same Preferences 
window) is used for matching. You can use any other (sub-)folder for profile matching as well. 
 

Look for noise profiles in folders of input images 

If this option is selected then Neat Image will look for matching profiles in the folders of the input 
images. If you put desired noise profile to a folder with input images and select this option then Neat 
Image will select this profile for every image from that folder. If there are several profiles in such a 
folder then the best matching will be selected for every input image. 
 

Matching parameters priorities 

To automatically match profiles for the input image, Neat Image compares the device parameters of the 
input image and candidate profiles selected from the folder specified by the above options. Different 
parameters usually have to be matched with different priorities. Using Matching parameters priorities 
controls, you can select the priorities of such parameters as Input device, ISO rate, Compression, Resolution, 
Sharpness, Exposure: 

 Match – the parameter should match exactly; 
 High – it is highly important that the parameter is very close or matches exactly; 
 Low – it is preferable that the parameter is close or matches exactly; 
 Ignore – the parameter is not important at all. 

 

8.5. Filtration preferences 

Main window 

Auto restore on finish is to restore the application window (if it was minimized during processing) when all 
filtration tasks are done. 
 

Processing priority 

Use this option to adjust the priority to the Neat Image filtration process running in a multitasking 
environment: 

 Idle – lowest priority; filtration gives way to other applications when necessary; 
 

 Below – priority below normal; provides the smoothest performance for all applications; this 
may slow down Neat Image a bit, but will allow you to work normally with other applications, 
especially if the computer is slow; 
 

 Normal – normal priority; filtration may somewhat slow down other applications. 
 

8.6. Performance preferences 
The first group of settings in this tab selects the computing devices to be used for image processing. This 
group of settings is optional, it is shown only if at least one supported GPU (graphic processing unit) is 
available along with the regular CPU (central processing unit, or processor). This group includes the 
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following items: 

Use CPU only 

This option makes Neat Image perform all image processing using only CPU. 

Use GPU only 

This option makes Neat Image perform all image processing using only GPU. 

Use CPU and GPU 

If you select this option then Neat Image will process images using both CPU and GPU. 

 
Depending on individual performance of each computing device (CPU and GPU), each of the above 
options may be the most efficient. You can try different settings and measure the resulting speed using the 
Benchmark tool below. 

CPU 

Number of used cores 

This option adjusts the number of CPU cores used by Neat Image for processing. The number of used 
cores can go up to the total number of cores in all CPUs in your computer (like 2 cores in Core Duo, 4 
cores in Core Quad, 8 cores in a desktop version of i7 with enabled hyperthreading, etc.). If the 
computer includes two physical CPUs then the number of cores is correspondingly higher. Ideally, 
using all cores should provide the best overall performance. In some cases however, processing speed 
may be even higher if fewer cores are used (especially on CPUs with hyperthreading). For example, 
using fewer than all 8 virtual cores in i7 is in some cases faster, so you may want to test different values 
of this setting. 
 

GPU 

In this box, yon can specify which of the available computation-capable GPU devices (CUDA-capable 
NVIDIA cards and/or supported OpenCL-capable AMD/ATI cards) should be used for image 
processing (in addition to CPU or instead of CPU). When you have one or more GPUs, you can allow 
Neat Image to use it and specify how much GPU memory may be used for Neat Image’s image 
processing. When you also have other software using the GPU, you may want to reserve only a part of 
the GPU memory for Neat Image and leave the rest free for other purposes. In any case, you can try 
different values and see which setting gives the best results. 
 

Benchmark 

Use the Benchmark button to measure the image processing speed with the current settings specified in 
the CPU and GPU boxes. 
 

Optimize 

Use the Optimize… button to open a specialized dialog designed to measure image processing speeds 
achieved with different combinations of the CPU and GPU settings. It allows to automatically 
benchmark all possible combinations of settings and to identify the best combination. This is the easiest 
way to optimize the performance of Neat Image for specific CPU and GPU hardware. 
 

8.7. Folders preferences 

Profile folder 

Select the folder where Neat Image must look for device noise profiles. This should be the topmost 
folder of all the (sub)folders with device noise profiles. Neat Image will display all profiles (stored in all 
subfolders of the specified folder) in the popup menu in the Device noise profile panel of the application 
window and in other parts of Neat Image. 
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By default, the Profile folder is located in your Documents folder: 
  Documents\Neat Image Standalone\Profiles\ 

You can select another location to store and use your Neat Image profiles if you prefer. 
 

Preset folder 

Select the folder where Neat Image must look for filter presets. This should be the topmost folder of all 
the (sub)folders with filter presets. Neat Image will display all presets (stored in all subfolders of the 
specified folder) in the popup menu in the Filter Settings panel of the application window and in other 
parts of Neat Image. 

By default, the Preset folder is located in your Documents folder: 
  Documents\Neat Image Standalone\Presets\ 

You can select another location to store and use your Neat Image presets if you prefer. 

Temporary folder 

Select the folder that Neat Image must use to store its temporary files. 
 

8.8. Output preferences 

8.8.1. Save Settings 

Allow overwriting existing image files 

Enable this option to allow Neat Image overwrite existing image files when output images are auto 
saved by the application (for example, when Neat Image automatically processes multiple images). 
 

Preserve image metadata in output image files (when possible) 

Enable this option to make Neat Image preserve the EXIF, IPTC and other metadata by copying these 
from the input to output images. Note that copying the metadata to the output image is not always 
possible. This depends on both input and output file types used and on type of metadata as well. The 
EXIF data are copied with the following combinations of input and output file types: JPEG->JPEG, 
JPEG->TIFF, TIFF->TIFF, and TIFF->JPEG. The IPTC data are copied with the following 
combinations: JPEG->JPEG and TIFF->TIFF. 
 

Preserve original timestamp in output image files 

Enable this option to make Neat Image preserve the original image's file timestamp (the date and time 
when the image file was created and/or modified) by copying it from the input to the output image file. 
This will keep the output images in the same relative order as the input images when sorted by date and 
time. 

Important note: Do not enable this option if you use Neat Image as an external editor in Lightroom. 
Otherwise Lightroom will not recognize that the image has been successfully processed by Neat Image. 
 

Output bitdepth 

This option controls the bitdepth of the images processed by the filter. For example, if the input image 
has 8 bits per channel and the output bitdepth is selected to be 16 bits per channel, then the input image 
will be converted to 16-bit representation, processed with the filter, and the output image will be 16-bit. 
If ‘Match input’ is selected then the output bitdepth will match the input bitdepth. 
 

Output file name suffix 

Select the suffix added to the output image file name by default (to differentiate processed images from 
originals). Note that the suffix can be empty only if the Allow overwriting existing image files option is 
enabled (see above). 



User Guide Neat Image standalone (Win) 
  

  
© 1999-2013 Neat Image team, ABSoft. All rights reserved.  44 24-Oct-13

Auto save output images 

Enable this setting to let Neat Image automatically save output images when they are ready. 
 

Save filtered images to 

Folder(s) of input images 

Enable this option to save each output image beside the corresponding input image. 

Specified folder 

Enable this option and specify a folder to make Neat Image save all output images to that folder. 
 

Output file format 

Format 

Select the output file format to be used by default when the output image is saved by Neat Image. 
 

Quality / Compression 

Select the JPEG quality level (or PNG compression level) to be used by default when the output image 
is saved by Neat Image in the JPEG (or PNG) format. 
 

Auto remove completed tasks 

Enable this option to automatically remove from the list of tasks (or close) image filtration tasks that 
have been fully processed and saved. 
 

Use settings above to save output images (do not ask every time) 

Enable this option to make Neat Image automatically save output images using the settings from this 
Preferences tab. Neat Image will then silently save output images without opening the Save Settings 
dialog for every image. In this way you can set the desired output settings once here and not be asked to 
adjust them each time you save an output image. 

 

9. Command line version of Neat Image 
Besides the GUI (graphical user interface) version of Neat Image, there is also a separate command line 
(CL) version. It can also build noise profiles and filter one or more images. 

To see how to use the command line version of Neat Image, open Windows Command Prompt and 
execute the following command: 
 
    "C:\Program Files\Neat Image Standalone\NeatImageCL.exe"      (with the quote marks) 
 
or "C:\Program Files (x86)\Neat Image Standalone\NeatImageCL.exe" (for 32-bit NI in Win64) 
 
This will display the description of command line format of the CL version. Use the description to 
formulate new commands for the CL version. 

Please note that the CL version of Neat Image uses the settings specified in the Preferences of the GUI 
version. Therefore, if you want to adjust any of those settings please start the GUI version, adjust the 
settings and apply, close the GUI version, and then use the CL version. 
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10. Using Neat Image with Lightroom 
Neat Image standalone can be used with Lightroom in two different ways: 

1. You can manually save and load intermediate files to exchange images between Lightroom 
and Neat Image. 

2. Neat Image can be used via the "External Editor" facility available in Lightroom (this option is 
available with Home and Pro edition of Neat Image standalone, Demo will not work). 

 

To use the second method with either Home or Pro edition of Neat Image standalone you must set up 
Neat Image as an external editor in Lightroom using the following steps: 

1. In Lightroom, go to menu Edit | Preferences... | External Editing. 
In Additional External Editor box, click Choose and select NeatImage.exe (in C:\Program 
Files\Neat Image\). 

2. In the same Additional External Editor box, select 
File Format: TIFF; 
Bit Depth: 8 or 16 bits/component (depending on your images); 
Adjust Color Space, Resolution and Compression as desired. 

3. In the top of the Additional External Editor box, click the Preset drop-down and select the option: 
Save Current Settings as New Preset. 
Enter the name "Neat Image" and click the Create button. 

4. Click OK to save changes. 
 

From now on, you can use Neat Image as an external editor using the following steps: 

1. Go to menu Photo (or right-click the image) and select Edit In > Neat Image. 

2. In the Edit Photo with Neat Image dialog, select Edit a Copy or Edit a Copy with Lightroom Adjustments 
and uncheck Stack with original; then click Edit. 
 
Lightroom will then save the image into a new TIFF file and invoke Neat Image for that file.  
Please note that image will be converted to specified format (for example, to 16-bit TIFF, if 
that was specified above) only when you select "Copy with Lightroom Adjustments", otherwise 
Lightroom will just copy the original image file. 
 
Neat Image will add that new file as a new image filtration task and it will appear in the list of 
tasks in Neat Image. If Neat Image has been already running, you may need to select that new 

task in the list and click   (the Edit selected filtration task button) or use the Task > Edit… 
menu item. 

3. Process the image using the regular Neat Image workflow (see the section Filtration process 
details, page 9, for more details). 
 
In the end of the workflow, save the filtered image into the same TIFF file overwriting the 
input image file (the file exported by Lightroom to Neat Image for processing). 
 
Note: to facilitate overwriting input images, adjust the output settings in Neat Image 
Preferences: go to menu Tools > Preferences > Output, make the Output file name suffix field empty 
and enable the Allow overwriting existing image files option. 

4. Close Neat Image. 

5. You are now back in Lightroom and the TIFF image filtered by Neat Image is now also 
returned to Lightroom. You can further work with that new image in your regular workflow. 
 

Please note that you can also send several images to Neat Image instead of just one. To do that, select 
the files you want to process and follow steps 1-5 above. 
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11. Examples 

11.1. Images to build a noise profile 
The image below contains examples of areas that are “good” and “bad” from the standpoint of profiling. 
Here, “good” image areas are highlighted in green, these should be at least 32x32 pixels large, 
preferably more than 128x128 pixels; “bad” ones are highlighted in red. If the input image you have 
does contain similar ‘good’ flat featureless noise-only areas as shown in the example then you can be 
sure that automatic profiling will produce an accurate noise profile. However if there are no such flat 
featureless areas in the input image, then automatic profiling will not work well with the image because 
building a profile using an area with details produces an inaccurate profile that will then lead to very 
inaccurate filtration. In such a case, you have to use either an alternative image with flat featureless 
areas or to use the Calibration Target to produce test images with flat featureless areas. 

 

Additional comments regarding the “good” and “bad” areas in this example are available on the next page.
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These image areas are good to build device noise profiles, as they contain no visible details: 

 

– GOOD, because this area contains no important details 

  

 

– GOOD, no important details (this area is from another image)

 

Examples of “bad” areas that contain visible details: 

 

 – NOT RECOMMENDED, because this area contains a 
detail: corner – junction of wall and ceiling 

  

 

 – UNACCEPTABLE, because this area contains many details 

  

 

 – NOT RECOMMENDED, because this area contains some 
details: clouds (this area is from another image) 

 

 

See more examples of building noise profiles on the Neat Image web page: 
http://www.neatimage.com/win/standalone/profiling.html 
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11.2. Filtration results 
Here are some examples of Neat Image performance. 

Input Output 

  

This is a small portion of a digital photo taken with a compact digital camera. The original image 
contains easily visible noise. In this case, the source of noise is the camera's image sensor (CCD) 
working in high ISO mode. 

 

Input Output 

  

This image was also taken with a digital camera. Along with the strong high ISO noise, there is an 
image degradation caused by the JPEG compression. Even though Neat Image tries to do its best to 
clean up such images, please avoid using strong JPEG compression. 

See more filtration examples in the Neat Image web page: 
 http://www.neatimage.com/win/standalone/examples.html 
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12. Questions and answers 

12.1. General questions 

Q What is the difference between Demo, Home and Pro editions of Neat Image? 

A The Demo edition of Neat Image has some of the functionality disabled. In particular, it does not save 
images in TIFF, PNG and BMP formats and does not copy output image to the clipboard (the Demo 
edition only saves images in JPEG with fixed quality). Non-Demo editions do not have those 
limitations. Please see the Detailed feature map, page 52, for more details. 

Q Should I uninstall Demo prior to installing Home / Pro edition? 

A This is not necessary. However, you will not need Demo anymore because you are installing a 
non-Demo edition, which has all the functionality of Demo plus more. To uninstall Demo, use the 
Uninstall shortcut in the Windows Start menu: Start menu > Programs > Neat Image Standalone > Uninstall. 
That will remove Demo. 

Q Should I uninstall the older version of Neat Image prior to installing a newer one? 

A Yes, please uninstall the older version of Neat Image and only after that proceed to install a newer 
version. This will ensure that important files are not mixed up. 

Q I think I have found a bug. How can I submit a bug report? 

A Please use the online bug report form ( http://www.neatimage.com/win/standalone/brf.html ) to let us 
know all the details necessary to reproduce the problem. 
 
See more information about bugs in the Issues and bugs subsection, page 51, and about bug fixes in the 
WhatsNew.txt  file supplied with the software – use the Help > What’s New menu item to open that file 
(also see the history section on the Neat Image web page for the most up to date information: 
http://www.neatimage.com/win/standalone/history.html ). 

Q What about batch processing? 

A Neat Image supports batch processing. Please see the Batch processing section, page 33. 

12.2. Filtration-related questions 

Q Why do I receive some crystal-like artifacts in the filtered image? 

A Presence of many residual noise elements is usually a consequence of using a poorly built noise profile 
or a profile built for another device and/or device mode. The crystal-like artifacts (usually these are the 
residual JPEG compression artifacts) look like thin lines in the filtered image. They can be easily 
eliminated by increasing the high frequency noise level in the filter settings. 

Q Filtered image looks 'plastic'. Why? 

A The reason is that too much filtration was applied. Let Neat Image keep some noise to produce 
natural-looking results. Adjust the noise reduction amounts; for example, reduce the noise reduction 
amount in the luminance (Y) channel to 50-70%. Also, make sure the device noise profile does match 
the input image. Using an incorrectly chosen or poorly built profile can either produce plastic-looking 
results or leave residual artifacts (see the previous question). 

Q What is frequency? 

A The term (spatial) frequency is used in Neat Image to denote image elements (both important details 
and noise) of certain size. 

High frequency corresponds to image elements of smallest size. Medium (mid) 
frequency corresponds to elements of medium size. Low frequency corresponds to 
image elements of (relatively) large size. For reference, see the noise samples of 
different frequencies in the Noise Filter Settings tab of the Filtration Task Editor.  
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Q The filtration process is not very fast, is this normal? 

A This is normal, because the filtration algorithm is quite complex. We work on further optimization to 
provide better performance. 

Q Is the input image automatically changed according to the profile that is being opened? 

A The input image is NEVER changed. Neat Image always creates a new output image, which contains 
the filtration results. The output image can be saved to any file. 

Q How to filter only the color noise (not the brightness noise)? 

A Set the value of the luminance (Y) channel noise reduction amount to 0%. This will disable filtration in 
the luminance (brightness) channel. 

Q What is YCrCb? 

A YCrCb is the name of a family of color spaces widely used in digital imaging, television, image 
compression (e.g., the JPEG compression transform RGB images into the YCrCb space to efficiently 
compress image data), etc. In 'YCrCb', 'Y' corresponds to the luminance channel, 'Cr' - to the Cr 
chrominance channel covering the red to blue-green color range, 'Cb' - to the Cb chrominance channel 
covering the blue to yellow color range. Because this space enables easy separation of the luminance 
and chrominance information, it is very suitable to conduct noise reduction. 

Q Is processing via Neat Image best done before or after any other processing (i.e. tonal/color 
correction)? 

A Such operations as tonal/color correction are quite conservative from the standpoint of noise, i.e., they 
do not significantly change the noise characteristics of the image. Therefore, filtering before or after is 
about the same as long as the noise profile is built and applied at the same stage of image processing. 
For example, do not use a device noise profile built with an unprocessed (with the color correction not 
yet applied) image to filter a processed image. 
 
Some digital cameras apply some color correction internally. Other cameras allow access to 
unprocessed RAW data. Neat Image is a generic filter, which can be applied in both cases. The only 
requirement is to build and use a noise profile in the same point of the post-processing workflow. 
 
On the other hand, image sharpening applied to a noisy image makes it much noisier. It is best to apply 
Neat Image filtration before sharpening. However, the sharpening and noise filters of Neat Image itself 
can be used together because Neat Image's sharpening is applied AFTER its noise filtration. 
 
If you are not sure, try to use Neat Image as close to the source of the input image as possible.
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13. Tips and tricks 

13.1. Preventing banding 
In some cases, the banding effect may appear when applying the noise filter to images with faint 
brightness gradients. This effect is quite rare for normal images, especially when viewed on a true color 
display. 

To avoid banding, try to reduce the noise reduction amount for the high frequency component to 50%. 

Another option is to process the image in higher bitdepth. 

13.2. Filtration of shadow areas 
In some situations, it is preferable to filter only the shadow areas of images leaving bright areas intact. 
You can do this with the standalone Neat Image by using the noise profile equalizer to limit or stop 
filtration of bright image areas. 

The graph nodes in the noise profile equalizer correspond to particular ranges of brightness 
(individually for each color channel) of the RGB color space. The position of each node reflects the 
noise level in the corresponding range of brightness. So, the lower a node, the less filtration will 
eventually be applied to image elements that belong to the corresponding range of brightness. 

Therefore, to filter only shadows you can manually move all the 'bright' nodes down (refer to the 
gradients in the bottom of the noise profile equalizer to see which brightness level they correspond to). 
For example, move down all but the three ‘darkest’ nodes in each RGB channel. 

Using this method, you can effectively prevent filtration of the bright image areas. 

13.3. Partial filtration 
Some images contain both noisy and clean areas and it may be preferable to filter only noisy areas. This 
can be manually done by combining two images – original and filtered one – in an image editor. For 
example, the following steps can be used: 

1. Filter the input image in Neat Image (so that noisy areas are cleaned) and save the output image 
to a new file; 

2. Open this new file in your image editor; 
3. Place the filtered image in a new layer on top of the original image; 
4. Adjust the transparency of the top layer so that noisy areas look fine; 
5. Select and delete the areas of the top layer where filtration is not necessary or excessive (you 

may want to use the eraser tool with adjustable transparency and shape). 
 

14. Information 

14.1. Issues and bugs 
We try to keep Neat Image as free of bugs as possible. Please report any bugs or issues (even those 
already reported before) you encounter while working with Neat Image. Use the online bug report form 
on the Neat Image web page: http://www.neatimage.com/win/standalone/brf.html . Your feedback will 
greatly help us to improve the software and provide you with even better versions of Neat Image. 

14.2. Plans 
The current version of Neat Image is the result of our ongoing research on noise filtration. We continue 
to work on the core noise reduction algorithms to improve the quality and speed of noise reduction. 

Please let us know if you have ideas that can make Neat Image better. Participate in the discussion on 
the Neat Image community forum, express your opinion, make suggestions, and ask questions. The 
more people that ask for a feature the more likely it is that it will be implemented. 
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14.3. Detailed feature map 
Edition 

Features 
Demo Home Pro 

  8 bit/channel (24-bit RGB,   8-bit Grayscale) + 
16 bit/channel (48-bit RGB, 16-bit Grayscale) – + 

Image 
processing 

32 bit/channel (96-bit RGB, 32-bit Grayscale) – + 
 

Standalone version of the filter + 
Maximum batch size 10 100 unlimited 
Command line support in GUI version – + 
Command line version + + 

JPEG 8 bits/channel +/+
1
 +/+ 

8 bits/channel +/–
2
 +/+ TIFF: 

single image, no layers, 
no alpha channel, no mask 16 / 32 bits/channel +/– +/– +/+ 

BMP: uncompressed, Win3x 8 bits/channel +/– +/+ 
8 bits/channel +/– +/+ 

PNG 
16 bits/channel +/– +/– +/+ 

Windows clipboard 8 bits/channel +/– +/+ 
Drag and drop (from Windows Explorer) – + 

Workflow 

Preserving image EXIF data in processed files
3
 – + 

 

Automatic profiling of cameras and scanners + 
Manual profiling of any imaging devices + 

Device 
noise 
profiles Automatic matching profiles to input images + 

Channel-wise (Y, Cr, Cb) + Noise 
reduction Frequency-wise (High, Mid, Low, Very low) + 

Channel-wise (Y, Cr, Cb) + Smart 
sharpening Frequency-wise (High, Mid, Low) + 
Filter presets (reusable filter settings) + 

 

14.4. Contacts 
We really appreciate your opinion of Neat Image. Please let us know what you think about out software. 
Feel free to ask questions regarding Neat Image. To share your opinion or to receive support regarding 
Neat Image, use any of the following means: 

E-mails 

 info@neatimage.com — for general inquiries 

 standalone-win@neatimage.com — for any inquiries regarding use of Neat Image standalone 

 sales@neatimage.com — for any inquiries regarding purchase of Neat Image software 

Community Forum 

Register in Neat Image community forum ( http://www.neatimage.net/forum/ ), and participate in 
discussions on the use and development of Neat Image. Such topics are covered in the forum as: 

 announcements of new and updated versions of the software; 
 questions about use of Neat Image; 
 examples of Neat Image performance with comments and suggestions; 
 feedback from the users: suggestions of new features and improvements; 
 polls: what OS, processor, camera types are used with Neat Image; 
 contacts and general comments. 

Web page 

http://www.neatimage.com/win/standalone/ 
                                                           
1
 The JPEG compression level is set to a fixed high quality value in Demo edition. 

2
 Here, +/– means input is supported and output is not. 

3
 Whenever possible. Please see "Preserve image metadata in output image files" in page 43 for more details. 
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14.5. Legal information 

Copyright 

Neat Image © 1999-2013 Neat Image team, ABSoft. All rights reserved. 

License agreement 

By downloading and/or using the Neat Image standalone (Win) software (called “Neat Image” hereunder in this 
agreement) you indicate that you accept this license agreement. If you are unable or unwilling to accept this license 
agreement then you may not use Neat Image and must return and/or destroy all copies of Neat Image in your 
possession. 

You may 

Use Neat Image Demo edition free of charge for non-commercial purposes only. 

Copy and distribute Neat Image Demo edition. 

Run Neat Image Home or Pro on one (or more, up to the number specified in the license) computer (computers) at 
a time for commercial and other purposes provided you are a registered user and you have a valid license for the 
corresponding edition of the Neat Image software. 

You may not 

Sublicense, rent, lease and sell any version or edition of the Neat Image software or any portion of it including the 
license data without the explicit written permission from the Neat Image team, ABSoft. 

Copy, share and distribute the Home and Pro edition of the Neat Image software or any portion of it including the 
license data without the explicit written permission from the Neat Image team, ABSoft. 

Decompile, disassemble, reverse engineer, modify, clone and emulate any version or edition of the Neat Image 
software or any portion of it including the license data. 

Use the Home and Pro edition of the Neat Image software if you are not registered user. 

Term and termination 

If you are a registered user of Neat Image Home or Pro edition and you have purchased a license for a certain major 
version and edition of Neat Image then you may use the same major version (including all minor updates of that 
major version) and edition of the software without time limitations provided you observe this license agreement. 

A license for a certain major version of the Neat Image software may be extended to a higher major version. By 
decision of the Neat Image team, ABSoft, this extension may be automatic and free or may involve an upgrade fee. 

You may terminate this license agreement at any time by returning or destroying all copies of Neat Image in your 
possession and notifying the Neat Image team. 

This license agreement will terminate immediately if you infringe upon the Neat Image team, ABSoft’s copyrights 
or breach this agreement. Copyright infringement or breaching this agreement may also result in criminal or civil 
prosecution. 

Disclaimer of warranty 

The authors make no warranty or representation, either express or implied, with respect to this software, its quality, 
accuracy, merchantability, or fitness for a particular purpose. This software is provided "as is", and you, its user, 
assume the entire risk as to its quality and accuracy. 

Distribution 

Neat Image Demo edition may be distributed unmodified provided any charge is to cover distribution costs only. 

Neat Image Demo edition may be placed on magazine CDs as long as the Neat Image team is informed. 

14.6. Registration 
To become a registered user and to get a fully functional edition of Neat Image standalone (Home or Pro 
edition) you have to purchase a Neat Image license (a single- or multi-user license). You can purchase a 
license online. Please find the detailed information in the purchase section of the Neat Image web page: 
http://www.neatimage.com/win/standalone/purchase.html 

After you have purchased a Neat Image license, you receive an e-mail from the Neat Image team with 
detailed download and registration instructions. These instructions will help you download and become 
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a registered user of the Neat Image software. 

By becoming a registered user of Neat Image you will: 

 Encourage the authors to further develop and improve Neat Image; 
 Get access to all functions of Neat Image that are disabled in the Demo edition (see the Detailed 

feature map, page 52); 
 Be able to use Neat Image for commercial and other purposes; 
 Get free updates of the software (minor modifications with the same major version number, for 

example, updates from the current version to any v6.x); 
 Enjoy reduced upgrade prices for new major future modifications of Neat Image or will get a free 

upgrade; 
 Receive the priority support from Neat Image support group; 
 Receive the priority attention of Neat Image development group 

(tell us what you want to see in the next version). 

 

Message from the Neat Image team 

By becoming a registered user you are helping us to further develop and improve the software. 

Become a registered user and we will make Neat Image better for you! 

14.7. Acknowledgments 
Neat Image utilizes the IJG JPEG library developed by the Independent JPEG Group. 
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 Neat Image team, ABSoft 
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